summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422019-02-06 18:00:01 +0100
committerSkycoder422019-02-06 18:00:01 +0100
commitce5ddf32a9c44f1d500fe374d7e50f76f89937ed (patch)
tree593acb0cbc58959f0e8731083722a650d5f712be
parentfe42e87241f4766f6dedf40c10c0753e6549bf69 (diff)
downloadaur-ce5ddf32a9c44f1d500fe374d7e50f76f89937ed.tar.gz
patch missing includes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--missing-headers.patch13
3 files changed, 23 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc25fc6bc1e3..9301924e3058 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-jsonserializer
pkgdesc = A library to perform generic seralization and deserialization of QObjects
pkgver = 3.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Skycoder42/QtJsonSerializer
arch = i686
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = qt5-jsonserializer
depends = qt5-base
optdepends = repkg: Automatically rebuild the package on dependency updates
source = qt5-jsonserializer-3.3.0::git+https://github.com/Skycoder42/QtJsonSerializer.git#tag=3.3.0
+ source = missing-headers.patch
source = qt5-jsonserializer.rule
sha256sums = SKIP
+ sha256sums = 37e13775a69ead1e6f4a9ce34bccff519c39e929499e5f7728252e0fc115a3e8
sha256sums = 1b52eef5216017cfb4b399df1775950db544550a68a542053efe00eb8ef34911
pkgname = qt5-jsonserializer
diff --git a/PKGBUILD b/PKGBUILD
index 7fe10d069ed7..709dd9a1ddd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=qt5-jsonserializer
pkgname=(qt5-jsonserializer qt5-jsonserializer-doc)
group=qt5-jsonserializer-full
pkgver=3.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="A library to perform generic seralization and deserialization of QObjects"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtJsonSerializer"
@@ -13,8 +13,10 @@ makedepends=('git' 'qt5-tools' 'python' 'doxygen' 'graphviz')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
source=("$_pkgfqn::git+https://github.com/Skycoder42/QtJsonSerializer.git#tag=$pkgver"
+ "missing-headers.patch"
"$pkgname.rule")
sha256sums=('SKIP'
+ '37e13775a69ead1e6f4a9ce34bccff519c39e929499e5f7728252e0fc115a3e8'
'1b52eef5216017cfb4b399df1775950db544550a68a542053efe00eb8ef34911')
prepare() {
@@ -22,6 +24,10 @@ prepare() {
}
build() {
+ cd "$_pkgfqn"
+ git apply ../missing-headers.patch
+ cd ..
+
cd build
qmake "../$_pkgfqn/"
diff --git a/missing-headers.patch b/missing-headers.patch
new file mode 100644
index 000000000000..d04d2879af6e
--- /dev/null
+++ b/missing-headers.patch
@@ -0,0 +1,13 @@
+diff --git a/src/jsonserializer/qjsonserializer.h b/src/jsonserializer/qjsonserializer.h
+index 4e2f54f..3fff0e4 100644
+--- a/src/jsonserializer/qjsonserializer.h
++++ b/src/jsonserializer/qjsonserializer.h
+@@ -21,6 +21,8 @@
+ #include <QtCore/qlinkedlist.h>
+ #include <QtCore/qvector.h>
+ #include <QtCore/qset.h>
++#include <QtCore/qqueue.h>
++#include <QtCore/qstack.h>
+ #include <QtCore/qhash.h>
+ #include <QtCore/qmap.h>
+