summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-11-11 13:06:03 +0100
committerSkycoder422017-11-11 13:06:03 +0100
commite31a08cfd2157d485a0d634a4c43860cd0af9b30 (patch)
treec07c178a4a2e2bcbd409709fccac29fd4a7bbd78
parentfee027e3287b20787629fe6085c90516b61d2cd0 (diff)
downloadaur-e31a08cfd2157d485a0d634a4c43860cd0af9b30.tar.gz
Updated to 3.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e346e30a00e..4a1d2770a975 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = qt5-jsonserializer
pkgdesc = A library to perform generic seralization and deserialization of QObjects
- pkgver = 3.0.0
- pkgrel = 2
- url = https://github.com/Skycoder42/QJsonSerializer
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://github.com/Skycoder42/QtJsonSerializer
arch = i686
arch = x86_64
license = BSD
@@ -10,7 +10,7 @@ pkgbase = qt5-jsonserializer
makedepends = qt5-tools
depends = qt5-base
optdepends = repkg: Automatically rebuild the package on dependency updates
- source = qt5-jsonserializer-3.0.0::git+https://github.com/Skycoder42/QJsonSerializer.git#tag=3.0.0-2
+ source = qt5-jsonserializer-3.1.0::git+https://github.com/Skycoder42/QtJsonSerializer.git#tag=3.1.0
source = qt5-jsonserializer.rule
sha256sums = SKIP
sha256sums = 2147916eaeebda7109b04f17e122a873388f42f2015e4b6b9fbf6f98e8e80d15
diff --git a/PKGBUILD b/PKGBUILD
index bf9d72f81bd4..9a6843e7714a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-jsonserializer
-pkgver=3.0.0
-pkgrel=2
+pkgver=3.1.0
+pkgrel=1
pkgdesc="A library to perform generic seralization and deserialization of QObjects"
arch=('i686' 'x86_64')
-url="https://github.com/Skycoder42/QJsonSerializer"
+url="https://github.com/Skycoder42/QtJsonSerializer"
license=('BSD')
depends=('qt5-base')
makedepends=('git' 'qt5-tools')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
-source=("$_pkgfqn::git+https://github.com/Skycoder42/QJsonSerializer.git#tag=$pkgver-2" #temporary fix for Qt 5.9.2
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtJsonSerializer.git#tag=$pkgver"
"$pkgname.rule")
sha256sums=('SKIP'
'2147916eaeebda7109b04f17e122a873388f42f2015e4b6b9fbf6f98e8e80d15')
@@ -22,7 +22,8 @@ prepare() {
build() {
cd build
- qmake -r "../$_pkgfqn/"
+ qmake "../$_pkgfqn/"
+ make qmake_all
make
}