summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCian Mc Govern2020-01-05 00:04:24 +0000
committerCian Mc Govern2020-01-05 00:04:24 +0000
commit7e27abe1537990288018489c2e0aec4cb985ce52 (patch)
treeebace151c47de322e06a29c49c1d1540f678579d
downloadaur-7e27abe1537990288018489c2e0aec4cb985ce52.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92e253163874
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qt5-location-595
+ pkgdesc = Provides access to position, satellite and area monitoring classes
+ pkgver = 5.9.5
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = gconf
+ depends = qt5-declarative-595
+ source = http://download.qt.io/official_releases/qt/5.9/5.9.5/submodules/qtlocation-opensource-src-5.9.5.tar.xz
+ sha256sums = 41f0390e1709140e3590bed434e63ec00406fac2051529c400c756acbb70a80e
+
+pkgname = qt5-location-595
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..550d1c92e845
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Cian McGovern <cian@cianmcgovern.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=qt5-location-595
+_qtver=5.9.5
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='Provides access to position, satellite and area monitoring classes'
+depends=('qt5-declarative-595')
+makedepends=('gconf')
+_pkgfqn="qtlocation-opensource-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('41f0390e1709140e3590bed434e63ec00406fac2051529c400c756acbb70a80e')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ QT_BASE_DIR=/opt/qt595
+ export QTDIR=$QT_BASE_DIR
+ export PATH=$QT_BASE_DIR/bin:$PATH
+ cd build
+
+ qmake ../${_pkgfqn}
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/opt/qt595/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/opt/qt595/share/licenses
+ ln -s /opt/qt595/share/licenses/qt5-base "$pkgdir"/opt/qt595/share/licenses/${pkgname}
+}