aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2015-10-18 18:38:22 +0300
committerDāvis2015-10-18 18:38:22 +0300
commit93e492e356fef1130b8560730048e2b565a38b16 (patch)
treec25c438188b133a85674c8382b599bddb82ce231
downloadaur-qt5-location-git.tar.gz
Release qt5-location-git
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--README.md2
-rw-r--r--UNLICENSE24
5 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55a23e5cc4aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qt5-location-git
+ pkgdesc = Provides access to position, satellite and area monitoring classes
+ pkgver = v5.6.0.alpha1.r31.gf87ba04
+ pkgrel = 1
+ url = https://code.qt.io/cgit/qt/qtlocation.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ depends = qt5-declarative-git
+ depends = geoclue
+ provides = qt5-location
+ conflicts = qt5-location
+ source = qt5-location::git+https://code.qt.io/qt/qtlocation.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = qt5-location-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f5d547779e75
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.tar*
+/qt5-location/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a50b1a069fc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+
+_pkgname=qt5-location
+pkgname=$_pkgname-git
+pkgver=v5.6.0.alpha1.r31.gf87ba04
+pkgrel=1
+pkgdesc='Provides access to position, satellite and area monitoring classes'
+arch=('i686' 'x86_64')
+url='https://code.qt.io/cgit/qt/qtlocation.git'
+license=('GPL3' 'LGPL')
+depends=('qt5-declarative-git' 'geoclue')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://code.qt.io/qt/qtlocation.git#branch=dev")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/build"
+
+ qmake "../$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 $srcdir/$_pkgname/LGPL_EXCEPTION.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LGPL_EXCEPTION.txt
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..796f1975acea
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# qt5-location-git
+
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>