aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2015-10-18 22:30:43 +0300
committerDāvis2015-10-18 22:30:43 +0300
commit22af5c0520f758cbf908d732d9a1e7160d0d6fed (patch)
tree2125de244f0886b456c857bdb0c7a0ea4d7420d9
downloadaur-qt5-multimedia-git.tar.gz
Release qt5-multimedia-git
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
-rw-r--r--README.md1
-rw-r--r--UNLICENSE24
5 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28508a22f48f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qt5-multimedia-git
+ pkgdesc = Classes for audio, video, radio and camera functionality
+ pkgver = v5.6.0.alpha1.r29.g318159c
+ pkgrel = 1
+ url = https://code.qt.io/cgit/qt/qtmultimedia.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ depends = qt5-declarative-git
+ depends = libpulse
+ depends = gst-plugins-base-libs
+ depends = openal
+ optdepends = gst-plugins-bad: Qt MediaService plugin
+ provides = qt5-multimedia
+ conflicts = qt5-multimedia
+ source = qt5-multimedia::git+https://code.qt.io/qt/qtmultimedia.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = qt5-multimedia-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9be0eb6645b4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar*
+/qt5-multimedia/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d43aeaf8429
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+
+_pkgname=qt5-multimedia
+pkgname=$_pkgname-git
+pkgver=v5.6.0.alpha1.r29.g318159c
+pkgrel=1
+pkgdesc='Classes for audio, video, radio and camera functionality'
+arch=('i686' 'x86_64')
+url='https://code.qt.io/cgit/qt/qtmultimedia.git'
+license=('GPL3' 'LGPL')
+depends=('qt5-declarative-git' 'libpulse' 'gst-plugins-base-libs' 'openal')
+optdepends=('gst-plugins-bad: Qt MediaService plugin')
+makedepends=("git")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://code.qt.io/qt/qtmultimedia.git#branch=dev")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/build"
+
+ qmake "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 $srcdir/$_pkgname/LGPL_EXCEPTION.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LGPL_EXCEPTION.txt
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..37585168a13d
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+# qt5-multimedia-git
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>