summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422018-03-14 20:17:57 +0100
committerSkycoder422018-03-14 20:17:57 +0100
commite037bc89b9ef53d36a5772b9f659061b17167e0f (patch)
tree92b414c70ee1fd6b75562c7cb1a9a81f9985ea6f
downloadaur-e037bc89b9ef53d36a5772b9f659061b17167e0f.tar.gz
Create AUR package at version 1.0.1
-rw-r--r--.SRCINFO64
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD160
-rw-r--r--qt5-mvvmcore.rule1
-rw-r--r--qt5-mvvmdatasynccore.rule1
-rw-r--r--qt5-mvvmdatasyncquick.rule1
-rw-r--r--qt5-mvvmdatasyncwidgets.rule1
-rw-r--r--qt5-mvvmquick.rule1
-rw-r--r--qt5-mvvmwidgets.rule1
9 files changed, 231 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a156c51bdfc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,64 @@
+pkgbase = qt5-mvvm
+ pkgdesc = A mvvm oriented library for Qt, to create Projects for Widgets and Quick in parallel
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/Skycoder42/QtMvvm
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = qt5-tools
+ makedepends = qt5-quickcontrols2
+ makedepends = qt5-graphicaleffects
+ makedepends = qt5-datasync
+ makedepends = git
+ makedepends = qpmx-qpmsource
+ makedepends = python
+ makedepends = doxygen
+ makedepends = graphviz
+ depends = qt5-base
+ depends = qt5-svg
+ optdepends = repkg: Automatically rebuild the package on dependency updates
+ source = qt5-mvvm-1.0.1::git+https://github.com/Skycoder42/QtMvvm.git#tag=1.0.1
+ source = qt5-mvvmcore.rule
+ source = qt5-mvvmwidgets.rule
+ source = qt5-mvvmquick.rule
+ source = qt5-mvvmdatasynccore.rule
+ source = qt5-mvvmdatasyncwidgets.rule
+ source = qt5-mvvmdatasyncquick.rule
+ sha256sums = SKIP
+ sha256sums = 2147916eaeebda7109b04f17e122a873388f42f2015e4b6b9fbf6f98e8e80d15
+ sha256sums = c69a4d6f324019d30a6f3d5dac00760af670c8f14b5064e6f4c08072a34ab5b8
+ sha256sums = 1a1ad4f7468f0b78cbe64e4a25f6ecbba2e6d94c79c4aecc54ca23f45fc791d7
+ sha256sums = 312675fe1ef88356119d62b9c4e4f481b21b189bc1d32954ecdeb88c73eba382
+ sha256sums = 9d14762455458b3bb414c714dbdc572212cf2c3e2cd6e6719c855ab9ec210191
+ sha256sums = 9d14762455458b3bb414c714dbdc572212cf2c3e2cd6e6719c855ab9ec210191
+
+pkgname = qt5-mvvmcore
+
+pkgname = qt5-mvvmwidgets
+ depends = qt5-mvvmcore
+ optdepends =
+
+pkgname = qt5-mvvmquick
+ depends = qt5-mvvmcore
+ depends = qt5-quickcontrols2
+ depends = qt5-graphicaleffects
+ optdepends =
+
+pkgname = qt5-mvvmdatasynccore
+ depends = qt5-mvvmcore
+ depends = qt5-datasync
+ optdepends =
+
+pkgname = qt5-mvvmdatasyncwidgets
+ depends = qt5-mvvmdatasynccore
+ optdepends =
+
+pkgname = qt5-mvvmdatasyncquick
+ depends = qt5-mvvmdatasynccore
+ optdepends =
+
+pkgname = qt5-mvvm-doc
+ depends = qt5-mvvmcore
+ optdepends =
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67e6a491370c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,160 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgbase=qt5-mvvm
+pkgname=(qt5-mvvmcore qt5-mvvmwidgets qt5-mvvmquick qt5-mvvmdatasynccore qt5-mvvmdatasyncwidgets qt5-mvvmdatasyncquick qt5-mvvm-doc)
+group=qt5-mvvm
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A mvvm oriented library for Qt, to create Projects for Widgets and Quick in parallel"
+arch=('i686' 'x86_64')
+url="https://github.com/Skycoder42/QtMvvm"
+license=('BSD')
+depends=('qt5-base' 'qt5-svg')
+makedepends=('qt5-tools' 'qt5-quickcontrols2' 'qt5-graphicaleffects' 'qt5-datasync' 'git' 'qpmx-qpmsource' 'python' 'doxygen' 'graphviz')
+optdepends=("repkg: Automatically rebuild the package on dependency updates")
+_pkgfqn=$pkgbase-$pkgver
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtMvvm.git#tag=$pkgver"
+ "${pkgbase}core.rule"
+ "${pkgbase}widgets.rule"
+ "${pkgbase}quick.rule"
+ "${pkgbase}datasynccore.rule"
+ "${pkgbase}datasyncwidgets.rule"
+ "${pkgbase}datasyncquick.rule")
+sha256sums=('SKIP'
+ '2147916eaeebda7109b04f17e122a873388f42f2015e4b6b9fbf6f98e8e80d15'
+ 'c69a4d6f324019d30a6f3d5dac00760af670c8f14b5064e6f4c08072a34ab5b8'
+ '1a1ad4f7468f0b78cbe64e4a25f6ecbba2e6d94c79c4aecc54ca23f45fc791d7'
+ '312675fe1ef88356119d62b9c4e4f481b21b189bc1d32954ecdeb88c73eba382'
+ '9d14762455458b3bb414c714dbdc572212cf2c3e2cd6e6719c855ab9ec210191'
+ '9d14762455458b3bb414c714dbdc572212cf2c3e2cd6e6719c855ab9ec210191')
+
+prepare() {
+ mkdir -p build
+
+ cd "$_pkgfqn"
+}
+
+build() {
+ cd build
+
+ qmake "../$_pkgfqn/"
+ make qmake_all
+ make
+ make lrelease
+ make doxygen
+}
+
+package_qt5-mvvmcore() {
+ cd build
+ cd src/mvvmcore
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../imports/mvvmcore
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../../..
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgbase/LICENSE"
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+}
+
+package_qt5-mvvmwidgets() {
+ depends=('qt5-mvvmcore')
+ optdepends=()
+
+ cd build
+ cd src/mvvmwidgets
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../..
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+}
+
+package_qt5-mvvmquick() {
+ depends=('qt5-mvvmcore' 'qt5-quickcontrols2' 'qt5-graphicaleffects')
+ optdepends=()
+
+ cd build
+ cd src/mvvmquick
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../imports/mvvmquick
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../../..
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+}
+
+package_qt5-mvvmdatasynccore() {
+ depends=('qt5-mvvmcore' 'qt5-datasync')
+ optdepends=()
+
+ cd build
+ cd src/mvvmdatasynccore
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../imports/mvvmdatasynccore
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../../..
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+ # Install mimetype
+ install -D -m644 "../$_pkgfqn/src/mvvmdatasynccore/application-x-datasync-account-data.xml" "$pkgdir/usr/share/mime/packages/application-x-datasync-account-data.xml"
+}
+
+package_qt5-mvvmdatasyncwidgets() {
+ depends=('qt5-mvvmdatasynccore')
+ optdepends=()
+
+ cd build
+ cd src/mvvmdatasyncwidgets
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../..
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+}
+
+package_qt5-mvvmdatasyncquick() {
+ depends=('qt5-mvvmdatasynccore')
+ optdepends=()
+
+ cd build
+ cd src/mvvmdatasyncquick
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../imports/mvvmdatasyncquick
+ make INSTALL_ROOT="$pkgdir" install
+ cd ../../..
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+}
+
+package_qt5-mvvm-doc() {
+ depends=('qt5-mvvmcore')
+ optdepends=()
+
+ cd build/doc
+ make INSTALL_ROOT="$pkgdir" install
+
+ # DROP file paths from doc tags
+ find "$pkgdir/usr/share/doc/qt" -type f -name '*.tags' \
+ -exec sed -i -e 's:<path>[^<]*<\/path>:<path>/usr/include/qt/QtMvvm</path>:g' {} \;
+}
diff --git a/qt5-mvvmcore.rule b/qt5-mvvmcore.rule
new file mode 100644
index 000000000000..5317ab13edbd
--- /dev/null
+++ b/qt5-mvvmcore.rule
@@ -0,0 +1 @@
+qt5-base
diff --git a/qt5-mvvmdatasynccore.rule b/qt5-mvvmdatasynccore.rule
new file mode 100644
index 000000000000..75268d24f075
--- /dev/null
+++ b/qt5-mvvmdatasynccore.rule
@@ -0,0 +1 @@
+qt5-mvvmcore qt5-datasync
diff --git a/qt5-mvvmdatasyncquick.rule b/qt5-mvvmdatasyncquick.rule
new file mode 100644
index 000000000000..ca07e57990e7
--- /dev/null
+++ b/qt5-mvvmdatasyncquick.rule
@@ -0,0 +1 @@
+qt5-mvvmdatasynccore
diff --git a/qt5-mvvmdatasyncwidgets.rule b/qt5-mvvmdatasyncwidgets.rule
new file mode 100644
index 000000000000..ca07e57990e7
--- /dev/null
+++ b/qt5-mvvmdatasyncwidgets.rule
@@ -0,0 +1 @@
+qt5-mvvmdatasynccore
diff --git a/qt5-mvvmquick.rule b/qt5-mvvmquick.rule
new file mode 100644
index 000000000000..f0eb68bd17ad
--- /dev/null
+++ b/qt5-mvvmquick.rule
@@ -0,0 +1 @@
+qt5-mvvmcore qt5-declarative qt5-quickcontrols2 qt5-graphicaleffects
diff --git a/qt5-mvvmwidgets.rule b/qt5-mvvmwidgets.rule
new file mode 100644
index 000000000000..4db9dfa28baa
--- /dev/null
+++ b/qt5-mvvmwidgets.rule
@@ -0,0 +1 @@
+qt5-mvvmcore