summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Egeberg2018-08-26 17:05:15 +0200
committerDaniel Egeberg2018-08-26 17:05:15 +0200
commit5001a1fc54025bc8e55836ec6fe44dd45eb0df0d (patch)
treefaf96f71796274a4fb1625cfa6a97c47b6a02f4a
downloadaur-5001a1fc54025bc8e55836ec6fe44dd45eb0df0d.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a11f22df961
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Aug 26 15:05:08 UTC 2018
+pkgbase = qt5-pmp-webchannel
+ pkgdesc = Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (for plex-media-player)
+ pkgver = 5.9.5
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = x86_64
+ groups = qt5-pmp
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ depends = qt5-pmp-declarative
+ source = http://download.qt.io/official_releases/qt/5.9/5.9.5/submodules/qtwebchannel-opensource-src-5.9.5.tar.xz
+ sha256sums = bfdd75a3a3c522aa31f5b9a4f5cfa631d5a96355ee934a710e612dfbf9d2d977
+
+pkgname = qt5-pmp-webchannel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3cafa0cdade
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Daniel Egeberg <daniel.egeberg@gmail.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=qt5-pmp-webchannel
+_qtver=5.9.5
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('x86_64')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (for plex-media-player)'
+depends=('qt5-pmp-declarative')
+makedepends=()
+groups=('qt5-pmp')
+_pkgfqn="${pkgname/5-pmp-/}-opensource-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('bfdd75a3a3c522aa31f5b9a4f5cfa631d5a96355ee934a710e612dfbf9d2d977')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ /opt/qt5-pmp/usr/bin/qmake ../${_pkgfqn}
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/opt/qt5-pmp/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/opt/qt5-pmp/usr/share/licenses
+ ln -s /opt/qt5-pmp/usr/share/licenses/qt5-base "$pkgdir"/opt/qt5-pmp/usr/share/licenses/${pkgname}
+}