summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2018-04-10 18:02:44 +0200
committerNorbert Pfeiler2018-04-10 18:02:44 +0200
commit358e3497353abf2b0bd9deef3b8be77a95c98870 (patch)
tree88389540931c58742fe2b962cbd6207f0acc24f9
parent960f71a74f872a88d6f34fbee724889d6e277bff (diff)
downloadaur-358e3497353abf2b0bd9deef3b8be77a95c98870.tar.gz
use DESTDIR for correct CMake Config generation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13b3354dbe74..815493cfb453 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Feb 18 21:45:30 UTC 2017
+# Tue Apr 10 16:01:32 UTC 2018
pkgbase = qt5-python27-git
pkgdesc = PythonQt fork featuring Qt 5.x and Python 3.x support and improved CMake build system (Qt5 and Python2.7 version)
- pkgver = 3.1+115.gb06f864
+ pkgver = 3.1+116.g1d22033
pkgrel = 1
url = https://github.com/knossos-project/PythonQt
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c7b5236373f0..076318f606dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="qt5-python27-git"
_qtver=5.8.0
-pkgver=3.1+115.gb06f864
+pkgver=3.1+116.g1d22033
pkgrel=1
arch=("x86_64")
pkgdesc="PythonQt fork featuring Qt 5.x and Python 3.x support and improved CMake build system (Qt5 and Python2.7 version)"
@@ -36,7 +36,7 @@ prepare() {
build() {
mkdir -p "$srcdir/build-$CHOST-$pkgname"
cd "$srcdir/build-$CHOST-$pkgname"
- cmake -G Ninja -DCMAKE_BUILD_TYPE=RELEASE -DBUILD_SHARED_LIBS=TRUE -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" -DPythonQt_Qt5=TRUE -DPythonQt_Python3=FALSE ../PythonQt
+ cmake -G Ninja -DCMAKE_BUILD_TYPE=RELEASE -DBUILD_SHARED_LIBS=TRUE -DCMAKE_INSTALL_PREFIX="/usr" -DPythonQt_Qt5=TRUE -DPythonQt_Python3=FALSE ../PythonQt
ninja
}
@@ -51,5 +51,5 @@ check() {
package() {
cd "$srcdir/build-$CHOST-$pkgname"
- ninja install
+ env DESTDIR="$pkgdir" ninja install
}