summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2016-07-02 08:06:14 +0200
committerNorbert Pfeiler2016-07-02 08:35:42 +0200
commita6683d46ac71da17bc3fb4885cf0b35b1721df6f (patch)
tree1d6ebe98ce59c4e8517248a77683517ec83afa8c
parentb737520e8907d11c8d8d8ed9122d8304dcb13b92 (diff)
downloadaur-a6683d46ac71da17bc3fb4885cf0b35b1721df6f.tar.gz
v3.1
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
3 files changed, 23 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f43617e83275..cf7ddda49389 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,26 @@
# Generated by mksrcinfo v8
-# Thu Dec 10 10:17:10 UTC 2015
+# Sat Jul 2 06:35:35 UTC 2016
pkgbase = qt5-python27-git
pkgdesc = PythonQt fork featuring Qt 5.x and Python 3.x support and improved CMake build system (Qt5 and Python2.7 version)
- pkgver = 3.0+16.gf3755ad.dirty
- pkgrel = 2
+ pkgver = 3.1
+ pkgrel = 1
url = https://github.com/knossos-project/PythonQt
- arch = any
+ arch = x86_64
license = LGPL
makedepends = cmake
makedepends = ninja
depends = python2
- depends = qt5-base
+ depends = qt5-declarative
depends = qt5-multimedia
depends = qt5-svg
- depends = qt5-tools
- depends = qt5-webkit
- depends = qt5-xmlpatterns
provides = qt5-python27
provides = pythonqt
conflicts = pythonqt
replaces = qt5-python26
- replaces = qt5-python25
- replaces = qt5-python24
- replaces = qt5-python23
- replaces = qt5-python22
- replaces = qt5-python21
- replaces = qt5-python20
source = git+https://github.com/knossos-project/PythonQt.git
+ source = qmetaobjectbuilder_p.h::http://code.qt.io/cgit/qt/qtbase.git/plain/src/corelib/kernel/qmetaobjectbuilder_p.h?h=5.7.0
md5sums = SKIP
+ md5sums = cee8d4c63cf37186a6076465a1b40e70
pkgname = qt5-python27-git
diff --git a/.gitignore b/.gitignore
index 694163612ff2..cd9f9bbe9a41 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@ PythonQt
# generated packages
*.tar.*
+/qmetaobjectbuilder_p.h
diff --git a/PKGBUILD b/PKGBUILD
index 43e411a9f480..f87924a1acb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: KNOSSOS-Team <knossos-team ät mpimf-heidelberg.mpg.de>
pkgname="qt5-python27-git"
-pkgver=3.0+16.gf3755ad.dirty
-pkgrel=2
-arch=("any")
+_qtver=5.7.0
+pkgver=3.1
+pkgrel=1
+arch=("x86_64")
pkgdesc="PythonQt fork featuring Qt 5.x and Python 3.x support and improved CMake build system (Qt5 and Python2.7 version)"
license=("LGPL")
url="https://github.com/knossos-project/PythonQt"
@@ -11,33 +12,30 @@ makedepends=("cmake"
"ninja"
)
depends=("python2"
- "qt5-base"
+ "qt5-declarative" # =$_qtver
"qt5-multimedia"
"qt5-svg"
- "qt5-tools"
- "qt5-webkit"
- "qt5-xmlpatterns"
)
provides=("qt5-python27"
"pythonqt"
)
conflicts=("pythonqt")
-replaces=("qt5-python26"
- "qt5-python25"
- "qt5-python24"
- "qt5-python23"
- "qt5-python22"
- "qt5-python21"
- "qt5-python20"
-)
-source=("git+https://github.com/knossos-project/PythonQt.git")
-md5sums=('SKIP')
+replaces=("qt5-python26") # conflicting older versions is the idea
+source=("git+https://github.com/knossos-project/PythonQt.git"
+ "qmetaobjectbuilder_p.h::http://code.qt.io/cgit/qt/qtbase.git/plain/src/corelib/kernel/qmetaobjectbuilder_p.h?h=$_qtver")
+md5sums=('SKIP'
+ 'cee8d4c63cf37186a6076465a1b40e70')
pkgver() {
cd "PythonQt"
git describe --always --dirty --tags | sed 's/^v//;s/-/+/;s/-/./g'
}
+prepare() {
+ mkdir -p PythonQt/src/private
+ cp qmetaobjectbuilder_p.h PythonQt/src/private/qmetaobjectbuilder_p.h
+}
+
build() {
mkdir -p "$srcdir/build-$CHOST-$pkgname"
cd "$srcdir/build-$CHOST-$pkgname"