summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2015-06-19 17:52:26 +0200
committerNorbert Pfeiler2015-06-19 17:52:26 +0200
commitcd8777c21446cd5f0c85cfc5d5533ae9aa0b0738 (patch)
tree26f9080c42c57a29ee74ec532d3eccd62935e510
downloadaur-cd8777c21446cd5f0c85cfc5d5533ae9aa0b0738.tar.gz
initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD54
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06296d4dc92e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = qt5-python27-git
+ pkgdesc = PythonQt fork featuring Qt 5.x and Python 3.x support and improved CMake build system (Qt5 and Python2.7 version)
+ pkgver = 3.0
+ pkgrel = 2
+ url = https://github.com/knossos-project/PythonQt
+ arch = any
+ license = LGPL
+ makedepends = cmake
+ makedepends = ninja
+ depends = python2
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = qt5-webkit
+ depends = qt5-xmlpatterns
+ provides = qt5-python27
+ provides = pythonqt
+ conflicts = pythonqt
+ replaces = qt5-python26
+ replaces = qt5-python25
+ replaces = qt5-python24
+ replaces = qt5-python23
+ replaces = qt5-python22
+ replaces = qt5-python21
+ replaces = qt5-python20
+ source = git+https://github.com/knossos-project/PythonQt.git
+ md5sums = SKIP
+
+pkgname = qt5-python27-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..694163612ff2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg folders
+src
+pkg
+PythonQt
+
+# generated packages
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6271edd86a3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+pkgname="qt5-python27-git"
+pkgver=3.0
+pkgrel=2
+arch=("any")
+pkgdesc="PythonQt fork featuring Qt 5.x and Python 3.x support and improved CMake build system (Qt5 and Python2.7 version)"
+license=("LGPL")
+url="https://github.com/knossos-project/PythonQt"
+makedepends=("cmake"
+ "ninja"
+)
+depends=("python2"
+ "qt5-base"
+ "qt5-multimedia"
+ "qt5-svg"
+ "qt5-tools"
+ "qt5-webkit"
+ "qt5-xmlpatterns"
+)
+provides=("qt5-python27"
+ "pythonqt"
+)
+conflicts=("pythonqt")
+replaces=("qt5-python26"
+ "qt5-python25"
+ "qt5-python24"
+ "qt5-python23"
+ "qt5-python22"
+ "qt5-python21"
+ "qt5-python20"
+)
+source=("git+https://github.com/knossos-project/PythonQt.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "PythonQt"
+ git describe --always --dirty --tags | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ mkdir -p "$srcdir/build-$CHOST-$pkgname"
+ cd "$srcdir/build-$CHOST-$pkgname"
+ cmake -G Ninja -DCMAKE_BUILD_TYPE=RELEASE -DBUILD_SHARED_LIBS=TRUE -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" -DPythonQt_Qt5=TRUE -DPythonQt_Python3=FALSE ../PythonQt
+ ninja
+}
+
+check() {
+ cd "$srcdir/build-$CHOST-$pkgname"
+ ninja tests
+}
+
+package() {
+ cd "$srcdir/build-$CHOST-$pkgname"
+ ninja install
+}