summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormickybart2016-06-03 20:24:16 -0400
committermickybart2016-06-03 20:24:16 -0400
commitad7c88e5a247925d95147bd5c087b73e4bdcbede (patch)
tree6c8493dd97fb29f69b80aa740d845789e649bf3e
downloadaur-ad7c88e5a247925d95147bd5c087b73e4bdcbede.tar.gz
initial: qt5-qpa-hwcomposer-plugin
Qt 5 QPA plugin for Droid hwcomposer This package is (at least) used for : - the GNU/Linux for Android devices project: https://github.com/mickybart/gnulinux_support - mer-hybris (https://github.com/mer-hybris) BUT in version 5.3.0 of Qt Patch for Qt 5.6.0 is not yet validate upstream but a pull is opened
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc33dac4252f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = qt5-qpa-hwcomposer-plugin
+ pkgdesc = Qt QPA plugin for Android hwcomposer
+ pkgver = 5.6.0
+ pkgrel = 1
+ url = https://github.com/mer-hybris/qt5-qpa-hwcomposer-plugin
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL3
+ license = LGPL
+ license = custom
+ depends = qt5-base
+ depends = qt5-wayland-compositor
+ depends = hybris-device
+ depends = libhybris
+ conflicts = qt
+ source = qt5-qpa-hwcomposer-plugin::git+http://github.com/mickybart/qt5-qpa-hwcomposer-plugin.git#tag=v5.6.0
+ md5sums = SKIP
+
+pkgname = qt5-qpa-hwcomposer-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cff7a6085d64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Michael Serpieri <mickybart@pygoscelis.org>
+
+pkgname=qt5-qpa-hwcomposer-plugin
+conflicts=('qt')
+_pkgname=qt5-qpa-hwcomposer-plugin
+_qtver=5.6.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('i686' 'x86_64' 'armv7h')
+url='https://github.com/mer-hybris/qt5-qpa-hwcomposer-plugin'
+license=('GPL3' 'LGPL' 'custom')
+pkgdesc='Qt QPA plugin for Android hwcomposer'
+depends=('qt5-base' 'qt5-wayland-compositor' 'hybris-device' 'libhybris')
+makedepends=()
+source=(${_pkgname}::git+http://github.com/mickybart/qt5-qpa-hwcomposer-plugin.git#tag=v${_qtver})
+md5sums=('SKIP')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ qmake ../${_pkgname}/hwcomposer/
+ make
+}
+
+package() {
+ cd build
+
+ make INSTALL_ROOT="$pkgdir" install
+}