summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2015-06-08 14:57:44 +0200
committerPier Luigi Fiorini2015-06-08 14:57:44 +0200
commitb90e165569aa1e13db4f8797782b5aa5dededc37 (patch)
tree6e64420abb60c30939f48e89d6651ee7cf7ab558
downloadaur-b90e165569aa1e13db4f8797782b5aa5dededc37.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10159e0962ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qt5-qpa-rpi-plugin
+ pkgdesc = Qt5 eglfs plugin built against Broadcom's GL libs.
+ pkgver = 5.4.0
+ pkgrel = 1
+ url = http://qt.io
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ license = LGPL
+ license = FDL
+ license = custom
+ depends = qt5-base
+ depends = mtdev
+ conflicts = qt5-qpa-rpi-plugin-git
+ source = https://github.com/greenisland/qt5-qpa-rpi-plugin/archive/v5.4.0.tar.gz
+ md5sums = b8a58bc5c438c11d105ece4b297d4cfc
+
+pkgname = qt5-qpa-rpi-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3efdd77ada5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+buildarch=16
+
+pkgname=qt5-qpa-rpi-plugin
+pkgver=5.4.0
+pkgrel=1
+pkgdesc="Qt5 eglfs plugin built against Broadcom's GL libs."
+url="http://qt.io"
+arch=('armv6h' 'armv7h')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
+depends=('qt5-base' 'mtdev')
+conflicts=('qt5-qpa-rpi-plugin-git')
+source=("https://github.com/greenisland/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('b8a58bc5c438c11d105ece4b297d4cfc')
+
+build() {
+ cd ${pkgname}-${pkgver}/eglfs_rpi
+ qmake
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/eglfs_rpi
+ make INSTALL_ROOT="${pkgdir}" install
+}