summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraudiolinux2016-03-28 13:28:34 +0200
committeraudiolinux2016-03-28 13:28:34 +0200
commit51ddd4d33a2121ffb0cae071acb60ef521b919dc (patch)
tree21dd8d25bf69c3151d29754178e44fa445f4702a
downloadaur-51ddd4d33a2121ffb0cae071acb60ef521b919dc.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD58
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c238f1b60e5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qt5-quick1
+ pkgdesc = Qt Declarative is provided for Qt 4 compatibility
+ pkgver = 5.6.0
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = x86_64
+ license = LGPL2.1
+ license = GPL3
+ makedepends = git
+ depends = qt5-webkit
+ depends = qt5-script
+ source = git://code.qt.io/qt/qtquick1.git#commit=dcc5e5c01c28b227f0e5e5e4976a9d26e8a45295
+ sha1sums = SKIP
+
+pkgname = qt5-quick1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07ce316b7d20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+# Contributor: almack
+
+pkgname=qt5-quick1
+pkgver=5.6.0
+_pkgver=5.6.0
+pkgrel=1
+arch=('x86_64')
+url='http://qt-project.org/'
+pkgdesc='Qt Declarative is provided for Qt 4 compatibility'
+license=('LGPL2.1' 'GPL3')
+#options=("debug")
+depends=('qt5-webkit' 'qt5-script')
+makedepends=('git')
+source=("git://code.qt.io/qt/qtquick1.git#commit=dcc5e5c01c28b227f0e5e5e4976a9d26e8a45295")
+sha1sums=('SKIP')
+
+_prlfix() {
+ # Fix wrong path in prl files
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
+}
+
+prepare() {
+ cd qtquick1
+
+ if [ ! -d include ]; then
+ syncqt.pl-qt5 -version 5.6.0 sync.profile
+ fi
+}
+
+build() {
+ cd qtquick1
+ mkdir -p build
+ cd build
+ qmake-qt5 ..
+
+ make
+
+ make docs
+}
+
+package() {
+ cd qtquick1/build
+ make INSTALL_ROOT="${pkgdir}" install
+ make INSTALL_ROOT="${pkgdir}" install_docs
+
+ _prlfix
+
+ # create some symlinks in /usr/bin, postfixed with -qt5
+ install -d "${pkgdir}"/usr/bin
+ for i in $(ls ${pkgdir}/usr/lib/qt5/bin); do
+ ln -s /usr/lib/qt5/bin/${i} ${pkgdir}/usr/bin/${i}-qt5
+ done
+
+ install -D -m644 ../LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}