aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2015-10-18 20:52:18 +0300
committerDāvis2015-10-18 20:52:18 +0300
commit3275b371638af581b688a25d25f262d24abb213e (patch)
treed223cdbec41c817f7a108895728469905417009f
downloadaur-3275b371638af581b688a25d25f262d24abb213e.tar.gz
Release qt5-tools-git
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD76
-rw-r--r--README.md2
-rw-r--r--UNLICENSE24
-rw-r--r--assistant.desktop8
-rw-r--r--designer.desktop10
-rw-r--r--linguist.desktop9
-rw-r--r--qdbusviewer.desktop9
-rw-r--r--qt5-tools.install12
10 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..809ebe572870
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = qt5-tools-git
+ pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp)
+ pkgver = v5.6.0.alpha1.r22.g42632bf
+ pkgrel = 1
+ url = https://code.qt.io/cgit/qt/qttools.git
+ install = qt5-tools.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ depends = qt5-webkit-git
+ depends = desktop-file-utils
+ depends = qt5-translations-git
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ provides = qt5-tools
+ conflicts = qt5-tools
+ options = staticlibs
+ source = qt5-tools::git+https://code.qt.io/qt/qttools.git#branch=dev
+ source = assistant.desktop
+ source = designer.desktop
+ source = linguist.desktop
+ source = qdbusviewer.desktop
+ sha256sums = SKIP
+ sha256sums = a34645c26ccedfd95a1285c316564828dc1a4da00072490d8be419b874286b55
+ sha256sums = 6a0666df1954e3a522b269e8c5278a346c37df6a33b0501a3c11e200e7e8c72e
+ sha256sums = 01378a279f7894b5a86bef08929835366f6c82b10410b41fe87053ba61e074e2
+ sha256sums = 309917aee2c0b0649f4043eb93c5dc1739640e741379214d2c684978e8eab6e9
+
+pkgname = qt5-tools-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0fc600c35209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.tar*
+/qt5-tools/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..981af8fa0fc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+
+_pkgname=qt5-tools
+pkgname=$_pkgname-git
+pkgver=v5.6.0.alpha1.r22.g42632bf
+pkgrel=1
+pkgdesc='A cross-platform application and UI framework (Development Tools, QtHelp)'
+arch=('i686' 'x86_64')
+url='https://code.qt.io/cgit/qt/qttools.git'
+license=('GPL3' 'LGPL')
+depends=('qt5-webkit-git' 'desktop-file-utils' 'qt5-translations-git' 'hicolor-icon-theme' 'xdg-utils')
+makedepends=('git')
+install='qt5-tools.install'
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+options=('staticlibs') # libQt5UiTools builds as static only
+source=("$_pkgname::git+https://code.qt.io/qt/qttools.git#branch=dev"
+ 'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop')
+sha256sums=('SKIP'
+ 'a34645c26ccedfd95a1285c316564828dc1a4da00072490d8be419b874286b55'
+ '6a0666df1954e3a522b269e8c5278a346c37df6a33b0501a3c11e200e7e8c72e'
+ '01378a279f7894b5a86bef08929835366f6c82b10410b41fe87053ba61e074e2'
+ '309917aee2c0b0649f4043eb93c5dc1739640e741379214d2c684978e8eab6e9'
+)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/build"
+
+ qmake "../$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # install missing icons and desktop files
+ for icon in $srcdir/$_pkgname/src/linguist/linguist/images/icons/linguist-*-32.png ; do
+ size=$(echo $(basename ${icon}) | cut -d- -f2)
+ install -p -D -m644 ${icon} "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/linguist.png"
+ done
+
+ install -D -m644 $srcdir/$_pkgname/src/assistant/assistant/images/assistant.png \
+ "${pkgdir}/usr/share/icons/hicolor/32x32/apps/assistant.png"
+ install -D -m644 $srcdir/$_pkgname/src/assistant/assistant/images/assistant-128.png \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/assistant.png"
+ install -D -m644 $srcdir/$_pkgname/src/designer/src/designer/images/designer.png \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/QtProject-designer.png"
+ install -D -m644 $srcdir/$_pkgname/src/qdbus/qdbusviewer/images/qdbusviewer.png \
+ "${pkgdir}/usr/share/icons/hicolor/32x32/apps/qdbusviewer.png"
+ install -D -m644 $srcdir/$_pkgname/src/qdbus/qdbusviewer/images/qdbusviewer-128.png \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/qdbusviewer.png"
+
+ install -d "${pkgdir}/usr/share/applications"
+ install -m644 "${srcdir}"/{linguist,designer,assistant,qdbusviewer}.desktop \
+ "${pkgdir}/usr/share/applications/"
+
+ # Useful symlinks
+ install -d "${pkgdir}"/usr/bin
+ for b in "${pkgdir}"/usr/lib/qt/bin/*; do
+ ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+
+ install -D -m644 $srcdir/$_pkgname/LGPL_EXCEPTION.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LGPL_EXCEPTION.txt
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..8e70cc449bb7
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# qt5-tools-git
+
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>
diff --git a/assistant.desktop b/assistant.desktop
new file mode 100644
index 000000000000..9d6100438216
--- /dev/null
+++ b/assistant.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Qt Assistant
+Comment=Shows Qt documentation and examples
+Exec=/usr/lib/qt/bin/assistant
+Icon=assistant
+Terminal=false
+Type=Application
+Categories=Qt;Development;Documentation;
diff --git a/designer.desktop b/designer.desktop
new file mode 100644
index 000000000000..b39e77a45726
--- /dev/null
+++ b/designer.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Qt Designer
+GenericName=Interface Designer
+Comment=Design GUIs for Qt applications
+Exec=/usr/lib/qt/bin/designer
+Icon=QtProject-designer
+MimeType=application/x-designer;
+Terminal=false
+Type=Application
+Categories=Qt;Development;
diff --git a/linguist.desktop b/linguist.desktop
new file mode 100644
index 000000000000..c6d1aa4bace7
--- /dev/null
+++ b/linguist.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Qt Linguist
+Comment=Add translations to Qt applications
+Exec=/usr/lib/qt/bin/linguist
+Icon=linguist
+MimeType=text/vnd.trolltech.linguist;application/x-linguist;
+Terminal=false
+Type=Application
+Categories=Qt;Development;
diff --git a/qdbusviewer.desktop b/qdbusviewer.desktop
new file mode 100644
index 000000000000..9165b6feb161
--- /dev/null
+++ b/qdbusviewer.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Qt QDbusViewer
+GenericName=D-Bus Debugger
+Comment=Debug D-Bus applications
+Exec=/usr/lib/qt/bin/qdbusviewer
+Icon=qdbusviewer
+Terminal=false
+Type=Application
+Categories=Qt;Development;Debugger;
diff --git a/qt5-tools.install b/qt5-tools.install
new file mode 100644
index 000000000000..5495fb1b5d27
--- /dev/null
+++ b/qt5-tools.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}