summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeoffrey Casper2021-03-04 14:28:34 -0500
committerGeoffrey Casper2021-03-04 14:33:19 -0500
commitba604c1316abec87a4ddb3d6d07dd35cfb4810be (patch)
tree09131e76c7ad3fae1c1d35eff84fb9ca432075fd
downloadaur-ba604c1316abec87a4ddb3d6d07dd35cfb4810be.tar.gz
Initial Commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD52
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a05d8f5e1cd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qt5-wayland-bugfixport-git
+ pkgdesc = A cross-platform application and UI framework (QtWayland)
+ pkgver = 5.15.2
+ pkgrel = 1
+ url = https://github.com/Geo25rey/qtwayland.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ depends = qt5-declarative
+ depends = libxcomposite
+ depends = wayland
+ provides = qt5-wayland
+ conflicts = qt5-wayland
+ source = https://github.com/Geo25rey/qtwayland.git
+ sha256sums = SKIP
+
+pkgname = qt5-wayland-bugfixport-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e54f672cb055
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Geoffrey Casper <gcasper42@gmail.com>
+# Contributor: Swift Geek
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+# Contributor: Mateusz Paluszkiewicz <aifam96 at gmail dot com> # Other hacks for repo's target, qt5-wayland-dev-git package
+# TODO: more hacks
+# TODO: better pkgver()
+# TODO: add prepare()
+
+_pkgname=qt5-wayland
+pkgname=$_pkgname-bugfixport-git
+pkgver=5.15.2 # If you want to update periodically - use changeling script (AUR) from aur with cron
+pkgrel=1
+pkgdesc="A cross-platform application and UI framework (QtWayland)"
+arch=("i686" "x86_64")
+url="https://github.com/Geo25rey/qtwayland.git"
+license=("GPL3" "LGPL")
+depends=("qt5-declarative" "libxcomposite" "wayland")
+makedepends=("git")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("https://github.com/Geo25rey/qtwayland.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "5.15.2-$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ # Replace Qt version to user version (Qt)
+ if [ -d ./build ]; then
+ rm -rf --one-file-system ./build
+ fi
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ mkdir build
+ cd build
+ export QT_SELECT=5
+ qmake CONFIG+=wayland-compositor ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ cd build
+ make INSTALL_ROOT="${pkgdir}" install
+}