summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Klokkhammer Helsing2018-05-16 12:32:30 +0200
committerJohan Klokkhammer Helsing2018-05-16 12:32:30 +0200
commit0854cffa55288bd99166af309b285e13d0b181ac (patch)
tree40cfe1b80149f7a3c8bfb2b99fa206a2415ddd24
parent7bacd310ee32bf8914e859b815f74d152a21a638 (diff)
downloadaur-0854cffa55288bd99166af309b285e13d0b181ac.tar.gz
Fix issues with rebuilding and add .gitignore
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 11 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4237ecbeaddc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+qt5-wayland/
+*.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
index d6689ed11a29..09f9927fcb2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=qt5-wayland
pkgname=$_pkgname-dev-backport-git
-pkgver=5.10.1.281e3d58 # If you want to update periodically - use changeling script (AUR) from aur with cron
+pkgver=5.10.1.281e3d58
pkgrel=1
pkgdesc="A cross-platform application and UI framework (QtWayland)"
arch=("i686" "x86_64")
@@ -21,23 +21,23 @@ sha256sums=('SKIP')
# Definition with userside version of Qt5
_qt5_userversion=`pkg-config --modversion Qt5Core`
-_branch=$(echo ${_qt5_userversion} | cut -d. -f1,2)
+_branch=dev-for-$(echo ${_qt5_userversion} | cut -d. -f1,2)
-source=("$_pkgname::git://github.com/johanhelsing/qtwayland-backports.git#branch=dev-for-${_branch}")
+source=("$_pkgname::git://github.com/johanhelsing/qtwayland-backports.git#branch=${_branch}")
pkgver() {
cd "$srcdir/$_pkgname"
echo "${_qt5_userversion}.$(git rev-parse --short HEAD)"
}
-#prepare() {
-# cd "$srcdir/$_pkgname"
-# # Replace Qt version to user version (Qt)
-# sed -i "3s/.*/MODULE_VERSION = ${_qt5_userversion}/" ./.qmake.conf
-# if [ -d ./build ]; then
-# rm -rf --one-file-system ./build
-# fi
-#}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ # Replace Qt version to user version (Qt)
+ sed -i "3s/.*/MODULE_VERSION = ${_qt5_userversion}/" ./.qmake.conf
+ if [ -d ./build ]; then
+ rm -rf --one-file-system ./build
+ fi
+}
build() {
cd "$srcdir/$_pkgname"