summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Klokkhammer Helsing2018-05-16 12:16:28 +0200
committerJohan Klokkhammer Helsing2018-05-16 12:18:19 +0200
commit7bacd310ee32bf8914e859b815f74d152a21a638 (patch)
tree8a06f762440a7d68a94f20f052fa6cab47eab60b
downloadaur-7bacd310ee32bf8914e859b815f74d152a21a638.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..626d6bd8c034
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qt5-wayland-dev-backport-git
+ pkgdesc = A cross-platform application and UI framework (QtWayland)
+ pkgver = 5.10.1.281e3d58
+ pkgrel = 1
+ url = http://code.qt.io/cgit/qt/qtwayland.git/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ depends = qt5-declarative
+ depends = libxcomposite
+ depends = wayland
+ provides = qt5-wayland
+ conflicts = qt5-wayland
+ source = qt5-wayland::git://github.com/johanhelsing/qtwayland-backports.git#branch=dev-for-5.10
+ sha256sums = SKIP
+
+pkgname = qt5-wayland-dev-backport-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6689ed11a29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Johan Helsing <johanhelsing@gmail.com>
+# Contirbutor: Swift Geek
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+# Contributor: Mateusz Paluszkiewicz <aifam96 at gmail dot com> # Other hacks for repo's target, qt5-wayland-dev-git package
+
+_pkgname=qt5-wayland
+pkgname=$_pkgname-dev-backport-git
+pkgver=5.10.1.281e3d58 # If you want to update periodically - use changeling script (AUR) from aur with cron
+pkgrel=1
+pkgdesc="A cross-platform application and UI framework (QtWayland)"
+arch=("i686" "x86_64")
+url="http://code.qt.io/cgit/qt/qtwayland.git/"
+license=("GPL3" "LGPL")
+depends=("qt5-declarative" "libxcomposite" "wayland")
+makedepends=("git")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+sha256sums=('SKIP')
+
+# Definition with userside version of Qt5
+_qt5_userversion=`pkg-config --modversion Qt5Core`
+_branch=$(echo ${_qt5_userversion} | cut -d. -f1,2)
+
+source=("$_pkgname::git://github.com/johanhelsing/qtwayland-backports.git#branch=dev-for-${_branch}")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "${_qt5_userversion}.$(git rev-parse --short HEAD)"
+}
+
+#prepare() {
+# cd "$srcdir/$_pkgname"
+# # Replace Qt version to user version (Qt)
+# sed -i "3s/.*/MODULE_VERSION = ${_qt5_userversion}/" ./.qmake.conf
+# if [ -d ./build ]; then
+# rm -rf --one-file-system ./build
+# fi
+#}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ mkdir build
+ cd build
+ export QT_SELECT=5
+ qmake CONFIG+=wayland-compositor ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ cd build
+ make INSTALL_ROOT="${pkgdir}" install
+}