summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2013-05-23 16:00:48 +0000
committerThomas Dziedzic2013-05-23 16:00:48 +0000
commit088f40b1d03f753d1f6caeb1ba2c969d501bfa8c (patch)
tree64514443aef000a669cacc175bcf24c2d9422391
downloadaur-088f40b1d03f753d1f6caeb1ba2c969d501bfa8c.tar.gz
Import from pkgbuild.com service
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db7ceceffa99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = qt5-wayland-git
+ pkgdesc = A cross-platform application and UI framework (QtCompositor, Wayland QPA plugins)
+ pkgver = 20130521
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = i686
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = GPL3
+ license = LGPL
+ makedepends = gcc
+ makedepends = git
+ depends = qt5-base-git
+ depends = qt5-declarative-git
+ depends = libxcomposite
+ depends = libxkbcommon
+ depends = wayland
+ provides = qt5-wayland
+ conflicts = qt5-wayland
+ replaces = qt5-qtwayland-git
+
+pkgname = qt5-wayland-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49f17cfaab65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=qt5-wayland-git
+pkgver=20130521
+pkgrel=1
+pkgdesc="A cross-platform application and UI framework (QtCompositor, Wayland QPA plugins)"
+groups=('qt' 'qt5')
+arch=('i686' 'x86_64')
+url="http://qt-project.org/"
+license=('GPL3' 'LGPL')
+depends=('qt5-base-git' 'qt5-declarative-git' 'libxcomposite' 'libxkbcommon' 'wayland')
+replaces=('qt5-qtwayland-git')
+provides=('qt5-wayland')
+conflicts=('qt5-wayland')
+makedepends=('gcc' 'git')
+
+#_gitroot="git://gitorious.org/qt/qtwayland.git"
+_gitroot="git://github.com/plfiorini/qtwayland.git"
+_gitname=qt5-qtwayland
+#_gitbranch=master
+_gitbranch=hawaii-stable
+
+build() {
+ if [ ! -d "${_gitname}" ]; then
+ git clone -b ${_gitbranch} --depth 1 ${_gitroot} ${_gitname} && cd ${_gitname}
+ else
+ cd ${_gitname} && git reset --hard && git pull origin && git clean -dfx
+ fi
+
+ msg "GIT checkout done."
+
+ #qmake CONFIG+=wayland-compositor
+ qmake
+ make
+}
+
+package() {
+ cd "${_gitname}"
+
+ make INSTALL_ROOT="${pkgdir}" install
+}