summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2015-01-22 00:00:11 +0000
committerKyle Keen2015-01-22 00:00:11 +0000
commit431006ed29137700d96d4238812196daad0cfa69 (patch)
treed69d9677ced86bb4e4ce060b4f7251fe8cee537b
parenta9fe52c14e6a91be19a7b0468d3c9b4aeea41a18 (diff)
downloadaur-431006ed29137700d96d4238812196daad0cfa69.tar.gz
Import from pkgbuild.com service
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd10d0d14b18..abad71eed240 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = qt5-wayland-git
pkgdesc = A cross-platform application and UI framework (QtWayland)
pkgver = a
- pkgrel = 1
- url = https://qt-project.org/
+ pkgrel = 2
+ url = https://qt.gitorious.org/qt/qtwayland
arch = i686
arch = x86_64
license = GPL3
@@ -12,7 +12,7 @@ pkgbase = qt5-wayland-git
depends = libxcomposite
provides = qt5-wayland
conflicts = qt5-wayland
- source = qt5-wayland::git://gitorious.org/qt/qtwayland.git#branch=5.4.1
+ source = qt5-wayland::git://gitorious.org/qt/qtwayland.git#branch=5.4.2
sha256sums = SKIP
pkgname = qt5-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
index d2b47cd7b080..7733bcd363cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,31 +10,32 @@
_pkgname=qt5-wayland
pkgname=$_pkgname-git
pkgver=a # If you want to update periodically - use changeling script from aur with cron
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform application and UI framework (QtWayland)"
arch=("i686" "x86_64")
-url="https://qt-project.org/" # TODO: change this adderess to gitorious?
+url="https://qt.gitorious.org/qt/qtwayland" # TODO: change this adderess to gitorious?
license=("GPL3" "LGPL")
depends=("qt5-declarative" "libxcomposite")
makedepends=("git")
provides=("$_pkgname")
conflicts=("$_pkgname")
+
+# Definition with userside version of Qt5
+_qt5_userversion=`pkg-config --modversion Qt5Core`
+
if [ -e /var/lib/pacman/local/qt5-base-5* ]; then
# If you are using repo's qt5, change to the latest minor version
-#TODO: automate version, perhaps _qt5_userversion?
- source=("$_pkgname::git://gitorious.org/qt/qtwayland.git#branch=5.4.1")
+ source=("$_pkgname::git://gitorious.org/qt/qtwayland.git#branch=${_qt5_userversion}")
else
# If you are using anything else eg. qt5-base-git
source=("$_pkgname::git://gitorious.org/qt/qtwayland.git#branch=dev")
fi
sha256sums=("SKIP")
-# Definition with userside version of Qt5
-_qt5_userversion=`pkg-config --modversion Qt5Core`
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ echo "${_qt5_userversion}.$(git rev-parse --short HEAD)"
}
build() {
@@ -48,6 +49,7 @@ build() {
cd build
export QT_SELECT=5
qmake CONFIG+=wayland-compositor ..
+ make
}
package() {