summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2014-02-09 00:49:23 +0000
committerKyle Keen2014-02-09 00:49:23 +0000
commitd01ef853070ec80067fd57547a4cec53926656ea (patch)
tree18a1ef4282de756a9ccf15f6ccc5483cb78ad9df
parentf50c372f96c9ef6295c9b0cd684c0656afd769e7 (diff)
downloadaur-d01ef853070ec80067fd57547a4cec53926656ea.tar.gz
Import from pkgbuild.com service
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fbf6f4caa6a..b5cd0c6c8d68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = qt5-wayland-git
makedepends = git
makedepends = qtchooser
depends = qt5-base
+ depends = qt5-declarative
depends = libxcomposite
depends = wayland
conflicts = qt5-wayland
diff --git a/PKGBUILD b/PKGBUILD
index eeb25e60923c..fa61a570e0f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="A cross-platform application and UI framework (QtWayland)"
arch=('i686' 'x86_64')
url="http://qt-project.org/"
license=('GPL3' 'LGPL')
-depends=('qt5-base' 'libxcomposite' 'wayland')
+depends=('qt5-base' 'qt5-declarative' 'libxcomposite' 'wayland')
makedepends=('git' 'qtchooser')
conflicts=('qt5-wayland')
options=('!libtool' 'debug')
@@ -23,7 +23,7 @@ build() {
export QT_SELECT=5
cd qtwayland
- qmake
+ qmake CONFIG+=wayland-compositor
make
}