summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2013-12-17 00:22:27 +0000
committerKyle Keen2013-12-17 00:22:27 +0000
commitf50c372f96c9ef6295c9b0cd684c0656afd769e7 (patch)
tree18745d7ac00a754ac9686cc4f38494090cc675dd
parentcc86c3e74ee03ac43d3f1130c6a16553549cdc08 (diff)
downloadaur-f50c372f96c9ef6295c9b0cd684c0656afd769e7.tar.gz
Import from pkgbuild.com service
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 20 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5db900965a0a..7fbf6f4caa6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,21 @@
pkgbase = qt5-wayland-git
- pkgdesc = A cross-platform application and UI framework (QtCompositor, Wayland QPA plugins)
+ pkgdesc = A cross-platform application and UI framework (QtWayland)
pkgver = 0.0.0
pkgrel = 1
url = http://qt-project.org/
arch = i686
arch = x86_64
- groups = qt
- groups = qt5
license = GPL3
license = LGPL
- makedepends = gcc
makedepends = git
- depends = qt5-base-git
- depends = qt5-declarative-git
+ makedepends = qtchooser
+ depends = qt5-base
depends = libxcomposite
- depends = libxkbcommon
depends = wayland
- provides = qt5-wayland
conflicts = qt5-wayland
- replaces = qt5-qtwayland-git
- source = qt5-wayland::git://github.com/plfiorini/qtwayland.git#branch=hawaii-stable
+ options = !libtool
+ options = debug
+ source = git://gitorious.org/qt/qtwayland.git#branch=stable
md5sums = SKIP
pkgname = qt5-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
index 6408f797f20c..eeb25e60923c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,31 @@
pkgname=qt5-wayland-git
pkgver=0.0.0
pkgrel=1
-pkgdesc="A cross-platform application and UI framework (QtCompositor, Wayland QPA plugins)"
-groups=('qt' 'qt5')
+pkgdesc="A cross-platform application and UI framework (QtWayland)"
arch=('i686' 'x86_64')
url="http://qt-project.org/"
license=('GPL3' 'LGPL')
-depends=('qt5-base-git' 'qt5-declarative-git' 'libxcomposite' 'libxkbcommon' 'wayland')
-replaces=('qt5-qtwayland-git')
-provides=('qt5-wayland')
+depends=('qt5-base' 'libxcomposite' 'wayland')
+makedepends=('git' 'qtchooser')
conflicts=('qt5-wayland')
-makedepends=('gcc' 'git')
-#_gitroot="git://gitorious.org/qt/qtwayland.git"
-_gitroot="git://github.com/plfiorini/qtwayland.git"
-#_gitbranch=master
-_gitbranch=hawaii-stable
-_gitname="qt5-wayland"
-source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+options=('!libtool' 'debug')
+source=(git://gitorious.org/qt/qtwayland.git#branch=stable)
md5sums=('SKIP')
pkgver() {
- cd ${srcdir}/${_gitname}
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd qtwayland
+ git describe --always | sed 's|-|.|g'
}
build() {
- cd ${srcdir}/${_gitname}
- qmake CONFIG+=wayland-compositor
- #qmake
- make
+ export QT_SELECT=5
+
+ cd qtwayland
+ qmake
+ make
}
package() {
- cd ${srcdir}/${_gitname}
- make INSTALL_ROOT="${pkgdir}" install
+ cd qtwayland
+ make INSTALL_ROOT="${pkgdir}" install
}