summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse McClure2017-11-15 18:42:17 -0500
committerJesse McClure2017-11-15 18:42:17 -0500
commit4d6ff9da9bed5a7234d8ad60e36ddf6b441f31e8 (patch)
tree03b062d0763d0b03fe1143db0a9dd36da913e4cd
parent8361612b94940f07d016db8ee1f9c95223acb6e7 (diff)
downloadaur-4d6ff9da9bed5a7234d8ad60e36ddf6b441f31e8.tar.gz
switch source from debian to arch-rollback-machine
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 217f6b752d71..aa48a5676ade 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Jesse McClure aka "Trilby" <jesse dot mcclure at umassmed dot edu>
-# Contributor: Doug Newgard <scimmia at archlinux dot info>
pkgname=qt5-webengine-widevine
pkgdesc='A browser plugin designed for the viewing of premium video content'
pkgver=61.0.3163.100
+_widevine_ver=1.4.8.1008
pkgrel=2
epoch=1
arch=('x86_64')
@@ -11,20 +11,19 @@ url='http://www.google.com/chrome'
license=('custom:chrome')
options=('!strip')
depends=('qt5-webengine')
-source=("http://ftp.us.debian.org/debian/pool/contrib/c/chromium-browser/chromium-widevine_${pkgver}-${pkgrel}_amd64.deb"
-'https://dl.google.com/widevine-cdm/1.4.8.1008-linux-x64.zip'
-'chrome-eula_text.html::https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html')
-sha256sums=('c27c44a89895840addb191f9fdf87430b3895d7b33015048a7fb82148f3003e8'
-'fe04a5b56eac6674f1eda2c8eb28a0183ec1a66d80f72db618291e33078eb17d'
-'e93c01576427cad9099f2cf0df0be70d0a2cc0a3a66c743318b2138aa7c4ed93')
-
-prepare() {
-bsdtar -xf data.tar.xz usr/lib/chromium/libwidevinecdmadapter.so
-}
+source=(
+ "https://archive.archlinux.org/packages/c/chromium/chromium-${pkgver}-1-x86_64.pkg.tar.xz"
+ "https://dl.google.com/widevine-cdm/${_widevine_ver}-linux-x64.zip"
+ "chrome-eula_text.html::https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html"
+)
+sha256sums=(
+ '5d4380308b3d5c2bc6e13d77090688ba00f0828f2777d83376d44038a6d0e2dd'
+ 'fe04a5b56eac6674f1eda2c8eb28a0183ec1a66d80f72db618291e33078eb17d'
+ 'e93c01576427cad9099f2cf0df0be70d0a2cc0a3a66c743318b2138aa7c4ed93'
+)
package() {
-install -Dm644 libwidevinecdm.so -t "$pkgdir/usr/lib/qt/plugins/ppapi/"
-install -Dm644 usr/lib/chromium/libwidevinecdmadapter.so -t "$pkgdir/usr/lib/qt/plugins/ppapi/"
-install -Dm644 chrome-eula_text.html -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 libwidevinecdm.so -t "$pkgdir/usr/lib/qt/plugins/ppapi/"
+ install -Dm644 usr/lib/chromium/libwidevinecdmadapter.so -t "$pkgdir/usr/lib/qt/plugins/ppapi/"
+ install -Dm644 chrome-eula_text.html -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-