summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2015-10-18 20:02:03 +0300
committerDāvis2015-10-18 20:02:03 +0300
commitf01e0bcc382c522d007e1345b8bc9068d036563a (patch)
treea9cf96e3780e3511bca6e8c8d73daa656a56ebe7
downloadaur-f01e0bcc382c522d007e1345b8bc9068d036563a.tar.gz
Release qt5-webkit-git
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD45
-rw-r--r--README.md1
-rw-r--r--UNLICENSE24
5 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38a657512e2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = qt5-webkit-git
+ pkgdesc = Classes for a WebKit2 based implementation and a new QML API
+ pkgver = v5.5.1.r28.g0be0076
+ pkgrel = 1
+ url = https://code.qt.io/cgit/qt/qtwebkit.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ license = FDL
+ makedepends = git
+ makedepends = python2
+ depends = qt5-sensors-git
+ depends = qt5-location-git
+ depends = qt5-webchannel-git
+ depends = gst-plugins-base
+ depends = libxslt
+ depends = libxcomposite
+ depends = libwebp
+ optdepends = gst-plugins-good: Webm codec support
+ provides = qt5-webkit
+ conflicts = qt5-webkit
+ source = qt5-webkit::git+https://code.qt.io/qt/qtwebkit.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = qt5-webkit-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..29d5013990d8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.tar*
+/qt5-webkit/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..066a885afbc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+
+_pkgname=qt5-webkit
+pkgname=$_pkgname-git
+pkgver=v5.5.1.r28.g0be0076
+pkgrel=1
+pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
+arch=('i686' 'x86_64')
+url='https://code.qt.io/cgit/qt/qtwebkit.git'
+license=('GPL3' 'LGPL' 'FDL')
+depends=('qt5-sensors-git' 'qt5-location-git' 'qt5-webchannel-git' 'gst-plugins-base' 'libxslt' 'libxcomposite' 'libwebp')
+optdepends=('gst-plugins-good: Webm codec support')
+makedepends=('git' 'python2')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://code.qt.io/qt/qtwebkit.git#branch=dev")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p build
+
+ # Use python2 for Python 2.x
+ find "./$_pkgname" -name '*.py' -exec sed -i \
+ 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|;1 s|#[ ].*$|#!/usr/bin/python2|' {} +
+ find "./$_pkgname" -type f \( -name "*.pr?" -o -name "*.make" \) -exec sed -i -e "s|python |python2 |" {} +
+}
+
+build() {
+ cd "$srcdir/build"
+
+ qmake "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make INSTALL_ROOT="$pkgdir" install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..56ad3c4cb331
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+# qt5-webkit-git
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>