aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2015-10-18 21:16:29 +0300
committerDāvis2015-10-18 21:16:29 +0300
commit51965896e652de1cf22a5f074c081d70a4f76c47 (patch)
tree2b6e16a89e52c1742062967d38658eda7611846b
downloadaur-qt5-x11extras-git.tar.gz
Release qt5-x11extras-git
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--README.md2
-rw-r--r--UNLICENSE24
5 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..419b8864aa94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qt5-x11extras-git
+ pkgdesc = Provides platform-specific APIs for X11
+ pkgver = v5.5.0.r2.g85654ad
+ pkgrel = 1
+ url = https://code.qt.io/cgit/qt/qtx11extras.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ depends = qt5-base-git
+ provides = qt5-x11extras
+ conflicts = qt5-x11extras
+ source = qt5-x11extras::git+https://code.qt.io/qt/qtx11extras.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = qt5-x11extras-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..472cee99fff3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.tar*
+/qt5-x11extras/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9427b99c6507
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+
+_pkgname=qt5-x11extras
+pkgname=$_pkgname-git
+pkgver=v5.5.0.r2.g85654ad
+pkgrel=1
+pkgdesc='Provides platform-specific APIs for X11'
+arch=('i686' 'x86_64')
+url='https://code.qt.io/cgit/qt/qtx11extras.git'
+license=('GPL3' 'LGPL')
+depends=('qt5-base-git')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://code.qt.io/qt/qtx11extras.git#branch=dev")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/build"
+
+ qmake "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 $srcdir/$_pkgname/LGPL_EXCEPTION.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LGPL_EXCEPTION.txt
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..1ba73071d9f7
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# qt5-x11extras-git
+
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>