summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2015-06-20 13:39:43 -0500
committerRiley Trautman2015-06-20 13:39:43 -0500
commitc49ab6efe2b0d0cdce1c845a039090a98bebfebc (patch)
tree0aaee629440731b23daf8513c91b7e3add5fabe5
downloadaur-c49ab6efe2b0d0cdce1c845a039090a98bebfebc.tar.gz
Initial Import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8f44c1a37e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qt5-xmlpatterns-git
+ pkgdesc = A cross-platform application and UI framework (QtXmlPatterns)
+ pkgver = v5.5.0.beta1.2.g25ad8b7
+ pkgrel = 1
+ url = https://qt-project.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ makedepends = python
+ depends = qt5-base-git
+ provides = qt5-xmlpatterns
+ conflicts = qt5-xmlpatterns
+ source = qt5-xmlpatterns::git://code.qt.io/qt/qtxmlpatterns.git#branch=5.5
+ sha256sums = SKIP
+
+pkgname = qt5-xmlpatterns-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08735482c0cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+_pkgname=qt5-xmlpatterns
+pkgname=$_pkgname-git
+pkgver=v5.5.0.beta1.2.g25ad8b7
+pkgrel=1
+pkgdesc="A cross-platform application and UI framework (QtXmlPatterns)"
+arch=("i686" "x86_64")
+url="https://qt-project.org/"
+license=("GPL3" "LGPL")
+depends=("qt5-base-git")
+makedepends=("git" "python")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git://code.qt.io/qt/qtxmlpatterns.git#branch=5.5")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p build
+ cd build
+ qmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+}