summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Hovorka2017-03-12 07:59:36 +0100
committerMarkus Hovorka2017-03-12 07:59:36 +0100
commit3b59a0110887b72c3663926c1b7853617b1bae0d (patch)
treec17e5578cc39c25de1c9b87e058590f8de656c44
parent071164386a970800ae2476412f48fcab518cdfcd (diff)
downloadaur-3b59a0110887b72c3663926c1b7853617b1bae0d.tar.gz
Fix build of QWebEngine
The buildsystem of QWebEngine expects python to point to python2 not python3. Also the PKGBUILD was missing some dependencies.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79adee7c1a4b..8c08c317ee0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5.6
pkgdesc = A cross-platform application and UI framework
pkgver = 5.6.2
- pkgrel = 2
+ pkgrel = 3
url = http://qt-project.org/
arch = i686
arch = x86_64
@@ -21,7 +21,6 @@ pkgbase = qt5.6
makedepends = bluez-libs
makedepends = python2
makedepends = libxcursor
- makedepends = libxrandr
makedepends = git
makedepends = gperf
makedepends = python
@@ -49,6 +48,12 @@ pkgbase = qt5.6
depends = nss
depends = libxslt
depends = gst-plugins-base-libs
+ depends = libxrandr
+ depends = libsrtp
+ depends = protobuf
+ depends = libxdamage
+ depends = minizip
+ depends = ffmpeg
optdepends = qt5-svg: to use SVG icon themes
optdepends = postgresql-libs: PostgreSQL driver
optdepends = libmariadbclient: MariaDB driver
diff --git a/PKGBUILD b/PKGBUILD
index a9a46ede190c..0eb7bf4d59c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=qt5.6
pkgver=5.6.2
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom')
@@ -13,10 +13,11 @@ depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-wm' 'xcb-util-image'
'icu' 'tslib' 'libinput' 'libxkbcommon-x11' 'jasper' 'libmng'
'libwebp' 'libpulse' 'openal' 'libxcomposite' 'pciutils' 'libxss'
'libvpx' 'opus' 'libevent' 'jsoncpp' 'snappy' 'nss' 'libxslt'
- 'gst-plugins-base-libs')
+ 'gst-plugins-base-libs' 'libxrandr' 'libsrtp' 'protobuf' 'libxdamage'
+ 'minizip' 'ffmpeg')
makedepends=('mtdev' 'libfbclient' 'libmariadbclient' 'unixodbc' 'alsa-lib'
'postgresql-libs' 'gtk2' 'cups' 'freetds' 'bluez-libs' 'python2'
- 'libxcursor' 'libxrandr' 'git' 'gperf' 'python')
+ 'libxcursor' 'git' 'gperf' 'python')
optdepends=('qt5-svg: to use SVG icon themes'
'postgresql-libs: PostgreSQL driver'
'libmariadbclient: MariaDB driver'
@@ -35,6 +36,11 @@ prepare() {
find . -name '*.py' -exec sed -i \
's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
+
+ # Hack to force using python2
+ mkdir -p "$srcdir/bin"
+ ln -s /usr/bin/python2 "$srcdir/bin/python"
+ export PATH="$srcdir/bin:$PATH"
}
build() {