summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Hovorka2017-01-30 15:18:39 +0100
committerMarkus Hovorka2017-01-30 15:18:39 +0100
commit69daadda2eebae6f42d76d47d0c19bf2b4938e00 (patch)
treea0ae9524beb4f89e000c2e69b3c2a607598ad3da
downloadaur-69daadda2eebae6f42d76d47d0c19bf2b4938e00.tar.gz
Add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO65
-rw-r--r--PKGBUILD60
2 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..099c3b0fc7ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,65 @@
+pkgbase = qt5.6
+ pkgdesc = A cross-platform application and UI framework
+ pkgver = 5.6.2
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ license = FDL
+ license = custom
+ makedepends = mtdev
+ makedepends = libfbclient
+ makedepends = libmariadbclient
+ makedepends = unixodbc
+ makedepends = alsa-lib
+ makedepends = postgresql-libs
+ makedepends = gtk2
+ makedepends = cups
+ makedepends = freetds
+ makedepends = bluez-libs
+ makedepends = python2
+ makedepends = libxcursor
+ makedepends = libxrandr
+ makedepends = git
+ makedepends = gperf
+ makedepends = python
+ depends = libjpeg-turbo
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
+ depends = xcb-util-image
+ depends = icu
+ depends = tslib
+ depends = libinput
+ depends = libxkbcommon-x11
+ depends = jasper
+ depends = libmng
+ depends = libwebp
+ depends = libpulse
+ depends = openal
+ depends = libxcomposite
+ depends = pciutils
+ depends = libxss
+ depends = libvpx
+ depends = opus
+ depends = libevent
+ depends = jsoncpp
+ depends = snappy
+ depends = nss
+ depends = libxslt
+ depends = gst-plugins-base-libs
+ optdepends = qt5-svg: to use SVG icon themes
+ optdepends = postgresql-libs: PostgreSQL driver
+ optdepends = libmariadbclient: MariaDB driver
+ optdepends = unixodbc: ODBC driver
+ optdepends = libfbclient: Firebird/iBase driver
+ optdepends = freetds: MS SQL driver
+ optdepends = mtdev: evdev plugin
+ optdepends = gtk2: GTK2 plugin
+ optdepends = bluez-libs: for sdpscanner
+ source = http://download.qt.io/official_releases/qt/5.6/5.6.2/single/qt-everywhere-opensource-src-5.6.2.tar.xz
+ md5sums = 5175fba2f221fd4c91e94771a57a5557
+
+pkgname = qt5.6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fedab261c592
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Markus Hovorka <m.hovorka@live.de>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=qt5.6
+pkgver=5.6.2
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL' 'FDL' 'custom')
+pkgdesc='A cross-platform application and UI framework'
+depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-wm' 'xcb-util-image'
+ 'icu' 'tslib' 'libinput' 'libxkbcommon-x11' 'jasper' 'libmng'
+ 'libwebp' 'libpulse' 'openal' 'libxcomposite' 'pciutils' 'libxss'
+ 'libvpx' 'opus' 'libevent' 'jsoncpp' 'snappy' 'nss' 'libxslt'
+ 'gst-plugins-base-libs')
+makedepends=('mtdev' 'libfbclient' 'libmariadbclient' 'unixodbc' 'alsa-lib'
+ 'postgresql-libs' 'gtk2' 'cups' 'freetds' 'bluez-libs' 'python2'
+ 'libxcursor' 'libxrandr' 'git' 'gperf' 'python')
+optdepends=('qt5-svg: to use SVG icon themes'
+ 'postgresql-libs: PostgreSQL driver'
+ 'libmariadbclient: MariaDB driver'
+ 'unixodbc: ODBC driver'
+ 'libfbclient: Firebird/iBase driver'
+ 'freetds: MS SQL driver'
+ 'mtdev: evdev plugin'
+ 'gtk2: GTK2 plugin'
+ 'bluez-libs: for sdpscanner')
+_tarname="qt-everywhere-opensource-src-${pkgver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/single/${_tarname}.tar.xz")
+md5sums=('5175fba2f221fd4c91e94771a57a5557')
+
+prepare() {
+ cd ${_tarname}
+
+ find . -name '*.py' -exec sed -i \
+ 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
+}
+
+build() {
+ cd ${_tarname}
+
+ PYTHON=/usr/bin/python2 ./configure -confirm-license -opensource \
+ -prefix /opt/qt5.6 \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
+ -optimized-qmake \
+ -openssl-linked \
+ -system-sqlite \
+ -system-pcre \
+ -system-harfbuzz
+ make
+}
+
+package() {
+ cd ${_tarname}
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+}