summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Hovorka2017-02-12 22:03:37 +0100
committerMarkus Hovorka2017-02-12 22:03:37 +0100
commitcfae6f87e1cde02fbe66ca76848a8085363e7194 (patch)
tree390651e4323adf2d986fafab175b4aafdacf3fb8
parent69daadda2eebae6f42d76d47d0c19bf2b4938e00 (diff)
downloadaur-cfae6f87e1cde02fbe66ca76848a8085363e7194.tar.gz
Prevent examples from being built
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD35
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 099c3b0fc7ee..79adee7c1a4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5.6
pkgdesc = A cross-platform application and UI framework
pkgver = 5.6.2
- pkgrel = 1
+ pkgrel = 2
url = http://qt-project.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index fedab261c592..a9a46ede190c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=qt5.6
pkgver=5.6.2
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom')
@@ -31,30 +31,33 @@ source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/singl
md5sums=('5175fba2f221fd4c91e94771a57a5557')
prepare() {
- cd ${_tarname}
+ cd ${_tarname}
- find . -name '*.py' -exec sed -i \
- 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
+ find . -name '*.py' -exec sed -i \
+ 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
}
build() {
- cd ${_tarname}
+ cd ${_tarname}
+ local qt5_src="/opt/qt5.6"
- PYTHON=/usr/bin/python2 ./configure -confirm-license -opensource \
- -prefix /opt/qt5.6 \
+ PYTHON=/usr/bin/python2 ./configure -confirm-license -opensource \
+ -prefix /opt/qt5.6 \
+ -nomake examples \
+ -no-use-gold-linker \
-plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
- -optimized-qmake \
- -openssl-linked \
- -system-sqlite \
- -system-pcre \
- -system-harfbuzz
+ -optimized-qmake \
+ -openssl-linked \
+ -system-sqlite \
+ -system-pcre \
+ -system-harfbuzz
make
}
package() {
- cd ${_tarname}
- make INSTALL_ROOT="${pkgdir}" install
+ cd ${_tarname}
+ make INSTALL_ROOT="${pkgdir}" install
- install -D -m644 LGPL_EXCEPTION.txt \
- "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}