summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2017-05-13 16:20:32 +0200
committerJosip Ponjavic2017-05-13 16:20:32 +0200
commitcceef51d62fe9bb4a5f700eca7cde062db9ea0e3 (patch)
tree608c26ecab4cedfc80ba82abb06ca196be160a81
downloadaur-cceef51d62fe9bb4a5f700eca7cde062db9ea0e3.tar.gz
initial import...
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--qt5ct.install5
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eab9be48f16f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qt5ct-svn
+ pkgdesc = Qt5 Configuration Tool - svn version.
+ pkgver = 0.32.r406
+ pkgrel = 1
+ url = http://qt-apps.org/content/show.php/Qt5+Configuration+Tool?content=168066
+ install = qt5ct.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = qt5-tools
+ makedepends = subversion
+ depends = qt5-svg
+ provides = qt5ct
+ conflicts = qt5ct
+ source = qt5ct::svn://svn.code.sf.net/p/qt5ct/code/trunk/qt5ct
+ md5sums = SKIP
+
+pkgname = qt5ct-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbf49b931440
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+
+pkgname=qt5ct-svn
+pkgver=0.32.r406
+pkgrel=1
+pkgdesc="Qt5 Configuration Tool - svn version."
+arch=('i686' 'x86_64')
+url="http://qt-apps.org/content/show.php/Qt5+Configuration+Tool?content=168066"
+license=('BSD')
+depends=('qt5-svg')
+makedepends=('qt5-tools' 'subversion')
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}")
+install=${pkgname%-*}.install
+source=('qt5ct::svn://svn.code.sf.net/p/qt5ct/code/trunk/qt5ct')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ major=$(grep 'define QT5CT_VERSION_MAJOR' src/qt5ct/qt5ct.h | awk '{print $3}')
+ minor=$(grep 'define QT5CT_VERSION_MINOR' src/qt5ct/qt5ct.h | awk '{print $3}')
+ local ver="$(svnversion)"
+ printf "%s.r%s" "$major"."$minor" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "${pkgname%-*}"
+ qmake-qt5 qt5ct.pro
+ make
+}
+
+package() {
+ cd "${pkgname%-*}"
+ make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/qt5ct.install b/qt5ct.install
new file mode 100644
index 000000000000..a5c26060e095
--- /dev/null
+++ b/qt5ct.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo ""
+ echo "==> Add line 'export QT_QPA_PLATFORMTHEME=qt5ct' to ~/.profile and re-login."
+ echo ""
+}