summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZithia Satazaki2020-09-21 13:43:27 -0400
committerZithia Satazaki2020-09-21 13:43:27 -0400
commit06b1a9f8c0a1e62ad70f612478ba9ace960e95cf (patch)
treefec33a5f16625a9ab1493b0f198aa20952afb3c2
parent9d7ba2397556a2306b593815b5163d5c95bb0465 (diff)
downloadaur-06b1a9f8c0a1e62ad70f612478ba9ace960e95cf.tar.gz
add environment variable check
-rw-r--r--PKGBUILD2
-rw-r--r--translucent.patch22
2 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61719e549ca1..46055a8fe29d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zetaPRIME <qmanxt at gmail dot com>
pkgname=qt5ct-svn-translucent
-pkgver=0.42.r561
+pkgver=1.2.r582
pkgrel=1
pkgdesc="Qt5 Configuration Tool, patched to globally allow translucent window backgrounds."
arch=('i686' 'x86_64')
diff --git a/translucent.patch b/translucent.patch
index 078674da7ccc..cfdadc2ba453 100644
--- a/translucent.patch
+++ b/translucent.patch
@@ -1,14 +1,22 @@
-Index: src/qt5ct-qtplugin/qt5ctplatformtheme.cpp
-===================================================================
---- src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (revision 561)
+--- src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (original)
+++ src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (working copy)
-@@ -77,6 +77,9 @@
+@@ -45,6 +45,7 @@
+ #endif
+ #include <QFile>
+ #include <QFileSystemWatcher>
++#include <QProcessEnvironment>
+
+ #include <qt5ct/qt5ct.h>
+ #include "qt5ctplatformtheme.h"
+@@ -78,6 +79,11 @@
}
qCDebug(lqt5ct) << "using qt5ct plugin";
#ifdef QT_WIDGETS_LIB
-+ QSurfaceFormat f = QSurfaceFormat::defaultFormat();
-+ f.setAlphaBufferSize(8);
-+ QSurfaceFormat::setDefaultFormat(f);
++ if (!QProcessEnvironment::systemEnvironment().contains("QT5CT_NO_TRANSLUCENT")) {
++ QSurfaceFormat f = QSurfaceFormat::defaultFormat();
++ f.setAlphaBufferSize(8);
++ QSurfaceFormat::setDefaultFormat(f);
++ }
if(!QStyleFactory::keys().contains("qt5ct-style"))
qCCritical(lqt5ct) << "unable to find qt5ct proxy style";
#endif