summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzetaPRIME2020-02-17 19:45:07 -0500
committerzetaPRIME2020-02-17 19:45:07 -0500
commit9d7ba2397556a2306b593815b5163d5c95bb0465 (patch)
tree8713015356a36773d27646cbc6825d324e2bda9a
parentb96f5e5084fe7ec8985460529d26ae72915c40b6 (diff)
downloadaur-9d7ba2397556a2306b593815b5163d5c95bb0465.tar.gz
qt5ct-svn-translucent
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
-rw-r--r--translucent.patch14
-rwxr-xr-xupdver.sh4
4 files changed, 41 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7be88b3ab00..15614b1bcb03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = qt5ct-svn
- pkgdesc = Qt5 Configuration Tool - svn version.
- pkgver = 0.37.r508
+pkgbase = qt5ct-svn-translucent
+ pkgdesc = Qt5 Configuration Tool, patched to globally allow translucent window backgrounds.
+ pkgver = 0.42.r561
pkgrel = 1
url = https://sourceforge.net/projects/qt5ct/
install = qt5ct.install
@@ -13,7 +13,9 @@ pkgbase = qt5ct-svn
provides = qt5ct
conflicts = qt5ct
source = qt5ct::svn://svn.code.sf.net/p/qt5ct/code/trunk/qt5ct
+ source = translucent.patch
+ md5sums = SKIP
md5sums = SKIP
-pkgname = qt5ct-svn
+pkgname = qt5ct-svn-translucent
diff --git a/PKGBUILD b/PKGBUILD
index d51a8d1b3d8b..61719e549ca1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,35 @@
-# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Maintainer: zetaPRIME <qmanxt at gmail dot com>
-pkgname=qt5ct-svn
-pkgver=0.37.r508
+pkgname=qt5ct-svn-translucent
+pkgver=0.42.r561
pkgrel=1
-pkgdesc="Qt5 Configuration Tool - svn version."
+pkgdesc="Qt5 Configuration Tool, patched to globally allow translucent window backgrounds."
arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/qt5ct/"
license=('BSD')
depends=('qt5-svg')
makedepends=('qt5-tools' 'subversion')
-conflicts=("${pkgname%-*}")
-provides=("${pkgname%-*}")
-install=${pkgname%-*}.install
-source=('qt5ct::svn://svn.code.sf.net/p/qt5ct/code/trunk/qt5ct')
-md5sums=('SKIP')
+conflicts=("${pkgname%%-*}")
+provides=("${pkgname%%-*}")
+install=${pkgname%%-*}.install
+source=('qt5ct::svn://svn.code.sf.net/p/qt5ct/code/trunk/qt5ct' 'translucent.patch')
+md5sums=('SKIP' 'SKIP')
pkgver() {
- cd "${pkgname%-*}"
+ cd "${pkgname%%-*}"
major=$(grep 'define QT5CT_VERSION_MAJOR' src/qt5ct/qt5ct.h | awk '{print $3}')
minor=$(grep 'define QT5CT_VERSION_MINOR' src/qt5ct/qt5ct.h | awk '{print $3}')
local ver="$(svnversion)"
printf "%s.r%s" "$major"."$minor" "${ver//[[:alpha:]]}"
}
+prepare() {
+ cd "${pkgname%%-*}"
+ patch -Np0 -i "${srcdir}/translucent.patch"
+}
+
build() {
- cd "${pkgname%-*}"
+ cd "${pkgname%%-*}"
qmake-qt5 PREFIX=/usr qt5ct.pro \
QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
@@ -33,7 +38,7 @@ build() {
}
package() {
- cd "${pkgname%-*}"
+ cd "${pkgname%%-*}"
make INSTALL_ROOT="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/translucent.patch b/translucent.patch
new file mode 100644
index 000000000000..078674da7ccc
--- /dev/null
+++ b/translucent.patch
@@ -0,0 +1,14 @@
+Index: src/qt5ct-qtplugin/qt5ctplatformtheme.cpp
+===================================================================
+--- src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (revision 561)
++++ src/qt5ct-qtplugin/qt5ctplatformtheme.cpp (working copy)
+@@ -77,6 +77,9 @@
+ }
+ qCDebug(lqt5ct) << "using qt5ct plugin";
+ #ifdef QT_WIDGETS_LIB
++ QSurfaceFormat f = QSurfaceFormat::defaultFormat();
++ f.setAlphaBufferSize(8);
++ QSurfaceFormat::setDefaultFormat(f);
+ if(!QStyleFactory::keys().contains("qt5ct-style"))
+ qCCritical(lqt5ct) << "unable to find qt5ct proxy style";
+ #endif
diff --git a/updver.sh b/updver.sh
new file mode 100755
index 000000000000..534eaac783f5
--- /dev/null
+++ b/updver.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+makepkg -o
+makepkg --printsrcinfo > .SRCINFO
+