summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2022-06-17 16:38:14 +0200
committerStephan Springer2022-06-17 16:38:14 +0200
commit1cb1b6aac5f2f028f3478b0c60e864328ac7060b (patch)
tree2345752f603921df26d6e093680efffe8bcf6c03
parentd9fead420c0d6d6e72a4ae3717549e3a0a5dd8c5 (diff)
downloadaur-1cb1b6aac5f2f028f3478b0c60e864328ac7060b.tar.gz
update to version 6.3.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c3077cda704..34db5dd39bdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt6-base-headless
pkgdesc = A cross-platform application and UI framework - headless build, no QtGui or QtWidgets
- pkgver = 6.3.0
+ pkgver = 6.3.1
pkgrel = 1
url = https://www.qt.io
arch = x86_64
@@ -28,10 +28,10 @@ pkgbase = qt6-base-headless
provides = qt6-base
conflicts = qt6-base
options = debug
- source = https://download.qt.io/official_releases/qt/6.3/6.3.0/submodules/qtbase-everywhere-src-6.3.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.3/6.3.1/submodules/qtbase-everywhere-src-6.3.1.tar.xz
source = qt6-base-cflags.patch
source = qt6-base-nostrip.patch
- sha256sums = b865aae43357f792b3b0a162899d9bf6a1393a55c4e5e4ede5316b157b1a0f99
+ sha256sums = 0a64421d9c2469c2c48490a032ab91d547017c9cc171f3f8070bc31888f24e03
sha256sums = 5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78
sha256sums = 4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094
diff --git a/PKGBUILD b/PKGBUILD
index 42a54665bdf0..e6e2aed004a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt6-base-headless
-_qtver=6.3.0
+_qtver=6.3.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(x86_64)
@@ -26,7 +26,7 @@ _pkgfn="qtbase-everywhere-src-$_qtver"
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
qt6-base-cflags.patch
qt6-base-nostrip.patch)
-sha256sums=('b865aae43357f792b3b0a162899d9bf6a1393a55c4e5e4ede5316b157b1a0f99'
+sha256sums=('0a64421d9c2469c2c48490a032ab91d547017c9cc171f3f8070bc31888f24e03'
'5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78'
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
@@ -56,7 +56,8 @@ build() {
-DQT_FEATURE_gui=OFF \
-DQT_FEATURE_widgets=OFF \
-DQT_FEATURE_freetype=OFF \
- -DQT_FEATURE_harfbuzz=OFF
+ -DQT_FEATURE_harfbuzz=OFF \
+ -DQT_FEATURE_zstd=OFF
cmake --build build
}