summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2022-09-30 11:45:45 +0200
committerStephan Springer2022-09-30 11:45:45 +0200
commit8e26510ba50b7a90c676bf7b2c151bb20eae5fd4 (patch)
tree8f6917756c3d51886525df89dcf161518326163b
parent5a8e8f7f98fd69b12ece3f4a42bd3d08fbfbd1f6 (diff)
downloadaur-8e26510ba50b7a90c676bf7b2c151bb20eae5fd4.tar.gz
update to version 6.4.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00fee63d4ebf..cdb1b8bac000 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt6-base-headless
pkgdesc = A cross-platform application and UI framework - headless build, no QtGui or QtWidgets
- pkgver = 6.3.2
+ pkgver = 6.4.0
pkgrel = 2
url = https://www.qt.io
arch = x86_64
@@ -28,10 +28,10 @@ pkgbase = qt6-base-headless
provides = qt6-base
conflicts = qt6-base
options = debug
- source = https://download.qt.io/official_releases/qt/6.3/6.3.2/submodules/qtbase-everywhere-src-6.3.2.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.4/6.4.0/submodules/qtbase-everywhere-src-6.4.0.tar.xz
source = qt6-base-cflags.patch
source = qt6-base-nostrip.patch
- sha256sums = 7929ba4df870b6b30870bc0aed2525cfc606ed7091107b23cf7ed7e434caa9a6
+ sha256sums = cb6475a0bd8567c49f7ffbb072a05516ee6671171bed55db75b22b94ead9b37d
sha256sums = 5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78
sha256sums = 4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094
diff --git a/PKGBUILD b/PKGBUILD
index c9f68df7bb97..6fb395c25b3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt6-base-headless
-_qtver=6.3.2
+_qtver=6.4.0
pkgver=${_qtver/-/}
pkgrel=2
arch=(x86_64)
@@ -26,7 +26,7 @@ _pkgfn="qtbase-everywhere-src-$_qtver"
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
qt6-base-cflags.patch
qt6-base-nostrip.patch)
-sha256sums=('7929ba4df870b6b30870bc0aed2525cfc606ed7091107b23cf7ed7e434caa9a6'
+sha256sums=('cb6475a0bd8567c49f7ffbb072a05516ee6671171bed55db75b22b94ead9b37d'
'5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78'
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
@@ -52,6 +52,7 @@ build() {
-DQT_FEATURE_openssl_linked=ON \
-DQT_FEATURE_system_sqlite=ON \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
+ -DCMAKE_MESSAGE_LOG_LEVEL=STATUS \
\
-DQT_FEATURE_gui=OFF \
-DQT_FEATURE_widgets=OFF \
@@ -66,7 +67,7 @@ package() {
optdepends+=('qt6-translations: Translations')
DESTDIR="$pkgdir" cmake --install build
- install -Dm644 $_pkgfn/LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgbase
+ install -Dm644 $_pkgfn/LICENSES/* -t "$pkgdir"/usr/share/licenses/$pkgbase
# Install symlinks for user-facing tools
cd "$pkgdir"