summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-09-21 13:36:58 -0300
committerDaniel Bermond2021-09-21 13:36:58 -0300
commit03fb574fe152fd9c4027034cc51f03bf51754566 (patch)
treec149b22bffa1da6b70b6f767c50589da6334b4ac
parentc551c91895e8907bdb2ddadd2cbcc0ea5fb8794d (diff)
downloadaur-03fb574fe152fd9c4027034cc51f03bf51754566.tar.gz
Fix build when qt5-base is also installed on the system
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2776d475ce26..b699ac5f4dfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt6-jpegxl-image-plugin-git
pkgdesc = Qt6 plug-in to allow Qt6 and KDE based applications to read/write JXL images (git version)
- pkgver = 0.2.0.r0.geb424dd
- pkgrel = 2
+ pkgver = 0.2.0.r8.g67d2eb0
+ pkgrel = 1
url = https://github.com/novomesk/qt-jpegxl-image-plugin/
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 18e564303b6e..0375b1c62186 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=qt6-jpegxl-image-plugin-git
-pkgver=0.2.0.r0.geb424dd
-pkgrel=2
+pkgver=0.2.0.r8.g67d2eb0
+pkgrel=1
pkgdesc='Qt6 plug-in to allow Qt6 and KDE based applications to read/write JXL images (git version)'
arch=('x86_64')
url='https://github.com/novomesk/qt-jpegxl-image-plugin/'
@@ -30,6 +30,7 @@ build() {
cmake -B build -S qt-jpegxl-image-plugin \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DKDE_INSTALL_QTPLUGINDIR:PATH='lib/qt6/plugins' \
-DQT_MAJOR:STRING='6' \
-Wno-dev
make -C build
@@ -42,5 +43,4 @@ check() {
package() {
make -C build DESTDIR="$pkgdir" install
install -d -m755 "${pkgdir}/usr/lib/qt6/plugins/imageformats"
- mv "${pkgdir}/usr/lib/plugins/imageformats"/*.so "${pkgdir}/usr/lib/qt6/plugins/imageformats"
}