summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-09-22 15:13:25 -0300
committerDaniel Bermond2021-09-22 15:13:25 -0300
commit5a9a87080829659fc3ee705ca39829debd8e6db9 (patch)
treec81d7b95128a1482a7d379baf4350f2a37dac2d9
parent21278d28a4875e3f8acc617a791848d71e29709a (diff)
downloadaur-5a9a87080829659fc3ee705ca39829debd8e6db9.tar.gz
Drop the kservices5/qimageioplugins file
It looks like this is not needed since kde frameworks 5 loads qt plugins from /usr/lib/qt/plugins, while this qt6 package installs the plugin to /usr/lib/qt6/plugins. The kservices files are provided on the qt5 package.
-rw-r--r--.SRCINFO4
-rw-r--r--010-qt-jpegxl-image-plugin-add-qt6-support.patch9
-rw-r--r--PKGBUILD5
3 files changed, 5 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b699ac5f4dfd..52009f8dd6d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt6-jpegxl-image-plugin-git
pkgdesc = Qt6 plug-in to allow Qt6 and KDE based applications to read/write JXL images (git version)
pkgver = 0.2.0.r8.g67d2eb0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/novomesk/qt-jpegxl-image-plugin/
arch = x86_64
license = GPL3
@@ -19,6 +19,6 @@ pkgbase = qt6-jpegxl-image-plugin-git
source = git+https://github.com/novomesk/qt-jpegxl-image-plugin.git
source = 010-qt-jpegxl-image-plugin-add-qt6-support.patch
sha256sums = SKIP
- sha256sums = 05d7106ddc07a91ae3dccaa8815cf74fa9aef87c12e2961dfadc1240c5f07790
+ sha256sums = aa8438527c072a26cc33114ecbe32417c39adb270176ba70a9d4a39dca105c82
pkgname = qt6-jpegxl-image-plugin-git
diff --git a/010-qt-jpegxl-image-plugin-add-qt6-support.patch b/010-qt-jpegxl-image-plugin-add-qt6-support.patch
index 2289df0af91a..fd3099473e51 100644
--- a/010-qt-jpegxl-image-plugin-add-qt6-support.patch
+++ b/010-qt-jpegxl-image-plugin-add-qt6-support.patch
@@ -28,12 +28,3 @@
install(TARGETS ${plugin} DESTINATION ${KDE_INSTALL_QTPLUGINDIR}/imageformats)
endfunction()
-@@ -27,7 +27,7 @@ endfunction()
- if (LibJXL_FOUND)
- kimageformats_add_plugin(libqjpegxl JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
- target_link_libraries(libqjpegxl PkgConfig::LibJXL PkgConfig::LibJXLThreads)
-- install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/)
-+ install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/ RENAME jxl_qt${QT_MAJOR}.desktop)
- endif()
-
- ##################################
diff --git a/PKGBUILD b/PKGBUILD
index d056b71ec1f3..fc629a0e2c5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=qt6-jpegxl-image-plugin-git
pkgver=0.2.0.r8.g67d2eb0
-pkgrel=1
+pkgrel=2
pkgdesc='Qt6 plug-in to allow Qt6 and KDE based applications to read/write JXL images (git version)'
arch=('x86_64')
url='https://github.com/novomesk/qt-jpegxl-image-plugin/'
@@ -16,7 +16,7 @@ options=('!emptydirs')
source=('git+https://github.com/novomesk/qt-jpegxl-image-plugin.git'
'010-qt-jpegxl-image-plugin-add-qt6-support.patch')
sha256sums=('SKIP'
- '05d7106ddc07a91ae3dccaa8815cf74fa9aef87c12e2961dfadc1240c5f07790')
+ 'aa8438527c072a26cc33114ecbe32417c39adb270176ba70a9d4a39dca105c82')
prepare() {
patch -d qt-jpegxl-image-plugin -Np1 -i "${srcdir}/010-qt-jpegxl-image-plugin-add-qt6-support.patch"
@@ -42,4 +42,5 @@ check() {
package() {
make -C build DESTDIR="$pkgdir" install
+ rm -r "${pkgdir}/usr/share/kservices5/qimageioplugins"
}