summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-11-25 17:55:24 -0300
committerDaniel Bermond2022-11-25 17:55:24 -0300
commitac504f8c49cbec2e4b6a4be4e053796191f23485 (patch)
tree2b4277049cb3e0a5e856467565fa6f3e8c85855f
parent5a9a87080829659fc3ee705ca39829debd8e6db9 (diff)
downloadaur-ac504f8c49cbec2e4b6a4be4e053796191f23485.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52009f8dd6d1..410187f416b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt6-jpegxl-image-plugin-git
pkgdesc = Qt6 plug-in to allow Qt6 and KDE based applications to read/write JXL images (git version)
- pkgver = 0.2.0.r8.g67d2eb0
- pkgrel = 2
+ pkgver = 0.4.1.r0.g0695db7
+ pkgrel = 1
url = https://github.com/novomesk/qt-jpegxl-image-plugin/
arch = x86_64
license = GPL3
@@ -17,8 +17,6 @@ pkgbase = qt6-jpegxl-image-plugin-git
conflicts = qt6-jpegxl-image-plugin
options = !emptydirs
source = git+https://github.com/novomesk/qt-jpegxl-image-plugin.git
- source = 010-qt-jpegxl-image-plugin-add-qt6-support.patch
sha256sums = SKIP
- sha256sums = aa8438527c072a26cc33114ecbe32417c39adb270176ba70a9d4a39dca105c82
pkgname = qt6-jpegxl-image-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
index fc629a0e2c5d..fbcb433c394e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=qt6-jpegxl-image-plugin-git
-pkgver=0.2.0.r8.g67d2eb0
-pkgrel=2
+pkgver=0.4.1.r0.g0695db7
+pkgrel=1
pkgdesc='Qt6 plug-in to allow Qt6 and KDE based applications to read/write JXL images (git version)'
arch=('x86_64')
url='https://github.com/novomesk/qt-jpegxl-image-plugin/'
@@ -13,14 +13,8 @@ checkdepends=('appstream')
provides=('qt6-jpegxl-image-plugin')
conflicts=('qt6-jpegxl-image-plugin')
options=('!emptydirs')
-source=('git+https://github.com/novomesk/qt-jpegxl-image-plugin.git'
- '010-qt-jpegxl-image-plugin-add-qt6-support.patch')
-sha256sums=('SKIP'
- 'aa8438527c072a26cc33114ecbe32417c39adb270176ba70a9d4a39dca105c82')
-
-prepare() {
- patch -d qt-jpegxl-image-plugin -Np1 -i "${srcdir}/010-qt-jpegxl-image-plugin-add-qt6-support.patch"
-}
+source=('git+https://github.com/novomesk/qt-jpegxl-image-plugin.git')
+sha256sums=('SKIP')
pkgver() {
git -C qt-jpegxl-image-plugin describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
@@ -31,7 +25,8 @@ build() {
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DKDE_INSTALL_QTPLUGINDIR:PATH='lib/qt6/plugins' \
- -DQT_MAJOR:STRING='6' \
+ -DQT_MAJOR_VERSION:STRING='6' \
+ -DCMAKE_SKIP_INSTALL_RPATH:BOOL='YES' \
-Wno-dev
make -C build
}
@@ -42,5 +37,4 @@ check() {
package() {
make -C build DESTDIR="$pkgdir" install
- rm -r "${pkgdir}/usr/share/kservices5/qimageioplugins"
}