summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-08-03 18:53:22 +0000
committerDaniel Bermond2021-08-03 18:54:58 +0000
commitc551c91895e8907bdb2ddadd2cbcc0ea5fb8794d (patch)
treef1cc727b970304fd0cfd753eb44b9f2ca063279e
parentcb38b485b3373063821efbff7ef9ce6d27954724 (diff)
downloadaur-c551c91895e8907bdb2ddadd2cbcc0ea5fb8794d.tar.gz
Fix plugin dir. Update patch.
-rw-r--r--.SRCINFO5
-rw-r--r--010-qt-jpegxl-image-plugin-add-qt6-support.patch13
-rw-r--r--PKGBUILD7
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f71709c21606..2776d475ce26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt6-jpegxl-image-plugin-git
pkgdesc = Qt6 plug-in to allow Qt6 and KDE based applications to read/write JXL images (git version)
pkgver = 0.2.0.r0.geb424dd
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/novomesk/qt-jpegxl-image-plugin/
arch = x86_64
license = GPL3
@@ -15,9 +15,10 @@ pkgbase = qt6-jpegxl-image-plugin-git
depends = qt6-base
provides = qt6-jpegxl-image-plugin
conflicts = qt6-jpegxl-image-plugin
+ options = !emptydirs
source = git+https://github.com/novomesk/qt-jpegxl-image-plugin.git
source = 010-qt-jpegxl-image-plugin-add-qt6-support.patch
sha256sums = SKIP
- sha256sums = 2058af22093781d6d675372fc177090416f667235d49342657c14b403f66271d
+ sha256sums = 05d7106ddc07a91ae3dccaa8815cf74fa9aef87c12e2961dfadc1240c5f07790
pkgname = qt6-jpegxl-image-plugin-git
diff --git a/010-qt-jpegxl-image-plugin-add-qt6-support.patch b/010-qt-jpegxl-image-plugin-add-qt6-support.patch
index 335e3fa9c63d..2289df0af91a 100644
--- a/010-qt-jpegxl-image-plugin-add-qt6-support.patch
+++ b/010-qt-jpegxl-image-plugin-add-qt6-support.patch
@@ -19,7 +19,7 @@
pkg_check_modules(LibJXL REQUIRED IMPORTED_TARGET libjxl>=0.5.0)
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -18,16 +18,16 @@ function(kimageformats_add_plugin plugin)
+@@ -18,7 +18,7 @@ function(kimageformats_add_plugin plugin)
add_library(${plugin} MODULE ${KIF_ADD_PLUGIN_SOURCES})
set_property(TARGET ${plugin} APPEND PROPERTY AUTOGEN_TARGET_DEPENDS ${json})
set_target_properties(${plugin} PROPERTIES LIBRARY_OUTPUT_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/imageformats")
@@ -28,15 +28,12 @@
install(TARGETS ${plugin} DESTINATION ${KDE_INSTALL_QTPLUGINDIR}/imageformats)
endfunction()
- ##################################
-
+@@ -27,7 +27,7 @@ endfunction()
if (LibJXL_FOUND)
-- kimageformats_add_plugin(libqjpegxl JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
-- target_link_libraries(libqjpegxl PkgConfig::LibJXL PkgConfig::LibJXLThreads)
+ kimageformats_add_plugin(libqjpegxl JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
+ target_link_libraries(libqjpegxl PkgConfig::LibJXL PkgConfig::LibJXLThreads)
- install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/)
-+ kimageformats_add_plugin(libqjpegxl-qt${QT_MAJOR} JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
-+ target_link_libraries(libqjpegxl-qt${QT_MAJOR} PkgConfig::LibJXL PkgConfig::LibJXLThreads)
-+ install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/ RENAME jxl-qt${QT_MAJOR}.desktop)
++ install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/ RENAME jxl_qt${QT_MAJOR}.desktop)
endif()
##################################
diff --git a/PKGBUILD b/PKGBUILD
index aaec674c7bdb..18e564303b6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=qt6-jpegxl-image-plugin-git
pkgver=0.2.0.r0.geb424dd
-pkgrel=1
+pkgrel=2
pkgdesc='Qt6 plug-in to allow Qt6 and KDE based applications to read/write JXL images (git version)'
arch=('x86_64')
url='https://github.com/novomesk/qt-jpegxl-image-plugin/'
@@ -12,10 +12,11 @@ makedepends=('git' 'cmake' 'extra-cmake-modules' 'highway' 'vulkan-headers')
checkdepends=('appstream')
provides=('qt6-jpegxl-image-plugin')
conflicts=('qt6-jpegxl-image-plugin')
+options=('!emptydirs')
source=('git+https://github.com/novomesk/qt-jpegxl-image-plugin.git'
'010-qt-jpegxl-image-plugin-add-qt6-support.patch')
sha256sums=('SKIP'
- '2058af22093781d6d675372fc177090416f667235d49342657c14b403f66271d')
+ '05d7106ddc07a91ae3dccaa8815cf74fa9aef87c12e2961dfadc1240c5f07790')
prepare() {
patch -d qt-jpegxl-image-plugin -Np1 -i "${srcdir}/010-qt-jpegxl-image-plugin-add-qt6-support.patch"
@@ -40,4 +41,6 @@ check() {
package() {
make -C build DESTDIR="$pkgdir" install
+ install -d -m755 "${pkgdir}/usr/lib/qt6/plugins/imageformats"
+ mv "${pkgdir}/usr/lib/plugins/imageformats"/*.so "${pkgdir}/usr/lib/qt6/plugins/imageformats"
}