summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-10-06 23:10:58 +0200
committerMartchus2020-10-06 23:10:58 +0200
commit8d35f79575a23d6a5fe998d554aeed0b0f06ca68 (patch)
tree83b9c916ad6d783388ba91a756c6cc41595b4a4d
downloadaur-8d35f79575a23d6a5fe998d554aeed0b0f06ca68.tar.gz
Initial commit for alpha
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--PKGBUILD.sh.ep11
-rw-r--r--qtwayland-sha256.txt1
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..152538f6564d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = qt6-wayland
+ pkgdesc = Provides APIs for Wayland
+ pkgver = 6.0.0alpha
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = x86_64
+ groups = qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = cmake
+ makedepends = vulkan-headers
+ makedepends = ninja
+ depends = qt6-declarative
+ depends = libxcomposite
+ source = https://download.qt.io/development_releases/qt/6.0/6.0.0-alpha/submodules/qtwayland-everywhere-src-6.0.0-alpha.tar.xz
+ sha256sums = cdddc443549b7c90ed062ef4b8f64563e91897464f0be22cb121be5c068bd57d
+
+pkgname = qt6-wayland
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..944036b51c8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=qt6-wayland
+_qtver=6.0.0-alpha
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(x86_64)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Provides APIs for Wayland'
+depends=(qt6-declarative libxcomposite)
+makedepends=(cmake vulkan-headers ninja)
+groups=(qt6)
+_pkgfqn="${pkgname/6-/}-everywhere-src-${_qtver}"
+source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('cdddc443549b7c90ed062ef4b8f64563e91897464f0be22cb121be5c068bd57d')
+
+build() {
+ cmake -G Ninja -B build -S $_pkgfqn
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/qt6-wayland
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..81ec6b90dc8f
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,11 @@
+% layout 'qt6-module';
+\
+_qtver=6.0.0-alpha
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(x86_64)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Provides APIs for Wayland'
+depends=(qt6-declarative libxcomposite)
+makedepends=(cmake vulkan-headers ninja)
diff --git a/qtwayland-sha256.txt b/qtwayland-sha256.txt
new file mode 100644
index 000000000000..0864b11009ba
--- /dev/null
+++ b/qtwayland-sha256.txt
@@ -0,0 +1 @@
+cdddc443549b7c90ed062ef4b8f64563e91897464f0be22cb121be5c068bd57d