summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-08-22 11:45:42 +0200
committerKrzysztof (3ED) AS2015-08-22 11:45:42 +0200
commit6c50b5ee070e8b6297b3e9b66eb2f2bd187d72ef (patch)
treefc37b53f0f7e813b46791de4329b4a2c711ee0cc
downloadaur-6c50b5ee070e8b6297b3e9b66eb2f2bd187d72ef.tar.gz
Init on aur4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--qtads.desktop19
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b859a603d4fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qtads
+ pkgdesc = A Qt-based interpreter for TADS text adventures. Support TADS 2 and 3, both for text-only and multimedia adventures.
+ pkgver = 2.1.6
+ pkgrel = 2
+ url = http://qtads.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = sdl_sound
+ depends = sdl_mixer
+ source = http://downloads.sourceforge.net/sourceforge/qtads/qtads-2.1.6.tar.bz2
+ source = qtads.desktop
+ md5sums = 58ed4a2cb3e9615cbeaca266998b86d4
+ md5sums = 53e37927a65bb80f4af9ba7d40d3f32a
+
+pkgname = qtads
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df6922da390d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: 3ED_0 <krzysztof1987 /at/ gmail.com>
+# Contributor: Rene Wiermer <rwiermer@googlemail.com>
+# Contributor: Eric Forgeot < http://anamnese.online.fr >
+
+pkgname=qtads
+pkgver=2.1.6
+pkgrel=2
+url="http://qtads.sourceforge.net/"
+license=('GPL')
+pkgdesc="A Qt-based interpreter for TADS text adventures. Support TADS 2 and 3, both for text-only and multimedia adventures."
+arch=('i686' 'x86_64')
+depends=('qt5-base' 'sdl_sound' 'sdl_mixer')
+source=(http://downloads.sourceforge.net/sourceforge/qtads/$pkgname-$pkgver.tar.bz2
+ $pkgname.desktop)
+md5sums=('58ed4a2cb3e9615cbeaca266998b86d4'
+ '53e37927a65bb80f4af9ba7d40d3f32a')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ qmake
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ install -D -m755 qtads $pkgdir/usr/bin/qtads
+ #desktop icon
+ install -D -m644 ${pkgname}_48x48.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -D -m644 $startdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+}
diff --git a/qtads.desktop b/qtads.desktop
new file mode 100644
index 000000000000..9f73ad030b4b
--- /dev/null
+++ b/qtads.desktop
@@ -0,0 +1,19 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=QTads
+Name[fr]=QTads
+Name[pl]=QTads
+GenericName=QTads IF interpreter
+GenericName[fr]=QTads Interpréteur de jeux textuels
+GenericName[pl]=QTads fikcja interaktywna
+Comment=A text-only interpreter for TADS text adventures. Support TADS 2 and 3.
+Comment[fr]=Un interpréteur pour les aventures textuelles au format TADS.
+Comment[pl]=Interpretator fikcji interaktywnej. Obsługuje formaty TADS 2 i 3.
+Icon=qtads.png
+Exec=qtads
+Categories=Game;
+Keywords=TADS;Interactive;Fiction;Game;Story;
+Keywords[fr]=TADS;Interactif;Fiction;Jeu;Conte;
+Keywords[pl]=TADS;Interaktywne;Fikcja;Gra;Opowieść;
+