summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:43:39 -0700
committerShadowKyogre2015-06-08 07:43:39 -0700
commit124397790f7b502d5dc232aa4e976182bb7754d1 (patch)
tree5ae9d65ef82b7d65d12fb3622fe612331e7bf958
downloadaur-124397790f7b502d5dc232aa4e976182bb7754d1.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
3 files changed, 51 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a75456d91bdf
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = qtarot-git
+ pkgdesc = A simple tarot reading program
+ pkgver = 0.5.9
+ pkgrel = 1
+ url = http://github.com/ShadowKyogre/QTarot/
+ arch = any
+ license = GPL
+ depends = pyqt
+ depends = python-lxml
+ source = qtarot-git::git://github.com/ShadowKyogre/QTarot.git
+
+pkgname = qtarot-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..847eb0568347
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = qtarot-git
+ pkgdesc = A simple tarot reading program
+ pkgver = 0.5.9
+ pkgrel = 1
+ url = http://github.com/ShadowKyogre/QTarot/
+ arch = any
+ license = GPL
+ depends = pyqt
+ depends = python-lxml
+ source = qtarot-git::git://github.com/ShadowKyogre/QTarot.git
+ md5sums = SKIP
+
+pkgname = qtarot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e253ad0ee162
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Sapphira Armageddos <shadowkyogre@aim.com>
+pkgname=qtarot-git
+pkgver=0.5.9
+pkgrel=1
+pkgdesc="A simple tarot reading program"
+arch='any'
+url="http://github.com/ShadowKyogre/QTarot/"
+license=('GPL')
+depends=('pyqt' 'python-lxml')
+source=("${pkgname}"::"git://github.com/ShadowKyogre/QTarot.git")
+md5sums=(SKIP) #generate with 'makepkg -g'
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package()
+{
+ cd "${srcdir}/${pkgname}"
+ python3 setup.py install --root="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: