summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Barany2019-01-19 01:59:15 -0800
committerAaron Barany2019-01-19 01:59:15 -0800
commit0d9646d4f22909be97256075914fb0c22906697f (patch)
tree3bd26f1d1108dc41d540742bb907de0915ab6eae
parent2885fbc2dc2dc9a11f0d363a1b0e1a2767de72c1 (diff)
downloadaur-0d9646d4f22909be97256075914fb0c22906697f.tar.gz
Updated to QtCreator 4.8.1.
Removed patches that have been merged into the 4.8.1 release. Also cleaned up theme fix patches that have been merged into master into a single patch.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--qtcreator-breakpoint-fix.patch31
-rw-r--r--qtcreator-dark-theme-fixes.patch123
-rw-r--r--qtcreator-exit-debugger-fix.patch81
-rw-r--r--qtcreator-theme-fixes.patch (renamed from qtcreator-dark-and-flat-selection-fixes.patch)221
6 files changed, 168 insertions, 338 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d5e9f034bb6..d6b30e760d5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtcreator-fixed-themes
pkgdesc = Lightweight, cross-platform integrated development environment, with fixes applied for various themes and other bug fixes
- pkgver = 4.8.0
- pkgrel = 11
+ pkgver = 4.8.1
+ pkgrel = 1
url = http://qt-project.org
arch = x86_64
license = LGPL
@@ -28,21 +28,15 @@ pkgbase = qtcreator-fixed-themes
optdepends = valgrind: analyze support
conflicts = qtcreator
options = docs
- source = http://download.qt.io/official_releases/qtcreator/4.8/4.8.0/qt-creator-opensource-src-4.8.0.tar.xz
+ source = http://download.qt.io/official_releases/qtcreator/4.8/4.8.1/qt-creator-opensource-src-4.8.1.tar.xz
source = qtcreator-clang-plugins.patch
- source = qtcreator-dark-theme-fixes.patch
- source = qtcreator-dark-and-flat-selection-fixes.patch
- source = qtcreator-exit-debugger-fix.patch
+ source = qtcreator-theme-fixes.patch
source = qtcreator-occurrences-fix.patch
- source = qtcreator-breakpoint-fix.patch
source = qtcreator-debugger-columns-fix.patch
- sha256sums = aec7b4595e17f5536eb2eef4331057f2d0fa4ba0a46f4968cc06959a1d589b43
+ sha256sums = 8f691de9b30b99dd44e010525ba9bf3054142a1082dc5273c46c533b91c07bd9
sha256sums = 6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6
- sha256sums = 9cd55729e76505ef35fe3059ddbaa86b1071f9f0075b4313f3ccbb8593094681
- sha256sums = 810c956dd8d8c1c0ee364b34f7447f417af5df863cb77fe1a51fd703e6e150e5
- sha256sums = f938a72cc79c9ed8de07da8af79b170f67448a74dbd3228dd3de7e4855ed633d
+ sha256sums = bf0f8e88d0fa628d24f59eaf1f359873926998dde442e3bcbd56afcdd6eec7fa
sha256sums = ba6a48156cc14935a0dea12e8282bdfb1936e0c67216c660eef41bd5b5a44d4b
- sha256sums = 12dad35519cfc62119b0af21b31a96149081ae1ee6d6e7cb65ee80f3774ff06f
sha256sums = cf378a8b591a10646ad89d101375d8b04844c76a83d6c9c960036ba6a3b122e3
pkgname = qtcreator-fixed-themes
diff --git a/PKGBUILD b/PKGBUILD
index aa99fd863247..13a91897ff0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@
# Contributor: delor <bartekpiech gmail com>
pkgname=qtcreator-fixed-themes
-pkgver=4.8.0
+pkgver=4.8.1
_clangver=7.0.1
-pkgrel=11
+pkgrel=1
pkgdesc='Lightweight, cross-platform integrated development environment, with fixes applied for various themes and other bug fixes'
arch=(x86_64)
url='http://qt-project.org'
@@ -33,20 +33,14 @@ optdepends=('qt5-doc: integrated Qt documentation'
'valgrind: analyze support')
source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
qtcreator-clang-plugins.patch
- qtcreator-dark-theme-fixes.patch
- qtcreator-dark-and-flat-selection-fixes.patch
- qtcreator-exit-debugger-fix.patch
- qtcreator-occurrences-fix.patch
- qtcreator-breakpoint-fix.patch
- qtcreator-debugger-columns-fix.patch)
-sha256sums=('aec7b4595e17f5536eb2eef4331057f2d0fa4ba0a46f4968cc06959a1d589b43'
+ qtcreator-theme-fixes.patch
+ qtcreator-occurrences-fix.patch
+ qtcreator-debugger-columns-fix.patch)
+sha256sums=('8f691de9b30b99dd44e010525ba9bf3054142a1082dc5273c46c533b91c07bd9'
'6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6'
- '9cd55729e76505ef35fe3059ddbaa86b1071f9f0075b4313f3ccbb8593094681'
- '810c956dd8d8c1c0ee364b34f7447f417af5df863cb77fe1a51fd703e6e150e5'
- 'f938a72cc79c9ed8de07da8af79b170f67448a74dbd3228dd3de7e4855ed633d'
- 'ba6a48156cc14935a0dea12e8282bdfb1936e0c67216c660eef41bd5b5a44d4b'
- '12dad35519cfc62119b0af21b31a96149081ae1ee6d6e7cb65ee80f3774ff06f'
- 'cf378a8b591a10646ad89d101375d8b04844c76a83d6c9c960036ba6a3b122e3')
+ 'bf0f8e88d0fa628d24f59eaf1f359873926998dde442e3bcbd56afcdd6eec7fa'
+ 'ba6a48156cc14935a0dea12e8282bdfb1936e0c67216c660eef41bd5b5a44d4b'
+ 'cf378a8b591a10646ad89d101375d8b04844c76a83d6c9c960036ba6a3b122e3')
prepare() {
mkdir -p build
@@ -61,14 +55,8 @@ prepare() {
# and https://bugs.archlinux.org/task/59492
patch -p1 -i ../qtcreator-clang-plugins.patch
# Theme fixes
- patch -p1 -i ../qtcreator-dark-theme-fixes.patch
- patch -p1 -i ../qtcreator-dark-and-flat-selection-fixes.patch
+ patch -p1 -i ../qtcreator-theme-fixes.patch
patch -p1 -i ../qtcreator-occurrences-fix.patch
- # Bonus patches!
- # Fix exiting debugger on program exit.
- patch -p1 -i ../qtcreator-exit-debugger-fix.patch
- # Fix infinite looping breakpoints.
- patch -p1 -i ../qtcreator-breakpoint-fix.patch
# Fix broken sizing for debugger columns.
patch -p1 -i ../qtcreator-debugger-columns-fix.patch
}
diff --git a/qtcreator-breakpoint-fix.patch b/qtcreator-breakpoint-fix.patch
deleted file mode 100644
index e0c21d651374..000000000000
--- a/qtcreator-breakpoint-fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/src/plugins/debugger/gdb/gdbengine.cpp b/src/plugins/debugger/gdb/gdbengine.cpp
-index b4d104509e..2ecbf28534 100644
---- a/src/plugins/debugger/gdb/gdbengine.cpp
-+++ b/src/plugins/debugger/gdb/gdbengine.cpp
-@@ -2488,15 +2488,17 @@ void GdbEngine::updateBreakpoint(const Breakpoint &bp)
- QTC_ASSERT(state2 == BreakpointUpdateProceeding, qDebug() << state2);
-
- DebuggerCommand cmd;
-- if (!bp->isPending() && requested.threadSpec != bp->threadSpec()) {
-- // The only way to change this seems to be to re-set the bp completely.
-- cmd.function = "-break-delete " + bpnr;
-- cmd.callback = [this, bp](const DebuggerResponse &r) { handleBreakThreadSpec(r, bp); };
-- } else if (!bp->isPending() && requested.lineNumber != bp->lineNumber()) {
-- // The only way to change this seems to be to re-set the bp completely.
-- cmd.function = "-break-delete " + bpnr;
-- cmd.callback = [this, bp](const DebuggerResponse &r) { handleBreakLineNumber(r, bp); };
-- } else if (requested.command != bp->command()) {
-+ // FIXME: See QTCREATORBUG-21611, QTCREATORBUG-21616
-+// if (!bp->isPending() && requested.threadSpec != bp->threadSpec()) {
-+// // The only way to change this seems to be to re-set the bp completely.
-+// cmd.function = "-break-delete " + bpnr;
-+// cmd.callback = [this, bp](const DebuggerResponse &r) { handleBreakThreadSpec(r, bp); };
-+// } else if (!bp->isPending() && requested.lineNumber != bp->lineNumber()) {
-+// // The only way to change this seems to be to re-set the bp completely.
-+// cmd.function = "-break-delete " + bpnr;
-+// cmd.callback = [this, bp](const DebuggerResponse &r) { handleBreakLineNumber(r, bp); };
-+// } else if
-+ if (requested.command != bp->command()) {
- cmd.function = "-break-commands " + bpnr;
- for (QString command : requested.command.split('\n')) {
- if (!command.isEmpty()) {
diff --git a/qtcreator-dark-theme-fixes.patch b/qtcreator-dark-theme-fixes.patch
deleted file mode 100644
index ead723716b3f..000000000000
--- a/qtcreator-dark-theme-fixes.patch
+++ /dev/null
@@ -1,123 +0,0 @@
-diff --git a/share/qtcreator/themes/dark.creatortheme b/share/qtcreator/themes/dark.creatortheme
-index ef19fc9fa6..5da67fa236 100644
---- a/share/qtcreator/themes/dark.creatortheme
-+++ b/share/qtcreator/themes/dark.creatortheme
-@@ -7,8 +7,10 @@ DefaultTextEditorColorScheme=dark.xml
- shadowBackground=ff232323
- text=ffe7e7e7
- textDisabled=7fffffff
-+textHighlighted=ffe7e7e7
- hoverBackground=18ffffff
- selectedBackground=66000000
-+selectedBackgroundText=aa1f75cc
- normalBackground=ff333333
- alternateBackground=ff515151
- error=ffd84044
-@@ -118,7 +120,7 @@ SplitterColor=splitterColor
- TextColorDisabled=textDisabled
- TextColorError=ffff4040
- TextColorHighlight=ffff0000
--TextColorHighlightBackground=555500
-+TextColorHighlightBackground=7a6f1c
- TextColorLink=textColorLink
- TextColorLinkVisited=textColorLinkVisited
- TextColorNormal=text
-@@ -143,7 +145,7 @@ OutputPanes_TestWarnTextColor=ffc8c800
- OutputPanes_TestFatalTextColor=ffb42828
- OutputPanes_TestDebugTextColor=ff329696
- OutputPaneButtonFlashColor=error
--OutputPaneToggleButtonTextColorChecked=text
-+OutputPaneToggleButtonTextColorChecked=textHighlighted
- OutputPaneToggleButtonTextColorUnchecked=text
-
- Debugger_LogWindow_LogInput=ff00acac
-@@ -204,9 +206,9 @@ PaletteText=text
- PaletteButtonText=text
- PaletteButtonTextDisabled=textDisabled
- PaletteToolTipBase=selectedBackground
--PaletteHighlight=selectedBackground
-+PaletteHighlight=selectedBackgroundText
- PaletteDark=shadowBackground
--PaletteHighlightedText=ffffffff
-+PaletteHighlightedText=textHighlighted
- PaletteToolTipText=text
- PaletteLink=textColorLink
- PaletteLinkVisited=textColorLinkVisited
-diff --git a/share/qtcreator/themes/flat-dark.creatortheme b/share/qtcreator/themes/flat-dark.creatortheme
-index 0c01aa1707..e73d10b0ff 100644
---- a/share/qtcreator/themes/flat-dark.creatortheme
-+++ b/share/qtcreator/themes/flat-dark.creatortheme
-@@ -7,12 +7,14 @@ DefaultTextEditorColorScheme=creator-dark.xml
- shadowBackground=ff404244
- text=ffd0d0d0
- textDisabled=60a4a6a8
-+textHighlighted=fff0f0f0
- toolBarItem=b6fbfdff
- toolBarItemDisabled=60a4a6a8
- fancyBarsNormalTextColor=ffd0d0d0
- fancyBarsBoldTextColor=b6fbfdff
- hoverBackground=22ffffff
- selectedBackground=66000000
-+selectedBackgroundText=ff1d545c
- normalBackground=ff2E2F30
- alternateBackground=ff353637
- error=ffdf4f4f
-@@ -122,7 +124,7 @@ SplitterColor=splitter
- TextColorDisabled=textDisabled
- TextColorError=ffff4040
- TextColorHighlight=ffff0000
--TextColorHighlightBackground=8a7f2c
-+TextColorHighlightBackground=7a6f1c
- TextColorLink=textColorLink
- TextColorLinkVisited=textColorLinkVisited
- TextColorNormal=text
-@@ -147,7 +149,7 @@ OutputPanes_TestWarnTextColor=ffc8c800
- OutputPanes_TestFatalTextColor=ffc82828
- OutputPanes_TestDebugTextColor=ff329696
- OutputPaneButtonFlashColor=error
--OutputPaneToggleButtonTextColorChecked=fancyBarsNormalTextColor
-+OutputPaneToggleButtonTextColorChecked=textHighlighted
- OutputPaneToggleButtonTextColorUnchecked=fancyBarsNormalTextColor
-
- Debugger_LogWindow_LogInput=ff00acac
-@@ -222,9 +224,9 @@ PaletteText=text
- PaletteButtonText=text
- PaletteButtonTextDisabled=textDisabled
- PaletteToolTipBase=selectedBackground
--PaletteHighlight=selectedBackground
-+PaletteHighlight=selectedBackgroundText
- PaletteDark=shadowBackground
--PaletteHighlightedText=ffffffff
-+PaletteHighlightedText=textHighlighted
- PaletteToolTipText=text
- PaletteLink=textColorLink
- PaletteLinkVisited=textColorLinkVisited
-diff --git a/src/plugins/coreplugin/locator/locatorwidget.cpp b/src/plugins/coreplugin/locator/locatorwidget.cpp
-index 7276685d20..2421bd776a 100644
---- a/src/plugins/coreplugin/locator/locatorwidget.cpp
-+++ b/src/plugins/coreplugin/locator/locatorwidget.cpp
-@@ -87,6 +87,7 @@ public:
- LocatorModel(QObject *parent = nullptr)
- : QAbstractListModel(parent)
- , mBackgroundColor(Utils::creatorTheme()->color(Utils::Theme::TextColorHighlightBackground))
-+ , mForegroundColor(Utils::creatorTheme()->color(Utils::Theme::TextColorNormal))
- {}
-
- void clear();
-@@ -100,6 +101,7 @@ private:
- mutable QList<LocatorFilterEntry> mEntries;
- bool hasExtraInfo = false;
- QColor mBackgroundColor;
-+ QColor mForegroundColor;
- };
-
- class CompletionDelegate : public HighlightingItemDelegate
-@@ -224,6 +226,8 @@ QVariant LocatorModel::data(const QModelIndex &index, int role) const
- }
- case int(HighlightingItemRole::Background):
- return mBackgroundColor;
-+ case int(HighlightingItemRole::Foreground):
-+ return mForegroundColor;
- }
-
- return QVariant();
diff --git a/qtcreator-exit-debugger-fix.patch b/qtcreator-exit-debugger-fix.patch
deleted file mode 100644
index 934752aeb308..000000000000
--- a/qtcreator-exit-debugger-fix.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-diff --git a/src/plugins/debugger/debuggerengine.cpp b/src/plugins/debugger/debuggerengine.cpp
-index d8975a82dd..a8ce2e2eee 100644
---- a/src/plugins/debugger/debuggerengine.cpp
-+++ b/src/plugins/debugger/debuggerengine.cpp
-@@ -418,6 +418,8 @@ public:
- m_watchHandler.cleanup();
- m_engine->showMessage(tr("Debugger finished."), StatusBar);
- m_engine->setState(DebuggerFinished); // Also destroys views.
-+ if (boolSetting(SwitchModeOnExit))
-+ EngineManager::deactivateDebugMode();
- }
-
- void scheduleResetLocation()
-diff --git a/src/plugins/debugger/debuggermainwindow.cpp b/src/plugins/debugger/debuggermainwindow.cpp
-index a0602851ea..12371975f8 100644
---- a/src/plugins/debugger/debuggermainwindow.cpp
-+++ b/src/plugins/debugger/debuggermainwindow.cpp
-@@ -26,6 +26,7 @@
- #include "debuggermainwindow.h"
- #include "debuggerconstants.h"
- #include "debuggerinternalconstants.h"
-+#include "enginemanager.h"
-
- #include <coreplugin/actionmanager/actioncontainer.h>
- #include <coreplugin/actionmanager/actionmanager.h>
-@@ -696,7 +697,7 @@ void Perspective::addWindow(QWidget *widget,
-
- void Perspective::select()
- {
-- ModeManager::activateMode(Debugger::Constants::MODE_DEBUG);
-+ Debugger::Internal::EngineManager::activateDebugMode();
- if (Perspective::currentPerspective() == this)
- return;
- theMainWindow->d->selectPerspective(this);
-diff --git a/src/plugins/debugger/debuggerplugin.cpp b/src/plugins/debugger/debuggerplugin.cpp
-index 4c7fb7a84c..c79cecab50 100644
---- a/src/plugins/debugger/debuggerplugin.cpp
-+++ b/src/plugins/debugger/debuggerplugin.cpp
-@@ -706,7 +706,6 @@ public:
- void runScheduled();
- void attachCore();
-
-- void runControlFinished(DebuggerRunTool *runTool);
- void remoteCommand(const QStringList &options);
-
- void dumpLog();
-diff --git a/src/plugins/debugger/enginemanager.cpp b/src/plugins/debugger/enginemanager.cpp
-index a3c503672a..883668e498 100644
---- a/src/plugins/debugger/enginemanager.cpp
-+++ b/src/plugins/debugger/enginemanager.cpp
-@@ -422,6 +422,18 @@ void EngineManager::activateDebugMode()
- }
- }
-
-+void EngineManager::deactivateDebugMode()
-+{
-+ if (ModeManager::currentModeId() == Constants::MODE_DEBUG && d->m_previousMode.isValid()) {
-+ // If stopping the application also makes Qt Creator active (as the
-+ // "previously active application"), doing the switch synchronously
-+ // leads to funny effects with floating dock widgets
-+ const Core::Id mode = d->m_previousMode;
-+ QTimer::singleShot(0, d, [mode]() { ModeManager::activateMode(mode); });
-+ d->m_previousMode = Id();
-+ }
-+}
-+
- bool EngineManager::isLastOf(const QString &type)
- {
- int count = 0;
-diff --git a/src/plugins/debugger/enginemanager.h b/src/plugins/debugger/enginemanager.h
-index a41f13183a..a1ee76c60b 100644
---- a/src/plugins/debugger/enginemanager.h
-+++ b/src/plugins/debugger/enginemanager.h
-@@ -49,6 +49,7 @@ public:
- static void unregisterEngine(DebuggerEngine *engine);
- static void activateEngine(DebuggerEngine *engine);
- static void activateDebugMode();
-+ static void deactivateDebugMode();
- static bool isLastOf(const QString &type);
-
- static QList<QPointer<DebuggerEngine> > engines();
diff --git a/qtcreator-dark-and-flat-selection-fixes.patch b/qtcreator-theme-fixes.patch
index 0bffee5df821..0905939ae89b 100644
--- a/qtcreator-dark-and-flat-selection-fixes.patch
+++ b/qtcreator-theme-fixes.patch
@@ -1,37 +1,59 @@
diff --git a/share/qtcreator/themes/dark.creatortheme b/share/qtcreator/themes/dark.creatortheme
-index 5da67fa236..43130e2630 100644
+index ef19fc9fa6..41439ff22a 100644
--- a/share/qtcreator/themes/dark.creatortheme
+++ b/share/qtcreator/themes/dark.creatortheme
-@@ -9,7 +9,7 @@ text=ffe7e7e7
+@@ -7,8 +7,10 @@ DefaultTextEditorColorScheme=dark.xml
+ shadowBackground=ff232323
+ text=ffe7e7e7
textDisabled=7fffffff
- textHighlighted=ffe7e7e7
++textHighlighted=ffe7e7e7
hoverBackground=18ffffff
-selectedBackground=66000000
+selectedBackground=aa1f75cc
- selectedBackgroundText=aa1f75cc
++selectedBackgroundText=aa1f75cc
normalBackground=ff333333
alternateBackground=ff515151
-@@ -50,9 +50,10 @@ DoubleTabWidget2ndTabInactiveTextColor=textDisabled
+ error=ffd84044
+@@ -48,6 +50,7 @@ DoubleTabWidget2ndTabInactiveTextColor=textDisabled
EditorPlaceholderColor=normalBackground
FancyToolBarSeparatorColor=43ffffff
FancyTabBarBackgroundColor=shadowBackground
+FancyTabBarSelectedBackgroundColor=88000000
FancyTabWidgetDisabledSelectedTextColor=textDisabled
FancyTabWidgetDisabledUnselectedTextColor=textDisabled
--FancyTabWidgetEnabledSelectedTextColor=text
-+FancyTabWidgetEnabledSelectedTextColor=ffffffff
- FancyTabWidgetEnabledUnselectedTextColor=text
- FancyToolButtonHoverColor=35ffffff
- FancyToolButtonSelectedColor=selectedBackground
-@@ -205,7 +206,7 @@ PaletteBrightText=ffff0000
+ FancyTabWidgetEnabledSelectedTextColor=text
+@@ -118,7 +121,7 @@ SplitterColor=splitterColor
+ TextColorDisabled=textDisabled
+ TextColorError=ffff4040
+ TextColorHighlight=ffff0000
+-TextColorHighlightBackground=555500
++TextColorHighlightBackground=7a6f1c
+ TextColorLink=textColorLink
+ TextColorLinkVisited=textColorLinkVisited
+ TextColorNormal=text
+@@ -143,7 +146,7 @@ OutputPanes_TestWarnTextColor=ffc8c800
+ OutputPanes_TestFatalTextColor=ffb42828
+ OutputPanes_TestDebugTextColor=ff329696
+ OutputPaneButtonFlashColor=error
+-OutputPaneToggleButtonTextColorChecked=text
++OutputPaneToggleButtonTextColorChecked=textHighlighted
+ OutputPaneToggleButtonTextColorUnchecked=text
+
+ Debugger_LogWindow_LogInput=ff00acac
+@@ -203,10 +206,10 @@ PaletteBrightText=ffff0000
PaletteText=text
PaletteButtonText=text
PaletteButtonTextDisabled=textDisabled
-PaletteToolTipBase=selectedBackground
+-PaletteHighlight=selectedBackground
+PaletteToolTipBase=66000000
- PaletteHighlight=selectedBackgroundText
++PaletteHighlight=selectedBackgroundText
PaletteDark=shadowBackground
- PaletteHighlightedText=textHighlighted
+-PaletteHighlightedText=ffffffff
++PaletteHighlightedText=textHighlighted
+ PaletteToolTipText=text
+ PaletteLink=textColorLink
+ PaletteLinkVisited=textColorLinkVisited
diff --git a/share/qtcreator/themes/design.creatortheme b/share/qtcreator/themes/design.creatortheme
index 8db109f313..cd90ad49de 100644
--- a/share/qtcreator/themes/design.creatortheme
@@ -73,105 +95,137 @@ index 8db109f313..cd90ad49de 100644
diff --git a/share/qtcreator/themes/flat-dark.creatortheme b/share/qtcreator/themes/flat-dark.creatortheme
-index e73d10b0ff..8e13d541d5 100644
+index 0c01aa1707..e79a96056d 100644
--- a/share/qtcreator/themes/flat-dark.creatortheme
+++ b/share/qtcreator/themes/flat-dark.creatortheme
-@@ -5,6 +5,7 @@ DefaultTextEditorColorScheme=creator-dark.xml
+@@ -4,15 +4,17 @@ PreferredStyles=Fusion
+ DefaultTextEditorColorScheme=creator-dark.xml
[Palette]
- shadowBackground=ff404244
-+darkBackground=66000000
+-shadowBackground=ff404244
++shadowBackground=ff404142
text=ffd0d0d0
textDisabled=60a4a6a8
- textHighlighted=fff0f0f0
-@@ -13,7 +14,7 @@ toolBarItemDisabled=60a4a6a8
+-toolBarItem=b6fbfdff
+-toolBarItemDisabled=60a4a6a8
++textHighlighted=fff0f0f0
++toolBarItem=bcfbfdff
++toolBarItemDisabled=56a5a6a7
fancyBarsNormalTextColor=ffd0d0d0
fancyBarsBoldTextColor=b6fbfdff
- hoverBackground=22ffffff
+-hoverBackground=22ffffff
-selectedBackground=66000000
-+selectedBackground=ff1d545c
- selectedBackgroundText=ff1d545c
++hoverBackground=28ffffff
++selectedBackground=7a000000
++selectedBackgroundText=ff1d545c
normalBackground=ff2E2F30
alternateBackground=ff353637
-@@ -54,9 +55,10 @@ DoubleTabWidget2ndTabInactiveTextColor=text
+ error=ffdf4f4f
+@@ -52,6 +54,7 @@ DoubleTabWidget2ndTabInactiveTextColor=text
EditorPlaceholderColor=normalBackground
FancyToolBarSeparatorColor=toolBarItemDisabled
FancyTabBarBackgroundColor=shadowBackground
-+FancyTabBarSelectedBackgroundColor=darkBackground
++FancyTabBarSelectedBackgroundColor=selectedBackground
FancyTabWidgetDisabledSelectedTextColor=toolBarItemDisabled
FancyTabWidgetDisabledUnselectedTextColor=toolBarItemDisabled
--FancyTabWidgetEnabledSelectedTextColor=fancyBarsBoldTextColor
-+FancyTabWidgetEnabledSelectedTextColor=fancyBarsNormalTextColor
- FancyTabWidgetEnabledUnselectedTextColor=fancyBarsBoldTextColor
- FancyToolButtonHoverColor=hoverBackground
- FancyToolButtonSelectedColor=selectedBackground
-@@ -223,7 +225,7 @@ PaletteBrightText=ffff3333
+ FancyTabWidgetEnabledSelectedTextColor=fancyBarsBoldTextColor
+@@ -122,7 +125,7 @@ SplitterColor=splitter
+ TextColorDisabled=textDisabled
+ TextColorError=ffff4040
+ TextColorHighlight=ffff0000
+-TextColorHighlightBackground=8a7f2c
++TextColorHighlightBackground=7a6f1c
+ TextColorLink=textColorLink
+ TextColorLinkVisited=textColorLinkVisited
+ TextColorNormal=text
+@@ -147,7 +150,7 @@ OutputPanes_TestWarnTextColor=ffc8c800
+ OutputPanes_TestFatalTextColor=ffc82828
+ OutputPanes_TestDebugTextColor=ff329696
+ OutputPaneButtonFlashColor=error
+-OutputPaneToggleButtonTextColorChecked=fancyBarsNormalTextColor
++OutputPaneToggleButtonTextColorChecked=textHighlighted
+ OutputPaneToggleButtonTextColorUnchecked=fancyBarsNormalTextColor
+
+ Debugger_LogWindow_LogInput=ff00acac
+@@ -221,10 +224,10 @@ PaletteBrightText=ffff3333
PaletteText=text
PaletteButtonText=text
PaletteButtonTextDisabled=textDisabled
-PaletteToolTipBase=selectedBackground
+-PaletteHighlight=selectedBackground
+PaletteToolTipBase=darkBackground
- PaletteHighlight=selectedBackgroundText
++PaletteHighlight=selectedBackgroundText
PaletteDark=shadowBackground
- PaletteHighlightedText=textHighlighted
+-PaletteHighlightedText=ffffffff
++PaletteHighlightedText=textHighlighted
+ PaletteToolTipText=text
+ PaletteLink=textColorLink
+ PaletteLinkVisited=textColorLinkVisited
diff --git a/share/qtcreator/themes/flat-light.creatortheme b/share/qtcreator/themes/flat-light.creatortheme
-index 29edca63fd..eae67298dc 100644
+index 29edca63fd..f6b726762c 100644
--- a/share/qtcreator/themes/flat-light.creatortheme
+++ b/share/qtcreator/themes/flat-light.creatortheme
-@@ -4,6 +4,7 @@ PreferredStyles=
-
- [Palette]
- shadowBackground=ffe4e4e4
-+lightBackground=a8ffffff
- text=ff000000
- textDisabled=55000000
- toolBarItem=a0010508
-@@ -11,7 +12,7 @@ toolBarItemDisabled=38000000
- fancyBarsNormalTextColor=ff000000
- fancyBarsBoldTextColor=a0010508
- hoverBackground=1a000000
--selectedBackground=a8ffffff
-+selectedBackground=553daee9
- normalBackground=ffffffff
- alternateBackground=ff515151
- stop_error=ffec7373
-@@ -50,9 +51,10 @@ DoubleTabWidget2ndTabInactiveTextColor=ff000000
+@@ -50,6 +50,7 @@ DoubleTabWidget2ndTabInactiveTextColor=ff000000
EditorPlaceholderColor=fff4f4f4
FancyToolBarSeparatorColor=toolBarItemDisabled
FancyTabBarBackgroundColor=shadowBackground
-+FancyTabBarSelectedBackgroundColor=lightBackground
++FancyTabBarSelectedBackgroundColor=selectedBackground
FancyTabWidgetDisabledSelectedTextColor=toolBarItemDisabled
FancyTabWidgetDisabledUnselectedTextColor=toolBarItemDisabled
--FancyTabWidgetEnabledSelectedTextColor=fancyBarsBoldTextColor
-+FancyTabWidgetEnabledSelectedTextColor=fancyBarsNormalTextColor
- FancyTabWidgetEnabledUnselectedTextColor=fancyBarsBoldTextColor
- FancyToolButtonHoverColor=hoverBackground
- FancyToolButtonSelectedColor=selectedBackground
+ FancyTabWidgetEnabledSelectedTextColor=fancyBarsBoldTextColor
diff --git a/share/qtcreator/themes/flat.creatortheme b/share/qtcreator/themes/flat.creatortheme
-index ab0189528f..91cf2a69cc 100644
+index ab0189528f..0f057d80c0 100644
--- a/share/qtcreator/themes/flat.creatortheme
+++ b/share/qtcreator/themes/flat.creatortheme
-@@ -11,7 +11,7 @@ toolBarItemDisabled=60a4a6a8
+@@ -3,15 +3,15 @@ ThemeName=Flat
+ PreferredStyles=
+
+ [Palette]
+-shadowBackground=ff404244
++shadowBackground=ff404142
+ text=ff000000
+ textDisabled=55000000
+-toolBarItem=b6fbfdff
+-toolBarItemDisabled=60a4a6a8
++toolBarItem=bcfbfdff
++toolBarItemDisabled=56a5a6a7
fancyBarsNormalTextColor=ffffffff
fancyBarsBoldTextColor=b6fbfdff
- hoverBackground=22ffffff
+-hoverBackground=22ffffff
-selectedBackground=66000000
-+selectedBackground=aa3daee9
++hoverBackground=28ffffff
++selectedBackground=7a000000
normalBackground=ffffffff
alternateBackground=ff515151
error=ffdf4f4f
-@@ -48,9 +48,10 @@ DoubleTabWidget2ndTabInactiveTextColor=ff000000
+@@ -48,6 +48,7 @@ DoubleTabWidget2ndTabInactiveTextColor=ff000000
EditorPlaceholderColor=ffdddddd
FancyToolBarSeparatorColor=toolBarItemDisabled
FancyTabBarBackgroundColor=shadowBackground
-+FancyTabBarSelectedBackgroundColor=66000000
++FancyTabBarSelectedBackgroundColor=selectedBackground
FancyTabWidgetDisabledSelectedTextColor=toolBarItemDisabled
FancyTabWidgetDisabledUnselectedTextColor=toolBarItemDisabled
--FancyTabWidgetEnabledSelectedTextColor=fancyBarsBoldTextColor
-+FancyTabWidgetEnabledSelectedTextColor=fancyBarsNormalTextColor
- FancyTabWidgetEnabledUnselectedTextColor=fancyBarsBoldTextColor
- FancyToolButtonHoverColor=hoverBackground
- FancyToolButtonSelectedColor=selectedBackground
+ FancyTabWidgetEnabledSelectedTextColor=fancyBarsBoldTextColor
+diff --git a/src/libs/utils/icon.cpp b/src/libs/utils/icon.cpp
+index dc7625aae3..f7edbd8614 100644
+--- a/src/libs/utils/icon.cpp
++++ b/src/libs/utils/icon.cpp
+@@ -139,13 +139,13 @@ static QPixmap masksToIcon(const MasksAndColors &masks, const QPixmap &combinedM
+ if (style & Icon::DropShadow && creatorTheme()->flag(Theme::ToolBarIconShadow)) {
+ const QPixmap shadowMask = maskToColorAndAlpha(combinedMask, Qt::black);
+ p.setCompositionMode(QPainter::CompositionMode_DestinationOver);
+- p.setOpacity(0.05);
++ p.setOpacity(0.08);
+ p.drawPixmap(QPointF(0, -0.501), shadowMask);
+ p.drawPixmap(QPointF(-0.501, 0), shadowMask);
+ p.drawPixmap(QPointF(0.5, 0), shadowMask);
+ p.drawPixmap(QPointF(0.5, 0.5), shadowMask);
+ p.drawPixmap(QPointF(-0.501, 0.5), shadowMask);
+- p.setOpacity(0.2);
++ p.setOpacity(0.3);
+ p.drawPixmap(0, 1, shadowMask);
+ }
+
diff --git a/src/libs/utils/theme/theme.h b/src/libs/utils/theme/theme.h
index 9a881e9e64..f350bf0ca2 100644
--- a/src/libs/utils/theme/theme.h
@@ -185,7 +239,7 @@ index 9a881e9e64..f350bf0ca2 100644
FancyTabWidgetDisabledUnselectedTextColor,
FancyTabWidgetEnabledSelectedTextColor,
diff --git a/src/plugins/coreplugin/fancytabwidget.cpp b/src/plugins/coreplugin/fancytabwidget.cpp
-index 31ef98704c..eba8f0c203 100644
+index 4fad26bc12..3df5112be2 100644
--- a/src/plugins/coreplugin/fancytabwidget.cpp
+++ b/src/plugins/coreplugin/fancytabwidget.cpp
@@ -288,6 +288,13 @@ static void paintIcon(QPainter *painter, const QRect &rect,
@@ -223,3 +277,32 @@ index 31ef98704c..eba8f0c203 100644
} else {
paintSelectedTabBackground(painter, rect);
}
+diff --git a/src/plugins/coreplugin/locator/locatorwidget.cpp b/src/plugins/coreplugin/locator/locatorwidget.cpp
+index 7276685d20..2421bd776a 100644
+--- a/src/plugins/coreplugin/locator/locatorwidget.cpp
++++ b/src/plugins/coreplugin/locator/locatorwidget.cpp
+@@ -87,6 +87,7 @@ public:
+ LocatorModel(QObject *parent = nullptr)
+ : QAbstractListModel(parent)
+ , mBackgroundColor(Utils::creatorTheme()->color(Utils::Theme::TextColorHighlightBackground))
++ , mForegroundColor(Utils::creatorTheme()->color(Utils::Theme::TextColorNormal))
+ {}
+
+ void clear();
+@@ -100,6 +101,7 @@ private:
+ mutable QList<LocatorFilterEntry> mEntries;
+ bool hasExtraInfo = false;
+ QColor mBackgroundColor;
++ QColor mForegroundColor;
+ };
+
+ class CompletionDelegate : public HighlightingItemDelegate
+@@ -224,6 +226,8 @@ QVariant LocatorModel::data(const QModelIndex &index, int role) const
+ }
+ case int(HighlightingItemRole::Background):
+ return mBackgroundColor;
++ case int(HighlightingItemRole::Foreground):
++ return mForegroundColor;
+ }
+
+ return QVariant();