summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Barany2018-12-07 21:09:10 -0800
committerAaron Barany2018-12-07 21:10:01 -0800
commit1c005b287fa40618b00579b2c7a4e7a56c0a6c82 (patch)
tree297860048b670b2096fb2f5a63d737b5edbb6beb
downloadaur-1c005b287fa40618b00579b2c7a4e7a56c0a6c82.tar.gz
Qt Creator 4.8 with theme fixes applied.
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD76
-rw-r--r--qtcreator-clang-plugins.patch40
-rw-r--r--qtcreator-dark-and-flat-selection-fixes.patch52
-rw-r--r--qtcreator-dark-theme-fixes.patch136
5 files changed, 345 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b967547c1ecd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = qtcreator-fixed-themes
+ pkgdesc = Lightweight, cross-platform integrated development environment, with fixes applied for various themes
+ pkgver = 4.8.0
+ pkgrel = 1
+ url = http://qt-project.org
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = mesa
+ makedepends = llvm
+ makedepends = python
+ depends = qt5-tools
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = qt5-webengine
+ depends = clang=7.0.0
+ depends = qbs
+ depends = clazy
+ optdepends = qt5-doc: integrated Qt documentation
+ optdepends = qt5-examples: welcome page examples
+ optdepends = qt5-translations: for other languages
+ optdepends = gdb: debugger
+ optdepends = cmake: cmake project support
+ optdepends = x11-ssh-askpass: ssh support
+ optdepends = git: git support
+ optdepends = mercurial: mercurial support
+ optdepends = bzr: bazaar support
+ optdepends = valgrind: analyze support
+ conflicts = qtcreator
+ options = docs
+ source = http://download.qt.io/official_releases/qtcreator/4.8/4.8.0/qt-creator-opensource-src-4.8.0.tar.xz
+ source = qtcreator-clang-plugins.patch
+ source = qtcreator-dark-theme-fixes.patch
+ source = qtcreator-dark-and-flat-selection-fixes.patch
+ sha256sums = aec7b4595e17f5536eb2eef4331057f2d0fa4ba0a46f4968cc06959a1d589b43
+ sha256sums = 6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6
+ sha256sums = 9daa35cd105b9b7cf1e3d07daa45aaff509265bf72209a15f4624854582ba186
+ sha256sums = f67ac674c54fc2a05d4a01c46adab8271fe5b0e40cb1cd1772e76810e295a038
+
+pkgname = qtcreator-fixed-themes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f571b839eee1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# AUR with fixes applied:
+# Maintainer: Aaron Barany <akb825@gmail.com>
+# Original:
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Imanol Celaya <ornitorrincos@archlinux-es.org>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Contributor: Dan Vratil <progdan@progdansoft.com>
+# Contributor: thotypous <matiasΘarchlinux-br·org>
+# Contributor: delor <bartekpiech gmail com>
+
+pkgname=qtcreator-fixed-themes
+pkgver=4.8.0
+_clangver=7.0.0
+pkgrel=1
+pkgdesc='Lightweight, cross-platform integrated development environment, with fixes applied for various themes'
+arch=(x86_64)
+url='http://qt-project.org'
+license=(LGPL)
+depends=(qt5-tools qt5-quickcontrols qt5-quickcontrols2 qt5-webengine clang=$_clangver qbs clazy)
+makedepends=(git mesa llvm python)
+conflicts=(qtcreator)
+options=(docs)
+optdepends=('qt5-doc: integrated Qt documentation'
+ 'qt5-examples: welcome page examples'
+ 'qt5-translations: for other languages'
+ 'gdb: debugger'
+ 'cmake: cmake project support'
+ 'x11-ssh-askpass: ssh support'
+ 'git: git support'
+ 'mercurial: mercurial support'
+ 'bzr: bazaar support'
+ 'valgrind: analyze support')
+source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
+ qtcreator-clang-plugins.patch
+ qtcreator-dark-theme-fixes.patch
+ qtcreator-dark-and-flat-selection-fixes.patch)
+sha256sums=('aec7b4595e17f5536eb2eef4331057f2d0fa4ba0a46f4968cc06959a1d589b43'
+ '6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6'
+ '9daa35cd105b9b7cf1e3d07daa45aaff509265bf72209a15f4624854582ba186'
+ 'f67ac674c54fc2a05d4a01c46adab8271fe5b0e40cb1cd1772e76810e295a038')
+
+prepare() {
+ mkdir -p build
+
+ cd qt-creator-opensource-src-$pkgver
+ # fix hardcoded libexec path
+ sed -e 's|libexec\/qtcreator|lib\/qtcreator|g' -i qtcreator.pri
+ # use system qbs
+ rm -r src/shared/qbs
+ # Load analyzer plugins on demand, since upstream clang doesn't link to all plugins
+ # see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
+ # and https://bugs.archlinux.org/task/59492
+ patch -p1 -i ../qtcreator-clang-plugins.patch
+ # Theme fixes
+ patch -p1 -i ../qtcreator-dark-theme-fixes.patch
+ patch -p1 -i ../qtcreator-dark-and-flat-selection-fixes.patch
+}
+
+build() {
+ cd build
+
+ qmake LLVM_INSTALL_DIR=/usr QBS_INSTALL_DIR=/usr CONFIG+=journald QMAKE_CFLAGS_ISYSTEM=-I \
+ DEFINES+=QBS_ENABLE_PROJECT_FILE_UPDATES "$srcdir"/qt-creator-opensource-src-$pkgver/qtcreator.pro
+ make
+ make docs
+}
+
+package() {
+ cd build
+
+ make INSTALL_ROOT="$pkgdir/usr/" install
+ make INSTALL_ROOT="$pkgdir/usr/" install_docs
+
+ install -Dm644 "$srcdir"/qt-creator-opensource-src-$pkgver/LICENSE.GPL3-EXCEPT "$pkgdir"/usr/share/licenses/qtcreator/LICENSE.GPL3-EXCEPT
+}
diff --git a/qtcreator-clang-plugins.patch b/qtcreator-clang-plugins.patch
new file mode 100644
index 000000000000..2585f29dbf5c
--- /dev/null
+++ b/qtcreator-clang-plugins.patch
@@ -0,0 +1,40 @@
+diff --git a/src/plugins/clangcodemodel/clangeditordocumentprocessor.cpp b/src/plugins/clangcodemodel/clangeditordocumentprocessor.cpp
+index 25054f14ec..b0e17c3260 100644
+--- a/src/plugins/clangcodemodel/clangeditordocumentprocessor.cpp
++++ b/src/plugins/clangcodemodel/clangeditordocumentprocessor.cpp
+@@ -524,6 +524,7 @@ private:
+ if (tidyMode == Mode::Disabled)
+ return;
+
++ addXclangArg("-load", "libclangTidyPlugin.so");
+ addXclangArg("-add-plugin", "clang-tidy");
+
+ if (tidyMode == Mode::File)
+@@ -539,6 +540,7 @@ private:
+ if (checks.isEmpty())
+ return;
+
++ addXclangArg("-load", "ClangLazy.so");
+ addXclangArg("-add-plugin", "clang-lazy");
+ addXclangArg("-plugin-arg-clang-lazy", "enable-all-fixits");
+ addXclangArg("-plugin-arg-clang-lazy", "no-autowrite-fixits");
+diff --git a/src/plugins/clangtools/clangtidyclazyrunner.cpp b/src/plugins/clangtools/clangtidyclazyrunner.cpp
+index d91724392e..75e1692f49 100644
+--- a/src/plugins/clangtools/clangtidyclazyrunner.cpp
++++ b/src/plugins/clangtools/clangtidyclazyrunner.cpp
+@@ -83,6 +83,7 @@ QStringList ClangTidyClazyRunner::constructCommandLineArguments(const QStringLis
+
+ const ClangDiagnosticConfig::TidyMode tidyMode = m_diagnosticConfig.clangTidyMode();
+ if (tidyMode != ClangDiagnosticConfig::TidyMode::Disabled) {
++ addXclangArg(arguments, QString("-load"), QString("libclangTidyPlugin.so"));
+ addXclangArg(arguments, QString("-add-plugin"), QString("clang-tidy"));
+ if (tidyMode != ClangDiagnosticConfig::TidyMode::File) {
+ const QString tidyChecks = m_diagnosticConfig.clangTidyChecks();
+@@ -92,6 +93,7 @@ QStringList ClangTidyClazyRunner::constructCommandLineArguments(const QStringLis
+
+ const QString clazyChecks = m_diagnosticConfig.clazyChecks();
+ if (!clazyChecks.isEmpty()) {
++ addXclangArg(arguments, QString("-load"), QString("ClangLazy.so"));
+ addXclangArg(arguments, QString("-add-plugin"), QString("clang-lazy"));
+ addXclangArg(arguments, QString("-plugin-arg-clang-lazy"), QString("enable-all-fixits"));
+ addXclangArg(arguments, QString("-plugin-arg-clang-lazy"), QString("no-autowrite-fixits"));
diff --git a/qtcreator-dark-and-flat-selection-fixes.patch b/qtcreator-dark-and-flat-selection-fixes.patch
new file mode 100644
index 000000000000..2b525228976a
--- /dev/null
+++ b/qtcreator-dark-and-flat-selection-fixes.patch
@@ -0,0 +1,52 @@
+diff --git a/share/qtcreator/themes/dark.creatortheme b/share/qtcreator/themes/dark.creatortheme
+index 57b0849170..5da67fa236 100644
+--- a/share/qtcreator/themes/dark.creatortheme
++++ b/share/qtcreator/themes/dark.creatortheme
+@@ -9,7 +9,7 @@ text=ffe7e7e7
+ textDisabled=7fffffff
+ textHighlighted=ffe7e7e7
+ hoverBackground=18ffffff
+-selectedBackground=aa1f75cc
++selectedBackground=66000000
+ selectedBackgroundText=aa1f75cc
+ normalBackground=ff333333
+ alternateBackground=ff515151
+diff --git a/share/qtcreator/themes/flat-dark.creatortheme b/share/qtcreator/themes/flat-dark.creatortheme
+index 89c54e943f..9c713b4202 100644
+--- a/share/qtcreator/themes/flat-dark.creatortheme
++++ b/share/qtcreator/themes/flat-dark.creatortheme
+@@ -13,7 +13,7 @@ toolBarItemDisabled=60a4a6a8
+ fancyBarsNormalTextColor=ffd0d0d0
+ fancyBarsBoldTextColor=b6fbfdff
+ hoverBackground=22ffffff
+-selectedBackground=aa1f75cc
++selectedBackground=66000000
+ selectedBackgroundText=aa1f75cc
+ normalBackground=ff2E2F30
+ alternateBackground=ff353637
+diff --git a/share/qtcreator/themes/flat-light.creatortheme b/share/qtcreator/themes/flat-light.creatortheme
+index 27fbbb2866..5932ae86dc 100644
+--- a/share/qtcreator/themes/flat-light.creatortheme
++++ b/share/qtcreator/themes/flat-light.creatortheme
+@@ -11,7 +11,7 @@ toolBarItemDisabled=38000000
+ fancyBarsNormalTextColor=ff000000
+ fancyBarsBoldTextColor=a0010508
+ hoverBackground=1a000000
+-selectedBackground=55000000
++selectedBackground=a8ffffff
+ normalBackground=ffffffff
+ alternateBackground=ff515151
+ stop_error=ffec7373
+diff --git a/share/qtcreator/themes/flat.creatortheme b/share/qtcreator/themes/flat.creatortheme
+index 10a60c1aad..ab0189528f 100644
+--- a/share/qtcreator/themes/flat.creatortheme
++++ b/share/qtcreator/themes/flat.creatortheme
+@@ -11,7 +11,7 @@ toolBarItemDisabled=60a4a6a8
+ fancyBarsNormalTextColor=ffffffff
+ fancyBarsBoldTextColor=b6fbfdff
+ hoverBackground=22ffffff
+-selectedBackground=ff1f75cc
++selectedBackground=66000000
+ normalBackground=ffffffff
+ alternateBackground=ff515151
+ error=ffdf4f4f
diff --git a/qtcreator-dark-theme-fixes.patch b/qtcreator-dark-theme-fixes.patch
new file mode 100644
index 000000000000..2e8ea760d15f
--- /dev/null
+++ b/qtcreator-dark-theme-fixes.patch
@@ -0,0 +1,136 @@
+diff --git a/share/qtcreator/themes/dark.creatortheme b/share/qtcreator/themes/dark.creatortheme
+index 5da67fa236..ef19fc9fa6 100644
+--- a/share/qtcreator/themes/dark.creatortheme
++++ b/share/qtcreator/themes/dark.creatortheme
+@@ -7,10 +7,8 @@ DefaultTextEditorColorScheme=dark.xml
+ shadowBackground=ff232323
+ text=ffe7e7e7
+ textDisabled=7fffffff
+-textHighlighted=ffe7e7e7
+ hoverBackground=18ffffff
+ selectedBackground=66000000
+-selectedBackgroundText=aa1f75cc
+ normalBackground=ff333333
+ alternateBackground=ff515151
+ error=ffd84044
+@@ -120,7 +118,7 @@ SplitterColor=splitterColor
+ TextColorDisabled=textDisabled
+ TextColorError=ffff4040
+ TextColorHighlight=ffff0000
+-TextColorHighlightBackground=7a6f1c
++TextColorHighlightBackground=555500
+ TextColorLink=textColorLink
+ TextColorLinkVisited=textColorLinkVisited
+ TextColorNormal=text
+@@ -145,7 +143,7 @@ OutputPanes_TestWarnTextColor=ffc8c800
+ OutputPanes_TestFatalTextColor=ffb42828
+ OutputPanes_TestDebugTextColor=ff329696
+ OutputPaneButtonFlashColor=error
+-OutputPaneToggleButtonTextColorChecked=textHighlighted
++OutputPaneToggleButtonTextColorChecked=text
+ OutputPaneToggleButtonTextColorUnchecked=text
+
+ Debugger_LogWindow_LogInput=ff00acac
+@@ -206,9 +204,9 @@ PaletteText=text
+ PaletteButtonText=text
+ PaletteButtonTextDisabled=textDisabled
+ PaletteToolTipBase=selectedBackground
+-PaletteHighlight=selectedBackgroundText
++PaletteHighlight=selectedBackground
+ PaletteDark=shadowBackground
+-PaletteHighlightedText=textHighlighted
++PaletteHighlightedText=ffffffff
+ PaletteToolTipText=text
+ PaletteLink=textColorLink
+ PaletteLinkVisited=textColorLinkVisited
+diff --git a/share/qtcreator/themes/flat-dark.creatortheme b/share/qtcreator/themes/flat-dark.creatortheme
+index 9c713b4202..0c01aa1707 100644
+--- a/share/qtcreator/themes/flat-dark.creatortheme
++++ b/share/qtcreator/themes/flat-dark.creatortheme
+@@ -7,14 +7,12 @@ DefaultTextEditorColorScheme=creator-dark.xml
+ shadowBackground=ff404244
+ text=ffd0d0d0
+ textDisabled=60a4a6a8
+-textHighlighted=ffd0d0d0
+ toolBarItem=b6fbfdff
+ toolBarItemDisabled=60a4a6a8
+ fancyBarsNormalTextColor=ffd0d0d0
+ fancyBarsBoldTextColor=b6fbfdff
+ hoverBackground=22ffffff
+ selectedBackground=66000000
+-selectedBackgroundText=aa1f75cc
+ normalBackground=ff2E2F30
+ alternateBackground=ff353637
+ error=ffdf4f4f
+@@ -124,7 +122,7 @@ SplitterColor=splitter
+ TextColorDisabled=textDisabled
+ TextColorError=ffff4040
+ TextColorHighlight=ffff0000
+-TextColorHighlightBackground=7a6f1c
++TextColorHighlightBackground=8a7f2c
+ TextColorLink=textColorLink
+ TextColorLinkVisited=textColorLinkVisited
+ TextColorNormal=text
+@@ -149,7 +147,7 @@ OutputPanes_TestWarnTextColor=ffc8c800
+ OutputPanes_TestFatalTextColor=ffc82828
+ OutputPanes_TestDebugTextColor=ff329696
+ OutputPaneButtonFlashColor=error
+-OutputPaneToggleButtonTextColorChecked=textHighlighted
++OutputPaneToggleButtonTextColorChecked=fancyBarsNormalTextColor
+ OutputPaneToggleButtonTextColorUnchecked=fancyBarsNormalTextColor
+
+ Debugger_LogWindow_LogInput=ff00acac
+@@ -224,9 +222,9 @@ PaletteText=text
+ PaletteButtonText=text
+ PaletteButtonTextDisabled=textDisabled
+ PaletteToolTipBase=selectedBackground
+-PaletteHighlight=selectedBackgroundText
++PaletteHighlight=selectedBackground
+ PaletteDark=shadowBackground
+-PaletteHighlightedText=textHighlighted
++PaletteHighlightedText=ffffffff
+ PaletteToolTipText=text
+ PaletteLink=textColorLink
+ PaletteLinkVisited=textColorLinkVisited
+diff --git a/share/qtcreator/themes/flat-light.creatortheme b/share/qtcreator/themes/flat-light.creatortheme
+index 5932ae86dc..29edca63fd 100644
+--- a/share/qtcreator/themes/flat-light.creatortheme
++++ b/share/qtcreator/themes/flat-light.creatortheme
+@@ -145,7 +145,7 @@ OutputPanes_TestWarnTextColor=ffd0bb00
+ OutputPanes_TestFatalTextColor=ff640000
+ OutputPanes_TestDebugTextColor=ff329696
+ OutputPaneButtonFlashColor=ffff0000
+-OutputPaneToggleButtonTextColorChecked=ffffffff
++OutputPaneToggleButtonTextColorChecked=fancyBarsNormalTextColor
+ OutputPaneToggleButtonTextColorUnchecked=fancyBarsNormalTextColor
+
+ Debugger_LogWindow_LogInput=ff00acac
+diff --git a/src/plugins/coreplugin/locator/locatorwidget.cpp b/src/plugins/coreplugin/locator/locatorwidget.cpp
+index 2421bd776a..7276685d20 100644
+--- a/src/plugins/coreplugin/locator/locatorwidget.cpp
++++ b/src/plugins/coreplugin/locator/locatorwidget.cpp
+@@ -87,7 +87,6 @@ public:
+ LocatorModel(QObject *parent = nullptr)
+ : QAbstractListModel(parent)
+ , mBackgroundColor(Utils::creatorTheme()->color(Utils::Theme::TextColorHighlightBackground))
+- , mForegroundColor(Utils::creatorTheme()->color(Utils::Theme::TextColorNormal))
+ {}
+
+ void clear();
+@@ -101,7 +100,6 @@ private:
+ mutable QList<LocatorFilterEntry> mEntries;
+ bool hasExtraInfo = false;
+ QColor mBackgroundColor;
+- QColor mForegroundColor;
+ };
+
+ class CompletionDelegate : public HighlightingItemDelegate
+@@ -226,8 +224,6 @@ QVariant LocatorModel::data(const QModelIndex &index, int role) const
+ }
+ case int(HighlightingItemRole::Background):
+ return mBackgroundColor;
+- case int(HighlightingItemRole::Foreground):
+- return mForegroundColor;
+ }
+
+ return QVariant();