summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Barany2018-12-10 21:23:08 -0800
committerAaron Barany2018-12-10 21:23:08 -0800
commitadd11e0820ba1eeb6ff26625ad30ae5a3eb9b61a (patch)
tree0121141538651e17033f00e2e62086701f1d168e
parent28a766f61b8ac210cf59fe4bc9f193fe11948e72 (diff)
downloadaur-add11e0820ba1eeb6ff26625ad30ae5a3eb9b61a.tar.gz
Added fix for infinite looping breakpoints.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--qtcreator-breakpoint-fix.patch15
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ff4f4ca961f..3a7e13aa0576 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtcreator-fixed-themes
pkgdesc = Lightweight, cross-platform integrated development environment, with fixes applied for various themes
pkgver = 4.8.0
- pkgrel = 2
+ pkgrel = 3
url = http://qt-project.org
arch = x86_64
license = LGPL
@@ -34,12 +34,14 @@ pkgbase = qtcreator-fixed-themes
source = qtcreator-dark-and-flat-selection-fixes.patch
source = qtcreator-exit-debugger-fix.patch
source = qtcreator-occurrences-fix.patch
+ source = qtcreator-breakpoint-fix.patch
sha256sums = aec7b4595e17f5536eb2eef4331057f2d0fa4ba0a46f4968cc06959a1d589b43
sha256sums = 6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6
sha256sums = a7b87219de0ee3e18754749a057535c04357acc2478dcb3fca6bc4b1ba8a8178
sha256sums = 514d9ff2989b0c865ead40b62df79f46871cbc1840ca552c64947b2e6c7d7d18
sha256sums = f938a72cc79c9ed8de07da8af79b170f67448a74dbd3228dd3de7e4855ed633d
sha256sums = ba6a48156cc14935a0dea12e8282bdfb1936e0c67216c660eef41bd5b5a44d4b
+ sha256sums = f934f743f30cd15744cb29642c3f9a1936a16aac6bc6e824c20869879c6df66e
pkgname = qtcreator-fixed-themes
diff --git a/PKGBUILD b/PKGBUILD
index 95f378989fbd..d1d2a1f64ef2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=qtcreator-fixed-themes
pkgver=4.8.0
_clangver=7.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Lightweight, cross-platform integrated development environment, with fixes applied for various themes'
arch=(x86_64)
url='http://qt-project.org'
@@ -36,13 +36,15 @@ source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/
qtcreator-dark-theme-fixes.patch
qtcreator-dark-and-flat-selection-fixes.patch
qtcreator-exit-debugger-fix.patch
- qtcreator-occurrences-fix.patch)
+ qtcreator-occurrences-fix.patch
+ qtcreator-breakpoint-fix.patch)
sha256sums=('aec7b4595e17f5536eb2eef4331057f2d0fa4ba0a46f4968cc06959a1d589b43'
'6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6'
'a7b87219de0ee3e18754749a057535c04357acc2478dcb3fca6bc4b1ba8a8178'
'514d9ff2989b0c865ead40b62df79f46871cbc1840ca552c64947b2e6c7d7d18'
'f938a72cc79c9ed8de07da8af79b170f67448a74dbd3228dd3de7e4855ed633d'
- 'ba6a48156cc14935a0dea12e8282bdfb1936e0c67216c660eef41bd5b5a44d4b')
+ 'ba6a48156cc14935a0dea12e8282bdfb1936e0c67216c660eef41bd5b5a44d4b'
+ 'f934f743f30cd15744cb29642c3f9a1936a16aac6bc6e824c20869879c6df66e')
prepare() {
mkdir -p build
@@ -60,8 +62,11 @@ prepare() {
patch -p1 -i ../qtcreator-dark-theme-fixes.patch
patch -p1 -i ../qtcreator-dark-and-flat-selection-fixes.patch
patch -p1 -i ../qtcreator-occurrences-fix.patch
- # Bonus patch! Fix exiting debugger on program exit.
+ # Bonus patches!
+ # Fix exiting debugger on program exit.
patch -p1 -i ../qtcreator-exit-debugger-fix.patch
+ # Fix infinite looping breakpoints.
+ patch -p1 -i ../qtcreator-breakpoint-fix.patch
}
build() {
diff --git a/qtcreator-breakpoint-fix.patch b/qtcreator-breakpoint-fix.patch
new file mode 100644
index 000000000000..68e856c9a55d
--- /dev/null
+++ b/qtcreator-breakpoint-fix.patch
@@ -0,0 +1,15 @@
+diff --git a/src/plugins/debugger/gdb/gdbengine.cpp b/src/plugins/debugger/gdb/gdbengine.cpp
+index b4d104509e..bc5f5767a7 100644
+--- a/src/plugins/debugger/gdb/gdbengine.cpp
++++ b/src/plugins/debugger/gdb/gdbengine.cpp
+@@ -2492,10 +2492,6 @@ void GdbEngine::updateBreakpoint(const Breakpoint &bp)
+ // The only way to change this seems to be to re-set the bp completely.
+ cmd.function = "-break-delete " + bpnr;
+ cmd.callback = [this, bp](const DebuggerResponse &r) { handleBreakThreadSpec(r, bp); };
+- } else if (!bp->isPending() && requested.lineNumber != bp->lineNumber()) {
+- // The only way to change this seems to be to re-set the bp completely.
+- cmd.function = "-break-delete " + bpnr;
+- cmd.callback = [this, bp](const DebuggerResponse &r) { handleBreakLineNumber(r, bp); };
+ } else if (requested.command != bp->command()) {
+ cmd.function = "-break-commands " + bpnr;
+ for (QString command : requested.command.split('\n')) {