summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Barany2019-01-11 23:26:45 -0800
committerAaron Barany2019-01-11 23:26:45 -0800
commitc2052eccef4ca31172ec3bc8b2400f176900597e (patch)
treed3655fee89156ae9824fc18590249c5dba3d70be
parent86efd2e80d4b8304a2b6e4c45a769162f5ea82ca (diff)
downloadaur-c2052eccef4ca31172ec3bc8b2400f176900597e.tar.gz
Updated selection indicator for mode selector.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--qtcreator-dark-and-flat-selection-fixes.patch24
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce6b835bf82d..b259af9feea5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtcreator-fixed-themes
pkgdesc = Lightweight, cross-platform integrated development environment, with fixes applied for various themes and other bug fixes
pkgver = 4.8.0
- pkgrel = 10
+ pkgrel = 11
url = http://qt-project.org
arch = x86_64
license = LGPL
@@ -39,7 +39,7 @@ pkgbase = qtcreator-fixed-themes
sha256sums = aec7b4595e17f5536eb2eef4331057f2d0fa4ba0a46f4968cc06959a1d589b43
sha256sums = 6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6
sha256sums = 9cd55729e76505ef35fe3059ddbaa86b1071f9f0075b4313f3ccbb8593094681
- sha256sums = 9ed32ab0d52ec981848bb424434e8d28cc34799035bb7471f08407e093cef059
+ sha256sums = a89bbbea66bf9387ae8fee0ca2d38c8e86200080273812bff8a0ab54bd6d14d8
sha256sums = f938a72cc79c9ed8de07da8af79b170f67448a74dbd3228dd3de7e4855ed633d
sha256sums = ba6a48156cc14935a0dea12e8282bdfb1936e0c67216c660eef41bd5b5a44d4b
sha256sums = 12dad35519cfc62119b0af21b31a96149081ae1ee6d6e7cb65ee80f3774ff06f
diff --git a/PKGBUILD b/PKGBUILD
index 107301a5b1fa..75ccda5eadec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=qtcreator-fixed-themes
pkgver=4.8.0
_clangver=7.0.1
-pkgrel=10
+pkgrel=11
pkgdesc='Lightweight, cross-platform integrated development environment, with fixes applied for various themes and other bug fixes'
arch=(x86_64)
url='http://qt-project.org'
@@ -42,7 +42,7 @@ source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/
sha256sums=('aec7b4595e17f5536eb2eef4331057f2d0fa4ba0a46f4968cc06959a1d589b43'
'6f19fc9d83964a5460d224b3d44ce580553847960181fe0364e2ce26e1efd2e6'
'9cd55729e76505ef35fe3059ddbaa86b1071f9f0075b4313f3ccbb8593094681'
- '9ed32ab0d52ec981848bb424434e8d28cc34799035bb7471f08407e093cef059'
+ 'a89bbbea66bf9387ae8fee0ca2d38c8e86200080273812bff8a0ab54bd6d14d8'
'f938a72cc79c9ed8de07da8af79b170f67448a74dbd3228dd3de7e4855ed633d'
'ba6a48156cc14935a0dea12e8282bdfb1936e0c67216c660eef41bd5b5a44d4b'
'12dad35519cfc62119b0af21b31a96149081ae1ee6d6e7cb65ee80f3774ff06f'
diff --git a/qtcreator-dark-and-flat-selection-fixes.patch b/qtcreator-dark-and-flat-selection-fixes.patch
index fd40b7b2b1f2..3c45b53a21b1 100644
--- a/qtcreator-dark-and-flat-selection-fixes.patch
+++ b/qtcreator-dark-and-flat-selection-fixes.patch
@@ -169,21 +169,27 @@ index 9a881e9e64..f350bf0ca2 100644
FancyTabWidgetDisabledUnselectedTextColor,
FancyTabWidgetEnabledSelectedTextColor,
diff --git a/src/plugins/coreplugin/fancytabwidget.cpp b/src/plugins/coreplugin/fancytabwidget.cpp
-index 31ef98704c..677ff22e3a 100644
+index 31ef98704c..1156eeb1d1 100644
--- a/src/plugins/coreplugin/fancytabwidget.cpp
+++ b/src/plugins/coreplugin/fancytabwidget.cpp
-@@ -349,7 +349,13 @@ void FancyTabBar::paintTab(QPainter *painter, int tabIndex) const
+@@ -315,6 +315,11 @@ static void paintIconAndText(QPainter *painter, const QRect &rect,
+ }
+
+ painter->setOpacity(1.0); //FIXME: was 0.7 before?
++ if (selected && creatorTheme()->flag(Theme::FlatToolBars)) {
++ QRect accentRect = rect;
++ accentRect.setWidth(2);
++ painter->fillRect(accentRect, creatorTheme()->color(Theme::IconsBaseColor));
++ }
+ if (enabled) {
+ painter->setPen(
+ selected ? creatorTheme()->color(Theme::FancyTabWidgetEnabledSelectedTextColor)
+@@ -349,7 +354,7 @@ void FancyTabBar::paintTab(QPainter *painter, int tabIndex) const
if (selected) {
if (creatorTheme()->flag(Theme::FlatToolBars)) {
// background color of a fancy tab that is active
- painter->fillRect(rect, creatorTheme()->color(Theme::FancyToolButtonSelectedColor));
-+ int selectedWidth = std::min(5, rect.width());
-+ int selectedBackgroundWidth = rect.width() - selectedWidth;
-+ const QRect selectedRect = QRect(rect.topLeft(), QSize(selectedWidth, rect.height()));
-+ const QRect selectedBackgroundRect = QRect(QPoint(rect.x() + selectedWidth, rect.y()),
-+ QSize(selectedBackgroundWidth, rect.height()));
-+ painter->fillRect(selectedRect, creatorTheme()->color(Theme::FancyToolButtonSelectedColor));
-+ painter->fillRect(selectedBackgroundRect, creatorTheme()->color(Theme::FancyTabBarSelectedBackgroundColor));
++ painter->fillRect(rect, creatorTheme()->color(Theme::FancyTabBarSelectedBackgroundColor));
} else {
paintSelectedTabBackground(painter, rect);
}