summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Barany2019-07-27 16:41:23 -0700
committerAaron Barany2019-07-27 16:42:34 -0700
commitf3f07e0788a5f89727f8fc988656f0abf325c5a4 (patch)
tree5d772bbd27b63255f5e2c43d58643d0e0b0313c0
parentdb4191e8398af97de44d7cb87f0e60cb5e1643c6 (diff)
downloadaur-f3f07e0788a5f89727f8fc988656f0abf325c5a4.tar.gz
Updated to 4.9.2 with latest clang.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
-rw-r--r--qtcreator-mime-database.patch77
3 files changed, 94 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54585768cc42..d793c0ba5640 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtcreator-fixed-themes
pkgdesc = Lightweight, cross-platform integrated development environment, with theme and bug fixes applied
- pkgver = 4.9.1
- pkgrel = 1
+ pkgver = 4.9.2
+ pkgrel = 3
url = https://www.qt.io
arch = x86_64
license = LGPL
@@ -12,7 +12,7 @@ pkgbase = qtcreator-fixed-themes
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
depends = qt5-webengine
- depends = clang=8.0.0
+ depends = clang=8.0.1
depends = qbs
depends = clazy
depends = syntax-highlighting
@@ -27,15 +27,18 @@ pkgbase = qtcreator-fixed-themes
optdepends = mercurial: mercurial support
optdepends = bzr: bazaar support
optdepends = valgrind: analyze support
+ optdepends = perf: performer analyzer
conflicts = qtcreator
options = docs
- source = https://download.qt.io/official_releases/qtcreator/4.9/4.9.1/qt-creator-opensource-src-4.9.1.tar.xz
+ source = https://download.qt.io/official_releases/qtcreator/4.9/4.9.2/qt-creator-opensource-src-4.9.2.tar.xz
source = qtcreator-clazy-1.5.patch
source = qtcreator-preload-plugins.patch
+ source = qtcreator-mime-database.patch
source = qtcreator-debugger-layout.patch
- sha256sums = 79b8228d0871927837681e6af9ab91e3ea28154cecfba317f9c0e56246b8ad81
+ sha256sums = b7e0c797e7704c6c22eb35351946c0a758502fd082f6beaee043166e1739d3d7
sha256sums = 1f6998fea92b9a157f42cca783839ce95f70ccc667027078b7881cbb253838f0
sha256sums = 150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d
+ sha256sums = 8d64b5c28535dcaab910f32e82b04b425253015ca70f379cbe5e9693526a852a
sha256sums = 6000452635f8c8f0cd21d1cc8d484821f4d0f8fc36afa744de5c2a3fdd1a5e9c
pkgname = qtcreator-fixed-themes
diff --git a/PKGBUILD b/PKGBUILD
index 79f9b7428fbe..4190aceba3c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@
# Contributor: delor <bartekpiech gmail com>
pkgname=qtcreator-fixed-themes
-pkgver=4.9.1
-_clangver=8.0.0
-pkgrel=1
+pkgver=4.9.2
+_clangver=8.0.1
+pkgrel=3
pkgdesc='Lightweight, cross-platform integrated development environment, with theme and bug fixes applied'
arch=(x86_64)
url='https://www.qt.io'
@@ -30,14 +30,17 @@ optdepends=('qt5-doc: integrated Qt documentation'
'git: git support'
'mercurial: mercurial support'
'bzr: bazaar support'
- 'valgrind: analyze support')
+ 'valgrind: analyze support'
+ 'perf: performer analyzer')
source=("https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
qtcreator-clazy-1.5.patch
qtcreator-preload-plugins.patch
+ qtcreator-mime-database.patch
qtcreator-debugger-layout.patch)
-sha256sums=('79b8228d0871927837681e6af9ab91e3ea28154cecfba317f9c0e56246b8ad81'
+sha256sums=('b7e0c797e7704c6c22eb35351946c0a758502fd082f6beaee043166e1739d3d7'
'1f6998fea92b9a157f42cca783839ce95f70ccc667027078b7881cbb253838f0'
'150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d'
+ '8d64b5c28535dcaab910f32e82b04b425253015ca70f379cbe5e9693526a852a'
'6000452635f8c8f0cd21d1cc8d484821f4d0f8fc36afa744de5c2a3fdd1a5e9c')
prepare() {
@@ -55,6 +58,7 @@ prepare() {
# see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
# and https://bugs.archlinux.org/task/59492
patch -p1 -i ../qtcreator-preload-plugins.patch
+ patch -p1 -i ../qtcreator-mime-database.patch # Use system shared-mime-info
# Fixes for debugger layout.
patch -p1 -i ../qtcreator-debugger-layout.patch
}
diff --git a/qtcreator-mime-database.patch b/qtcreator-mime-database.patch
new file mode 100644
index 000000000000..65ce334f6d81
--- /dev/null
+++ b/qtcreator-mime-database.patch
@@ -0,0 +1,77 @@
+From e7ef1ad0ba526dd2fc47602e4d45d62adbdbe5db Mon Sep 17 00:00:00 2001
+From: Thiago Macieira <thiago.macieira@intel.com>
+Date: Fri, 28 Jun 2019 22:46:20 -0700
+Subject: [PATCH] Re-fix QtCore resource path changing and prepare for Qt 5.13
+
+Commit 9cf8ab3b3d44ac50a1f8d4893d8f70b8aedb18b0 added the #ifdef, but
+that of course only works if you don't upgrade Qt compared to what Qt
+Creator was compiled with. Instead, attempt both paths and only do that
+if the system copy is not found.
+
+Searching the system copy is required to address Qt 5.13's configure
+option -no-mimetype-database (used by Linux distributions because the
+system copy is always present).
+
+This code will still need work to deal with Qt 5.14 changes.
+
+Task-number: QTCREATORBUG-19600
+Task-number: QTCREATORBUG-22636
+Change-Id: I6aed4df6a12e43c3ac8efffd15ac952a6e9d4770
+---
+
+diff --git a/src/libs/utils/mimetypes/mimeprovider.cpp b/src/libs/utils/mimetypes/mimeprovider.cpp
+index d444aa8..ce94215 100644
+--- a/src/libs/utils/mimetypes/mimeprovider.cpp
++++ b/src/libs/utils/mimetypes/mimeprovider.cpp
+@@ -784,32 +784,25 @@
+ {
+ if (!m_loaded /*|| shouldCheck()*/) {
+ m_loaded = true;
+-// bool fdoXmlFound = false;
+- QStringList allFiles;
++ QStringList allFiles = QStandardPaths::locateAll(QStandardPaths::GenericDataLocation,
++ QStringLiteral("mime/packages/freedesktop.org.xml"),
++ QStandardPaths::LocateFile);
+
+-// const QStringList packageDirs = QStandardPaths::locateAll(QStandardPaths::GenericDataLocation, QLatin1String("mime/packages"), QStandardPaths::LocateDirectory);
+-// //qDebug() << "packageDirs=" << packageDirs;
+-// for (const QString &packageDir : packageDirs) {
+-// QDir dir(packageDir);
+-// const QStringList files = dir.entryList(QDir::Files | QDir::NoDotAndDotDot);
+-// //qDebug() << static_cast<const void *>(this) << packageDir << files;
+-// if (!fdoXmlFound)
+-// fdoXmlFound = files.contains(QLatin1String("freedesktop.org.xml"));
+-// QStringList::const_iterator endIt(files.constEnd());
+-// for (QStringList::const_iterator it(files.constBegin()); it != endIt; ++it) {
+-// allFiles.append(packageDir + QLatin1Char('/') + *it);
+-// }
+-// }
+-
+-// if (!fdoXmlFound) {
+-// // We could instead install the file as part of installing Qt?
+-#if (QT_VERSION >= QT_VERSION_CHECK(5, 11, 0))
+- const char freedesktopOrgXml[] = ":/qt-project.org/qmime/packages/freedesktop.org.xml";
+-#else
+- const char freedesktopOrgXml[] = ":/qt-project.org/qmime/freedesktop.org.xml";
+-#endif
+- allFiles.prepend(QLatin1String(freedesktopOrgXml));
+-// }
++ if (allFiles.isEmpty()) {
++ // System freedsktop.org.xml file not found, try to use the one in QtCore.
++ // This is private API and has changed in the past:
++ // - Qt 5.11 added "package" subdir in 7a5644d6481a3c1a7416772998ca4e60c977bfbd
++ // - Qt 5.13 added an option to not bundle it at all
++ const QString fdoXml5_11 = QStringLiteral(":/qt-project.org/qmime/packages/freedesktop.org.xml");
++ const QString fdoXmlPre5_11 = QStringLiteral(":/qt-project.org/qmime/freedesktop.org.xml");
++ if (QFile::exists(fdoXml5_11))
++ allFiles << fdoXml5_11;
++ else if (QFile::exists(fdoXmlPre5_11))
++ allFiles << fdoXmlPre5_11;
++ else
++ qFatal("Utils::MimeXMLProvider: could not find the system freedesktop.org.xml file "
++ "and QtCore does not have an accessible copy.");
++ }
+
+ m_nameMimeTypeMap.clear();
+ m_aliases.clear();
+