summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Castro2017-10-25 21:13:29 -0500
committerGustavo Castro2017-10-25 21:13:29 -0500
commit9dc77d6b0b50cc52fa0165e0a797c5f59b19a5ab (patch)
tree37155b4d63352609c5810db3d606557e60fdb894
downloadaur-9dc77d6b0b50cc52fa0165e0a797c5f59b19a5ab.tar.gz
Initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29f2266fe821
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qtcreator-markview-plugin-git
+ pkgdesc = QtCreator Tabbed Editor Plugin
+ pkgver = 911587a
+ pkgrel = 1
+ url = https://github.com/OneMoreGres/qtc-markview
+ arch = i686
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = LGPL
+ makedepends = git
+ makedepends = qtcreator-src
+ depends = qtcreator
+ provides = qtcreator-markview-plugin
+ conflicts = qtcreator-markview-plugin
+ source = qtcreator-markview-plugin-git::git://github.com/OneMoreGres/qtc-markview.git
+ md5sums = SKIP
+
+pkgname = qtcreator-markview-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a9142de058b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gustavo Castro < gustawho [ at ] openmailbox [ dot ] org >
+
+_pkgname=qtc-markview
+pkgname=qtcreator-markview-plugin-git
+pkgver=911587a
+pkgrel=1
+pkgdesc="QtCreator Tabbed Editor Plugin"
+groups=('qt' 'qt5')
+arch=('i686' 'x86_64')
+url='https://github.com/OneMoreGres/qtc-markview'
+license=('LGPL')
+depends=('qtcreator')
+makedepends=('git' 'qtcreator-src')
+provides=('qtcreator-markview-plugin')
+conflicts=('qtcreator-markview-plugin')
+source=("$pkgname::git://github.com/OneMoreGres/qtc-markview.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $pkgname
+ # TODO: QTC_BUILD=/usr
+ QTC_SOURCE=/usr/src/qtcreator QTC_BUILD=build/usr qmake LIBS+="-L/usr/lib/qtcreator -L/usr/lib/qtcreator/plugins"
+ make
+}
+
+package() {
+ cd $pkgname
+ cp -r build/* ${pkgdir}
+}