summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrần Nam Tuấn2024-04-10 06:18:51 +0700
committerTrần Nam Tuấn2024-04-10 06:18:51 +0700
commit82125bcb50a0d49f17ce5a56c172f0ea02ecf0ec (patch)
treea1161873dac195d7e3c63d9c9fd8cf29cb227d72
parent5f67db1f162b01cd531e0fa53dca75b580862cfc (diff)
downloadaur-82125bcb50a0d49f17ce5a56c172f0ea02ecf0ec.tar.gz
Revert "Bump version 3.6.0"
This reverts commit 5f67db1f162b01cd531e0fa53dca75b580862cfc.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f75988fb8bd6..814dd7bd7b4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qtcreator-spellchecker-plugin
pkgdesc = Spell Checker plugin for the Qt Creator IDE
- pkgver = 3.6.0
+ pkgver = 3.5.0
pkgrel = 1
url = https://github.com/CJCombrink/SpellChecker-Plugin
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = qtcreator-spellchecker-plugin
makedepends = qtcreator-devel
depends = qtcreator
depends = hunspell
- source = https://github.com/CJCombrink/SpellChecker-Plugin/archive/v3.6.0.tar.gz
- sha256sums = 3887679e5cade0eea876ca413472284cad882e09ec2680fb44d761b92e45df94
+ conflicts = qtcreator-spellchecker-plugin-git
+ conflicts = qtcreator-spellchecker-plugin-bin
+ source = https://github.com/CJCombrink/SpellChecker-Plugin/archive/v3.5.0.tar.gz
+ sha256sums = d780fd90fee09c48c3162cd37e3e0f191bcedfe5805601c1f5728909960d38d3
pkgname = qtcreator-spellchecker-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 71da304ba6ec..7680e9a8e0a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: TheBill2001 <tuantran1632001 at gmail dot com>
pkgname=qtcreator-spellchecker-plugin
-pkgver=3.6.0
+pkgver=3.5.0
pkgrel=1
pkgdesc="Spell Checker plugin for the Qt Creator IDE"
groups=('qt')
@@ -10,16 +10,17 @@ url="https://github.com/CJCombrink/SpellChecker-Plugin"
license=('LGPL3' 'GPL3')
depends=('qtcreator' 'hunspell')
makedepends=('cmake' 'qtcreator-devel')
+conflicts=('qtcreator-spellchecker-plugin-git' 'qtcreator-spellchecker-plugin-bin')
source=("${url}/archive/v$pkgver.tar.gz")
-sha256sums=('3887679e5cade0eea876ca413472284cad882e09ec2680fb44d761b92e45df94')
+sha256sums=('d780fd90fee09c48c3162cd37e3e0f191bcedfe5805601c1f5728909960d38d3')
build() {
cmake \
-S SpellChecker-Plugin-$pkgver\
-B build \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DQT_DIR=/usr/lib/cmake/Qt6
-# -DCMAKE_BUILD_TYPE=Release \
cmake --build build
}