summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrần Nam Tuấn2022-05-24 14:48:28 +0700
committerTrần Nam Tuấn2022-05-24 14:48:28 +0700
commitea45c2a2a19f9b0edb9260e0cbd375f80d76e875 (patch)
treeced43449d0b9df28fabe034305ea4310b9366039
downloadaur-ea45c2a2a19f9b0edb9260e0cbd375f80d76e875.tar.gz
First commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4a6da30a869
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = qtcreator-spellchecker-plugin
+ pkgdesc = Spell Checker plugin for the Qt Creator IDE
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/CJCombrink/SpellChecker-Plugin
+ arch = i686
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ groups = qt6
+ license = LGPL3
+ makedepends = cmake
+ makedepends = qtcreator-devel
+ depends = qtcreator
+ depends = hunspell
+ conflicts = qtcreator-spellchecker-plugin-git
+ conflicts = qtcreator-spellchecker-plugin-bin
+ source = https://github.com/CJCombrink/SpellChecker-Plugin/archive/v3.0.0.tar.gz
+ sha256sums = 42c08467a7111f17e60504154865eb3fae7cfe667618d19f16e753e1fe9826ca
+
+pkgname = qtcreator-spellchecker-plugin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f01022966f45
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b27b8c7308e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: TheBill2001 <tuantran1632001 at gmail dot com>
+
+pkgname=qtcreator-spellchecker-plugin
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Spell Checker plugin for the Qt Creator IDE"
+groups=('qt' 'qt5' 'qt6')
+arch=('i686' 'x86_64')
+url="https://github.com/CJCombrink/SpellChecker-Plugin"
+license=('LGPL3')
+depends=('qtcreator' 'hunspell')
+makedepends=('cmake' 'qtcreator-devel')
+conflicts=('qtcreator-spellchecker-plugin-git' 'qtcreator-spellchecker-plugin-bin')
+source=("${url}/archive/v$pkgver.tar.gz")
+sha256sums=('42c08467a7111f17e60504154865eb3fae7cfe667618d19f16e753e1fe9826ca')
+
+build() {
+ cmake \
+ -G Ninja \
+ -S SpellChecker-Plugin-$pkgver\
+ -B build \
+ -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+package() {
+ install -D "build/lib/qtcreator/plugins/libSpellChecker.so" "${pkgdir}/usr/lib/qtcreator/plugins/libSpellChecker.so"
+}