summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2018-07-04 13:50:22 -0300
committerRodrigo Bezerra2018-07-04 13:50:22 -0300
commit82fdd9cdb6ecd4e62d5161a7d36a8068b2a395a4 (patch)
treeee2af85782cc02e07b7dfe5cf2b8ae654b25c1f3
parentc3569ef01973bba00459515c501c7e465b5f8fe5 (diff)
downloadaur-82fdd9cdb6ecd4e62d5161a7d36a8068b2a395a4.tar.gz
Remove patch. Fixed upstream.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--qregularexpression-fix.patch12
3 files changed, 4 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d029f8c7cb4..6a75b66073c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qtcreator-spellchecker-plugin-git
pkgdesc = Spell Checker plugin for the Qt Creator IDE
- pkgver = r194.0b30298
+ pkgver = r196.cd54877
pkgrel = 1
url = https://github.com/CJCombrink/SpellChecker-Plugin
arch = i686
@@ -13,9 +13,7 @@ pkgbase = qtcreator-spellchecker-plugin-git
depends = qtcreator
depends = hunspell
source = qtcreator-spellchecker-plugin-git::git+https://github.com/CJCombrink/SpellChecker-Plugin.git
- source = qregularexpression-fix.patch
sha256sums = SKIP
- sha256sums = b8c4a6412ae10a38bf43836cbe3c1a2d9c7b66ad3c5f5fcacb4ed29836d4eed9
pkgname = qtcreator-spellchecker-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
index 56e3917eed1e..d94501c70f7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
pkgname=qtcreator-spellchecker-plugin-git
-pkgver=r194.0b30298
+pkgver=r196.cd54877
pkgrel=1
pkgdesc="Spell Checker plugin for the Qt Creator IDE"
groups=('qt' 'qt5')
@@ -10,10 +10,8 @@ url="https://github.com/CJCombrink/SpellChecker-Plugin"
license=('GPL3')
depends=('qtcreator' 'hunspell')
makedepends=('git' 'qtcreator-src')
-source=("$pkgname"::git+https://github.com/CJCombrink/SpellChecker-Plugin.git
- qregularexpression-fix.patch)
-sha256sums=('SKIP'
- 'b8c4a6412ae10a38bf43836cbe3c1a2d9c7b66ad3c5f5fcacb4ed29836d4eed9')
+source=("$pkgname"::git+https://github.com/CJCombrink/SpellChecker-Plugin.git)
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -22,12 +20,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${pkgname}"
-
- patch -Np1 -i "${srcdir}/qregularexpression-fix.patch"
-}
-
build() {
cd "${srcdir}/${pkgname}"
diff --git a/qregularexpression-fix.patch b/qregularexpression-fix.patch
deleted file mode 100644
index cbcbad2529eb..000000000000
--- a/qregularexpression-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/SpellCheckers/HunspellChecker/hunspelloptionswidget.cpp b/SpellCheckers/HunspellChecker/hunspelloptionswidget.cpp
-index 47ef10e..6fd26ef 100644
---- a/SpellCheckers/HunspellChecker/hunspelloptionswidget.cpp
-+++ b/SpellCheckers/HunspellChecker/hunspelloptionswidget.cpp
-@@ -24,6 +24,7 @@
- #include <coreplugin/icore.h>
-
- #include <QFileDialog>
-+#include <QRegularExpression>
-
- using namespace SpellChecker::Checker::Hunspell;
-