summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2018-06-26 13:28:43 -0300
committerRodrigo Bezerra2018-06-26 13:28:43 -0300
commitc3569ef01973bba00459515c501c7e465b5f8fe5 (patch)
treedc81d9c1e463ce07fed4beb2be98cbf140c83978
parentdbc2ce94cfccd9cb45430c5e520aa02b5c7c5440 (diff)
downloadaur-c3569ef01973bba00459515c501c7e465b5f8fe5.tar.gz
Add patch to fix the missing QRegularExpression header
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--qregularexpression-fix.patch12
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c6392753d32..0d029f8c7cb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qtcreator-spellchecker-plugin-git
pkgdesc = Spell Checker plugin for the Qt Creator IDE
- pkgver = r176.e29621c
+ pkgver = r194.0b30298
pkgrel = 1
url = https://github.com/CJCombrink/SpellChecker-Plugin
arch = i686
@@ -13,7 +13,9 @@ pkgbase = qtcreator-spellchecker-plugin-git
depends = qtcreator
depends = hunspell
source = qtcreator-spellchecker-plugin-git::git+https://github.com/CJCombrink/SpellChecker-Plugin.git
+ source = qregularexpression-fix.patch
sha256sums = SKIP
+ sha256sums = b8c4a6412ae10a38bf43836cbe3c1a2d9c7b66ad3c5f5fcacb4ed29836d4eed9
pkgname = qtcreator-spellchecker-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
index ebb75874490c..56e3917eed1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
pkgname=qtcreator-spellchecker-plugin-git
-pkgver=r176.e29621c
+pkgver=r194.0b30298
pkgrel=1
pkgdesc="Spell Checker plugin for the Qt Creator IDE"
groups=('qt' 'qt5')
@@ -10,8 +10,10 @@ url="https://github.com/CJCombrink/SpellChecker-Plugin"
license=('GPL3')
depends=('qtcreator' 'hunspell')
makedepends=('git' 'qtcreator-src')
-source=("$pkgname"::git+https://github.com/CJCombrink/SpellChecker-Plugin.git)
-sha256sums=('SKIP')
+source=("$pkgname"::git+https://github.com/CJCombrink/SpellChecker-Plugin.git
+ qregularexpression-fix.patch)
+sha256sums=('SKIP'
+ 'b8c4a6412ae10a38bf43836cbe3c1a2d9c7b66ad3c5f5fcacb4ed29836d4eed9')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -20,6 +22,12 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ patch -Np1 -i "${srcdir}/qregularexpression-fix.patch"
+}
+
build() {
cd "${srcdir}/${pkgname}"
diff --git a/qregularexpression-fix.patch b/qregularexpression-fix.patch
new file mode 100644
index 000000000000..cbcbad2529eb
--- /dev/null
+++ b/qregularexpression-fix.patch
@@ -0,0 +1,12 @@
+diff --git a/SpellCheckers/HunspellChecker/hunspelloptionswidget.cpp b/SpellCheckers/HunspellChecker/hunspelloptionswidget.cpp
+index 47ef10e..6fd26ef 100644
+--- a/SpellCheckers/HunspellChecker/hunspelloptionswidget.cpp
++++ b/SpellCheckers/HunspellChecker/hunspelloptionswidget.cpp
+@@ -24,6 +24,7 @@
+ #include <coreplugin/icore.h>
+
+ #include <QFileDialog>
++#include <QRegularExpression>
+
+ using namespace SpellChecker::Checker::Hunspell;
+